My::Hash::* reimplementation for separate feature add-on packages (cleanup).
[MyWeb.git] / Hash / Push.pm
similarity index 56%
rename from Hash/Sub/Makefile.am
rename to Hash/Push.pm
index 3ea0c64..4e01cba 100644 (file)
@@ -1,5 +1,5 @@
 # $Id$
-# automake source for the Makefile of My/Hash/Readonly/ subdir
+# Hash tied to optionally dynamically generate its values
 # Copyright (C) 2005 Jan Kratochvil <project-www.jankratochvil.net@jankratochvil.net>
 # 
 # This program is free software; you can redistribute it and/or modify
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
 
 
-include $(top_srcdir)/Makefile-head.am
+package My::Hash::Push;
+our $VERSION=do { my @r=(q$Revision$=~/\d+/g); sprintf "%d.".("%03d"x$#r),@r; };
+our $CVS_ID=q$Id$;
+use strict;
+use warnings;
+use My::Web;   # for &Wrequire
+Wrequire 'My::Hash';
+our @ISA=qw(My::Hash);
+use Carp qw(cluck confess);
 
-EXTRA_DIST+= \
-               Readonly.pm
 
+sub STORE
+{
+my($this,$key,$value)=@_;
+
+       return $this->pass("STORE",$key,$value) if $key!~/_push$/;
+       my $val_orig=$this->pass("FETCH",$key);
+       $val_orig=[] if !defined $val_orig;
+       $val_orig=[$val_orig] if "ARRAY" ne ref $val_orig;
+       return $this->pass("STORE",$key,[@$val_orig,$value]);
+}
+
+1;