Optimizations disabling no longer needed due to explicit STDCALL workaround.
[captive.git] / debian / rules
index 58d0322..a1194fa 100755 (executable)
 # This is the debhelper compatibility version to use.
 export DH_COMPAT=3
 
+# This has to be exported to make some magic below work.
+export DH_OPTIONS
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+OPTFLAGS := -O2
+else
+OPTFLAGS := -O0
+endif
+
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -35,12 +44,9 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
 endif
 
-# FIXME: Use our own CFLAGS to prevent '-mcpu=i686' which up to gcc-20030214 gcc
-# will ignore stack freeing of attribute((stdcall)) callees in caller functions code.
-# Check at the final call of src/libcaptive/reactos/ntoskrnl/io/irp.c/IofCallDriver().
 config.status: configure
        dh_testdir
-       CFLAGS="-O2" ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+       ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
                --enable-shared --disable-static \
                --with-readline \
                --disable-bug-replay \