Initial original import from: fuse-2.4.2-2.fc4
[captive.git] / doc / apiref / Makefile.am
index 86afe0c..df517d7 100644 (file)
@@ -21,31 +21,24 @@ WANT_GTK_DOC=1
 include $(top_srcdir)/Makefile-head.am
 
 
-BUILT_SOURCES+=$(PACKAGE).types
-$(PACKAGE).types:
-       echo >$@
-
-# captive: configuration for $(top_srcdir)/macros/Makefile-gtk-doc.am
+# captive: configuration for gtk-doc.make of gtk-doc
 
 # The name of the module, e.g. 'glib'.
-DOC_MODULE=$(PACKAGE)
+DOC_MODULE=$(PACKAGE)-apiref
 
 # The top-level SGML file. Change it if you want.
-DOC_MAIN_SGML_FILE=$(DOC_MODULE).sgml
+DOC_MAIN_SGML_FILE=$(DOC_MODULE).xml
 
 # The directory containing the source code. Relative to $(srcdir).
 # gtk-doc will search all .c & .h files beneath here for inline comments
 # documenting functions and macros.
 DOC_SOURCE_DIR=$(top_srcdir)/src
 
-# Extra options to pass to gtkdoc-scanobj or gtkdoc-scangobj.
-SCANOBJ_OPTIONS=
-
 # Extra options to supply to gtkdoc-scan.
 SCAN_OPTIONS=
 
 # Extra options to supply to gtkdoc-mkdb.
-MKDB_OPTIONS=
+MKDB_OPTIONS=--sgml-mode --output-format=xml
 
 # Extra options to supply to gtkdoc-fixref.
 FIXXREF_OPTIONS=
@@ -54,32 +47,40 @@ FIXXREF_OPTIONS=
 HFILE_GLOB=
 CFILE_GLOB=
 
-# Header files to ignore when scanning.
+# Header files to ignore when scanning; space-separated list of strings.
 # captive: Ignore $(top_srcdir)/src/libcaptive/include/reactos/
 # captive: Ignore $(top_srcdir)/src/libcaptive/reactos/
-IGNORE_HFILES=reactos
+# captive: Ignore $(top_srcdir)/src/libcaptive/sandbox/sandbox.h
+IGNORE_HFILES=reactos sandbox.h
 
 # Images to copy into HTML directory.
-HTML_IMAGES =
+HTML_IMAGES=
 
 # Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
-content_files =
-
-# Other files to distribute.
-extra_files =
+content_files=
 
 # CFLAGS and LDFLAGS for compiling scan program. Only needed if your app/lib
 # contains GtkObjects/GObjects and you want to document signals and properties.
-GTKDOC_CFLAGS =
-GTKDOC_LIBS =
+GTKDOC_CFLAGS=$(GNOME_VFS_MODULE_CFLAGS) $(GLIB_CFLAGS)
+# of $(top_srcdir)/src/libcaptive/Makefile-libcaptive.am
+GTKDOC_CFLAGS+=-DLIBCAPTIVE
+GTKDOC_CFLAGS+=-I$(top_srcdir)/src/libcaptive/reactos/include
+GTKDOC_CFLAGS+=-I$(top_srcdir)/reactos/include -I$(top_srcdir)/reactos/ntoskrnl/include
+GTKDOC_LIBS=$(captive_library)           $(GLIB_LIBS)
+
+
+EXTRA_DIST+= \
+               gtk-doc.make-captive
+
+include gtk-doc.make-captive
+
 
-GTKDOC_CC=$(LIBTOOL) --mode=compile $(CC)
-GTKDOC_LD=$(LIBTOOL) --mode=link $(CC)
+$(DOC_MODULE)-overrides.txt:
+       touch $@
 
-# If you need to override some of the declarations, place them in the
-# $(DOC_MODULE)-overrides.txt file and uncomment the second line here.
-DOC_OVERRIDES =
-#DOC_OVERRIDES = $(DOC_MODULE)-overrides.txt
+$(DOC_MODULE)-sections.txt:
+       touch $@
 
+# Prevent: No rule to make target `tmpl/*.sgml', needed by `sgml-build.stamp'.  Stop.
+tmpl/*.sgml:
 
-include $(top_srcdir)/macros/Makefile-gtk-doc.am