+FUSE interface skeleton.
[captive.git] / src / client / fuse / Makefile.am
diff --git a/src/client/fuse/Makefile.am b/src/client/fuse/Makefile.am
new file mode 100644 (file)
index 0000000..b0e0b6c
--- /dev/null
@@ -0,0 +1,40 @@
+# $Id$
+# automake source for the fuse module for fuse Makefile 
+# Copyright (C) 2005 Jan Kratochvil <project-captive@jankratochvil.net>
+# 
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; exactly version 2 of June 1991 is required
+# 
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
+
+
+include $(top_srcdir)/Makefile-head.am
+include $(top_srcdir)/src/libcaptive/Makefile-libcaptive.am
+
+mount_captive_SOURCES= \
+               op_statfs.c \
+               op_statfs.h \
+               op_fsync.c \
+               op_fsync.h \
+               op_fsyncdir.c \
+               op_fsyncdir.h \
+               gnomevfsresult.c \
+               gnomevfsresult.h \
+               main.c \
+               main.h
+mount_captive_CFLAGS=                   $(GNOME_VFS_CFLAGS) $(FUSE_CFLAGS)
+mount_captive_LDADD =$(captive_library) $(GNOME_VFS_LIBS)   $(FUSE_LIBS)   $(INTLLIBS)
+mount_captive_LDFLAGS=$(READLINE_LDFLAGS)
+
+if ENABLE_BUG_REPLAY
+mount_captive_cond=mount.captive
+endif
+bin_PROGRAMS+=$(mount_captive_cond)