+Provide mount.captive(8) for "mount -t captive-ntfs ..." invocation syntax.
[captive.git] / src / client / lufs / Makefile.am
index fd9f9a7..5ff308e 100644 (file)
@@ -36,3 +36,21 @@ if HAVE_LUFS_INCLUDES
 liblufs_captivefs_la_cond=liblufs-captivefs.la
 endif
 lib_LTLIBRARIES+=$(liblufs_captivefs_la_cond)
+
+if HAVE_LUFS_INCLUDES
+if WITH_SBIN_MOUNT
+sbin_mount_captive_cond=mount.captive
+install-exec-hook:
+       $(mkinstalldirs) $(DESTDIR)$(with_sbin_mountdir)
+       IFS=:; \
+       with_sbin_mount_fs="$(with_sbin_mount_fs)"; \
+       for fs in $$with_sbin_mount_fs; do \
+               if test $$fs != no; then \
+                       $(RM) $(DESTDIR)$(with_sbin_mountdir)/mount.captive-$$fs; \
+                       $(LN_S) mount.captive $(DESTDIR)$(with_sbin_mountdir)/mount.captive-$$fs; \
+               fi; \
+               done
+
+endif
+endif
+with_sbin_mount_SCRIPTS=$(sbin_mount_captive_cond)