Initial original import from: fuse-2.4.2-2.fc4
[captive.git] / src / libcaptive / client / Makefile.am
index adcc308..55a700a 100644 (file)
 include $(top_srcdir)/Makefile-head.am
 include $(top_srcdir)/src/libcaptive/Makefile-libcaptive.am
 
+if HAVE_GNOME
+standalone_gnome_cond= \
+               standalone-gnome.c \
+               standalone-gnome.h
+endif
+
 noinst_LTLIBRARIES=libclient.la
 libclient_la_SOURCES= \
                directory-parent.c \
@@ -35,44 +41,50 @@ libclient_la_SOURCES= \
                file.h \
                giochannel-blind.c \
                giochannel-blind.h \
+               giochannel-subrange.c \
+               giochannel-subrange.h \
                init.c \
                init.h \
                leave.c \
                lib.c \
                lib.h \
                libxml.c \
-               marshallers.c \
-               marshallers.h \
                options-module.c \
                options.c \
                parent-connector.c \
                parent-connector.h \
                result.c \
                result.h \
+               standalone.c \
+               standalone.h \
                usecount.c \
                vfs-parent.c \
                vfs-parent.h \
                vfs-slave.c \
                vfs-slave.h \
                vfs.c \
-               vfs.h
+               vfs.h \
+               $(MARSHALLERS) \
+               $(standalone_gnome_cond)
 libclient_la_CFLAGS= \
                $(GNOME_VFS_MODULE_CFLAGS) $(OPENSSL_CFLAGS) $(LIBXML_CFLAGS)
 libclient_la_LIBADD= \
                $(GNOME_VFS_MODULE_LIBS)   $(OPENSSL_LIBS)   $(LIBXML_LIBS)
 
 marshallers.h: marshallers.list
-          glib-genmarshal --prefix=captive_client $< --header >$@
+       $(GLIB_GENMARSHAL) --prefix=captive_client $< --header >$@
 
 marshallers.c: marshallers.list
-          glib-genmarshal --prefix=captive_client $< --body >$@
+       $(GLIB_GENMARSHAL) --prefix=captive_client $< --body >$@
 
 EXTRA_DIST+= \
                marshallers.list
-
-CLEANFILES+= \
+MARSHALLERS= \
                marshallers.c \
                marshallers.h
+# 'BUILT_SOURCES' will force its building before any other compilation.
+BUILT_SOURCES+=$(MARSHALLERS)
+CLEANFILES+=$(MARSHALLERS)
 
-# FIXME: Prevent: libtool: link: `libclient_la-parent-connector.lo' is not a valid libtool object
-# dependency: libclient_la-parent-connector.lo: marshallers.h
+EXTRA_DIST +=options.pod.pl.in
+noinst_DATA+=options.pod.pl