Initial original import from: fuse-2.4.2-2.fc4
[captive.git] / src / libcaptive / client / Makefile.am
index cbe6247..55a700a 100644 (file)
@@ -1,6 +1,6 @@
 # $Id$
 # automake source for the client interface of libcaptive Makefile 
-# Copyright (C) 2002 Jan Kratochvil <project-captive@jankratochvil.net>
+# Copyright (C) 2002-2003 Jan Kratochvil <project-captive@jankratochvil.net>
 # 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 include $(top_srcdir)/Makefile-head.am
 include $(top_srcdir)/src/libcaptive/Makefile-libcaptive.am
 
+if HAVE_GNOME
+standalone_gnome_cond= \
+               standalone-gnome.c \
+               standalone-gnome.h
+endif
+
 noinst_LTLIBRARIES=libclient.la
 libclient_la_SOURCES= \
-               init.c \
-               lib.c \
-               lib.h \
+               directory-parent.c \
+               directory-parent.h \
+               directory-slave.c \
+               directory-slave.h \
                directory.c \
+               directory.h \
+               file-parent.c \
+               file-parent.h \
+               file-slave.c \
+               file-slave.h \
                file.c \
+               file.h \
                giochannel-blind.c \
                giochannel-blind.h \
+               giochannel-subrange.c \
+               giochannel-subrange.h \
+               init.c \
+               init.h \
+               leave.c \
+               lib.c \
+               lib.h \
+               libxml.c \
+               options-module.c \
+               options.c \
+               parent-connector.c \
+               parent-connector.h \
                result.c \
-               result.h
+               result.h \
+               standalone.c \
+               standalone.h \
+               usecount.c \
+               vfs-parent.c \
+               vfs-parent.h \
+               vfs-slave.c \
+               vfs-slave.h \
+               vfs.c \
+               vfs.h \
+               $(MARSHALLERS) \
+               $(standalone_gnome_cond)
+libclient_la_CFLAGS= \
+               $(GNOME_VFS_MODULE_CFLAGS) $(OPENSSL_CFLAGS) $(LIBXML_CFLAGS)
+libclient_la_LIBADD= \
+               $(GNOME_VFS_MODULE_LIBS)   $(OPENSSL_LIBS)   $(LIBXML_LIBS)
+
+marshallers.h: marshallers.list
+       $(GLIB_GENMARSHAL) --prefix=captive_client $< --header >$@
+
+marshallers.c: marshallers.list
+       $(GLIB_GENMARSHAL) --prefix=captive_client $< --body >$@
+
+EXTRA_DIST+= \
+               marshallers.list
+MARSHALLERS= \
+               marshallers.c \
+               marshallers.h
+# 'BUILT_SOURCES' will force its building before any other compilation.
+BUILT_SOURCES+=$(MARSHALLERS)
+CLEANFILES+=$(MARSHALLERS)
+
+EXTRA_DIST +=options.pod.pl.in
+noinst_DATA+=options.pod.pl