Integrate static packaing into the CVS HEAD; make it even default.
[captive.git] / src / libcaptive / client / Makefile.am
index ea4f66c..55a700a 100644 (file)
 include $(top_srcdir)/Makefile-head.am
 include $(top_srcdir)/src/libcaptive/Makefile-libcaptive.am
 
+if HAVE_GNOME
+standalone_gnome_cond= \
+               standalone-gnome.c \
+               standalone-gnome.h
+endif
+
 noinst_LTLIBRARIES=libclient.la
 libclient_la_SOURCES= \
                directory-parent.c \
@@ -49,6 +55,8 @@ libclient_la_SOURCES= \
                parent-connector.h \
                result.c \
                result.h \
+               standalone.c \
+               standalone.h \
                usecount.c \
                vfs-parent.c \
                vfs-parent.h \
@@ -56,7 +64,8 @@ libclient_la_SOURCES= \
                vfs-slave.h \
                vfs.c \
                vfs.h \
-               $(MARSHALLERS)
+               $(MARSHALLERS) \
+               $(standalone_gnome_cond)
 libclient_la_CFLAGS= \
                $(GNOME_VFS_MODULE_CFLAGS) $(OPENSSL_CFLAGS) $(LIBXML_CFLAGS)
 libclient_la_LIBADD= \