(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
1 %global fast 0
2 %global use_jankratochvil_dwz 1
3 %global use_jankratochvil_rust 0
4 %global pkg_prefix /opt/%{name}
5 %global _unpackaged_files_terminate_build 0
6 # dwz: Couldn't find DIE referenced by DW_OP_GNU_parameter_ref
7 %global _find_debuginfo_dwz_opts %{nil}
8 # *** ERROR: ambiguous python shebang in /opt/lldb-experimental/...: #!/usr/bin/env python. Change it to python3 (or python2) explicitly.
9 %global __brp_mangle_shebangs %{nil}
10 %if %{fast}
11 %global debug_package %{nil}
12 %endif
13 Name: lldb-experimental
14 Version: 10.0.0
15 Release: 0.20190817snap2%{?dist}
16 Summary: Next generation high-performance debugger - experimental trunk snapshot
17 License: NCSA
18 URL: http://lldb.llvm.org/
19 ExclusiveArch: x86_64
20 BuildRequires: gcc-c++ git libedit-devel swig libatomic ninja-build libxml2-devel zlib-devel valgrind-devel libpfm-devel epydoc
21 %if 0%{?rhel:1} && 0%{?rhel} <= 7
22 BuildRequires: llvm-toolset-7-cmake devtoolset-8-gcc-c++ python-devel python2-pyyaml
23 # https://bugzilla.redhat.com/show_bug.cgi?id=1511892
24 %global __cmake /opt/rh/llvm-toolset-7/root/usr/bin/cmake3
25 %global ninjabuild ninja-build
26 %else
27 BuildRequires: cmake z3-devel
28 BuildRequires: python3-devel python3-pygments python3-pyyaml
29 # removed in F31+
30 #BuildRequires: xar-devel
31 %global ninjabuild ninja
32 %endif
33
34 %description
35 LLDB is a next generation, high-performance debugger. It is built as a set
36 of reusable components which highly leverage existing libraries in the
37 larger LLVM Project, such as the Clang expression parser and LLVM
38 disassembler.
39 This package is an experimental trunk snapshot.
40 %if %{use_jankratochvil_dwz}
41 This package contains off-trunk DWZ support for Fedora debuginfos such as:
42   unsupported DW_FORM values: 0x1f20 0x1f21
43 %endif
44 %if %{use_jankratochvil_rust}
45 This package contains off-trunk Rust support:
46   https://github.com/rust-lang-nursery/lldb
47 %endif
48
49 %package devel
50 Summary: Development header files for %{name}
51 Requires: %{name}%{?_isa} = %{version}-%{release}
52
53 %description devel
54 The package contains header files for %{name}.
55
56 {-L,"-Wl,-rpath,"}%{pkg_prefix}/%{_lib} -I%{pkg_prefix}/include -llldb -lLLVMSupport -ltinfo -pthread
57
58 %ldconfig_scriptlets
59
60 %prep
61 %setup -q -c -T
62 git clone --depth 1 --no-tags --single-branch --reference-if-able reference https://github.com/llvm/llvm-project.git .
63 %if %{use_jankratochvil_dwz} || %{use_jankratochvil_rust}
64 git remote remove jankratochvil || :
65 git remote add jankratochvil git://git.jankratochvil.net/lldb
66 git fetch jankratochvil
67 git config user.email jankratochvil@copr.fedorainfracloud.org
68 git config user.name jankratochvil
69 %endif
70 %if %{use_jankratochvil_dwz}
71 git merge jankratochvil/dwz
72 %endif
73 %if %{use_jankratochvil_rust}
74 # '-c merge.renames=false' is F-29+.
75 # '-c merge.renameLimit=0' has no effect.
76 git -c merge.renameLimit=1 merge jankratochvil/rust
77 %endif
78
79 %build
80 mkdir build-release
81 cd    build-release
82
83 FLAGS="%{optflags}"
84
85 # lldb/scripts/LLDBWrapPython.cpp:23699:70: error: format not a string literal and no format arguments [-Werror=format-security]
86 FLAGS="$FLAGS -Wno-error=format-security"
87
88 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
89 . /opt/rh/devtoolset-8/enable
90 # -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
91 # https://bugzilla.redhat.com/show_bug.cgi?id=1590678
92 # Set %%{fast} only after %%debug_package above.
93 %global fast 1
94 %endif
95 %if %{fast}
96 FLAGS="$FLAGS -g0"
97 %else
98 # -fno-reorder-blocks-and-partition:
99 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
100 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
101 FLAGS="$FLAGS -gsplit-dwarf -fno-reorder-blocks-and-partition"
102 %endif
103
104 CFLAGS="$FLAGS"
105 CXXFLAGS="$FLAGS"
106
107 # This is default - changing it breaks the testsuite: -DLLVM_LINK_LLVM_DYLIB=OFF
108 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental
109 # -fdebug-types-section && -DLLVM_USE_LINKER=gold:
110 # ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
111 %cmake ../llvm \
112   -GNinja \
113   -DCMAKE_INSTALL_PREFIX=%{buildroot}%{pkg_prefix} \
114   -DBUILD_SHARED_LIBS=OFF \
115 %if %{fast}
116   -DCMAKE_BUILD_TYPE=Release \
117 %else
118   -DCMAKE_BUILD_TYPE=RelWithDebInfo \
119 %endif
120   -DLLVM_ENABLE_PROJECTS="lldb;clang;lld" \
121   -DLLVM_TARGETS_TO_BUILD=X86 \
122   -DLLVM_BUILD_TOOLS=OFF \
123   -DLLVM_USE_LINKER=gold \
124   $(: file INSTALL cannot find build-release/lib/python3.6 ) \
125 %if 0%{?__isa_bits} == 64
126   -DLLVM_LIBDIR_SUFFIX=64 \
127 %else
128   -DLLVM_LIBDIR_SUFFIX= \
129 %endif
130   -DLLDB_DISABLE_CURSES=OFF \
131   -DLLDB_DISABLE_LIBEDIT=OFF \
132   -DLLDB_DISABLE_PYTHON=OFF \
133   #
134 %{ninjabuild} -v
135
136 %install
137 mkdir -p %{buildroot}%{pkg_prefix}
138 (function revline {
139    echo "$(cd $1;git rev-parse ${2:-origin/master}) ${2:-$1}"
140  }
141  revline .
142 %if %{use_jankratochvil_dwz}
143  revline . jankratochvil/dwz
144 %endif
145 %if %{use_jankratochvil_rust}
146  revline . jankratochvil/rust
147 %endif
148 ) >%{buildroot}%{pkg_prefix}/HEAD
149 cd build-release
150 %{ninjabuild} -v install
151 mkdir -p %{buildroot}%{_bindir}
152 # lldb-mi
153 for i in lldb;do
154   echo >%{buildroot}%{_bindir}/${i}-experimental -e '#! /bin/bash\nexec %{pkg_prefix}/bin/'$i' "$@"'
155   chmod +x %{buildroot}%{_bindir}/${i}-experimental
156 done
157
158 # remove static libraries
159 rm -fv %{buildroot}%{_libdir}/*.a
160
161 ### python: fix liblldb.so -> liblldb.so.7 symlink target
162 (cd %{buildroot}%{pkg_prefix}/%{_lib}/python*/site-packages/lldb/
163  ln -vsf "$(dirname $(readlink _lldb.so))/$(readlink $(readlink _lldb.so))" _lldb.so
164 )
165
166 # FIXME: Port it to Python 3: remove bundled six.py - Python 2<->3
167 rm -f %{buildroot}%{pkg_prefix}/%{_lib}/python*/site-packages/six.py*
168
169 %files
170 %{_bindir}/lldb-experimental
171 #{_bindir}/lldb-mi-experimental
172 %{pkg_prefix}/HEAD
173 %{pkg_prefix}/bin/lldb
174 %{pkg_prefix}/bin/lldb-server
175 #{pkg_prefix}/bin/lldb-mi
176 %{pkg_prefix}/bin/lldb-argdumper
177 # RHEL-7: File not found by glob: .../lib{lldb,clang,LLVM}*.so.*
178 %{pkg_prefix}/%{_lib}/libl*.so.*
179 %{pkg_prefix}/%{_lib}/python*
180
181 %files devel
182 %{pkg_prefix}/include
183 %{pkg_prefix}/%{_lib}/lib[^l]*.so.*
184 %{pkg_prefix}/%{_lib}/*.so
185 %{pkg_prefix}/%{_lib}/*.a
186
187 %changelog
188 * Thu Apr  5 2018 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.0-0.1
189 - Initial import for COPR, based on Fedora package 'lldb'.