583b2f484d60fdae16c12cb47ac253f105d869ef
[lldb-experimental.git] / lldb-experimental.spec
1 %global fast 0
2 %global use_jankratochvil_dwz 1
3 %global use_jankratochvil_rust 0
4 %global pkg_prefix /opt/%{name}
5 %global _unpackaged_files_terminate_build 0
6 # dwz: Couldn't find DIE referenced by DW_OP_GNU_parameter_ref
7 %global _find_debuginfo_dwz_opts %{nil}
8 # *** ERROR: ambiguous python shebang in /opt/lldb-experimental/...: #!/usr/bin/env python. Change it to python3 (or python2) explicitly.
9 %global __brp_mangle_shebangs %{nil}
10 %if %{fast}
11 %global debug_package %{nil}
12 %endif
13 Name: lldb-experimental
14 Version: 11.0.0
15 Release: 0.20200424snap2%{?dist}
16 Summary: Next generation high-performance debugger - experimental trunk snapshot
17 License: NCSA
18 URL: http://lldb.llvm.org/
19 ExclusiveArch: x86_64
20 BuildRequires: gcc-c++ git libedit-devel swig libatomic ninja-build libxml2-devel zlib-devel valgrind-devel libpfm-devel
21 # https://src.fedoraproject.org/rpms/epydoc
22 #BuildRequires: epydoc
23 %if 0%{?rhel:1} && 0%{?rhel} <= 7
24 BuildRequires: llvm-toolset-7-cmake devtoolset-8-gcc-c++ python-devel python2-pyyaml
25 # https://bugzilla.redhat.com/show_bug.cgi?id=1511892
26 %global __cmake /opt/rh/llvm-toolset-7/root/usr/bin/cmake3
27 %global ninjabuild ninja-build
28 %else
29 %if !0%{?rhel:1} || 0%{?rhel} > 8
30 BuildRequires: z3-devel
31 %endif
32 BuildRequires: cmake
33 BuildRequires: python3-devel python3-pygments python3-pyyaml
34 # removed in F31+
35 #BuildRequires: xar-devel
36 %global ninjabuild ninja
37 %endif
38
39 %description
40 LLDB is a next generation, high-performance debugger. It is built as a set
41 of reusable components which highly leverage existing libraries in the
42 larger LLVM Project, such as the Clang expression parser and LLVM
43 disassembler.
44 This package is an experimental trunk snapshot.
45 %if %{use_jankratochvil_dwz}
46 This package contains off-trunk DWZ support for Fedora debuginfos such as:
47   unsupported DW_FORM values: 0x1f20 0x1f21
48 %endif
49 %if %{use_jankratochvil_rust}
50 This package contains off-trunk Rust support:
51   https://github.com/rust-lang-nursery/lldb
52 %endif
53
54 %package devel
55 Summary: Development header files for %{name}
56 Requires: %{name}%{?_isa} = %{version}-%{release}
57
58 %description devel
59 The package contains header files for %{name}.
60
61 {-L,"-Wl,-rpath,"}%{pkg_prefix}/%{_lib} -I%{pkg_prefix}/include -llldb -lLLVMSupport -ltinfo -pthread
62
63 %ldconfig_scriptlets
64
65 %prep
66 %setup -q -c -T
67 OPTS=""
68 %if !0%{?rhel:1} || 0%{?rhel} > 7
69   OPTS="$OPTS --no-tags"
70 %endif
71 REF="reference"
72 # RHEL-7 does not support: --reference-if-able
73 test -d ../$REF/ && OPTS="$OPTS --reference ../$REF"
74 # 2500 = 1 month in 2019
75 git clone --depth 10000 --single-branch $OPTS https://github.com/llvm/llvm-project.git .
76 %if %{use_jankratochvil_dwz} || %{use_jankratochvil_rust}
77 git remote remove jankratochvil || :
78 #git remote add jankratochvil git://git.jankratochvil.net/lldb
79 git remote add jankratochvil https://github.com/jankratochvil/llvm-project.git
80 git fetch jankratochvil
81 git config user.email jankratochvil@copr.fedorainfracloud.org
82 git config user.name jankratochvil
83 %endif
84 %if %{use_jankratochvil_dwz}
85 git merge jankratochvil/dwz
86 %endif
87 %if %{use_jankratochvil_rust}
88 # '-c merge.renames=false' is F-29+.
89 # '-c merge.renameLimit=0' has no effect.
90 git -c merge.renameLimit=1 merge jankratochvil/rust
91 %endif
92
93 %build
94 mkdir build-release
95 cd    build-release
96
97 FLAGS="%{optflags}"
98
99 # lldb/scripts/LLDBWrapPython.cpp:23699:70: error: format not a string literal and no format arguments [-Werror=format-security]
100 FLAGS="$FLAGS -Wno-error=format-security"
101
102 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
103 . /opt/rh/devtoolset-8/enable
104 # -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
105 # https://bugzilla.redhat.com/show_bug.cgi?id=1590678
106 # Set %%{fast} only after %%debug_package above.
107 %global fast 1
108 %endif
109 %if %{fast}
110 FLAGS="$FLAGS -g0"
111 %else
112 # -fno-reorder-blocks-and-partition:
113 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
114 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
115 FLAGS="$FLAGS -gsplit-dwarf -fno-reorder-blocks-and-partition"
116 %endif
117
118 CFLAGS="$FLAGS"
119 CXXFLAGS="$FLAGS"
120
121 # This is default - changing it breaks the testsuite: -DLLVM_LINK_LLVM_DYLIB=OFF
122 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental
123 # -fdebug-types-section && -DLLVM_USE_LINKER=gold:
124 # ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
125 %cmake ../llvm \
126   -GNinja \
127   -DCMAKE_INSTALL_PREFIX=%{buildroot}%{pkg_prefix} \
128   -DBUILD_SHARED_LIBS=OFF \
129 %if %{fast}
130   -DCMAKE_BUILD_TYPE=Release \
131 %else
132   -DCMAKE_BUILD_TYPE=RelWithDebInfo \
133 %endif
134   -DLLVM_ENABLE_PROJECTS="lldb;clang;lld" \
135   -DLLVM_TARGETS_TO_BUILD=X86 \
136   -DLLVM_BUILD_TOOLS=OFF \
137   -DLLVM_USE_LINKER=gold \
138   $(: file INSTALL cannot find build-release/lib/python3.6 ) \
139 %if 0%{?__isa_bits} == 64
140   -DLLVM_LIBDIR_SUFFIX=64 \
141 %else
142   -DLLVM_LIBDIR_SUFFIX= \
143 %endif
144   -DLLDB_DISABLE_CURSES=OFF \
145   -DLLDB_DISABLE_LIBEDIT=OFF \
146   -DLLDB_DISABLE_PYTHON=OFF \
147   #
148 %{ninjabuild} -v
149
150 %install
151 mkdir -p %{buildroot}%{pkg_prefix}
152 (function revline {
153    echo "$(cd $1;git rev-parse ${2:-origin/master}) ${2:-$1}"
154  }
155  revline .
156 %if %{use_jankratochvil_dwz}
157  revline . jankratochvil/dwz
158 %endif
159 %if %{use_jankratochvil_rust}
160  revline . jankratochvil/rust
161 %endif
162 ) >%{buildroot}%{pkg_prefix}/HEAD
163 cd build-release
164 %{ninjabuild} -v install
165 mkdir -p %{buildroot}%{_bindir}
166 # lldb-mi
167 for i in lldb;do
168   echo >%{buildroot}%{_bindir}/${i}-experimental -e '#! /bin/bash\nexec %{pkg_prefix}/bin/'$i' "$@"'
169   chmod +x %{buildroot}%{_bindir}/${i}-experimental
170 done
171
172 # remove static libraries
173 rm -fv %{buildroot}%{_libdir}/*.a
174
175 ### python: fix liblldb.so -> liblldb.so.7 symlink target
176 (cd %{buildroot}%{pkg_prefix}/%{_lib}/python*/site-packages/lldb/
177  ln -vsf "$(dirname $(readlink _lldb.so))/$(readlink $(readlink _lldb.so))" _lldb.so
178 )
179
180 %files
181 %{_bindir}/lldb-experimental
182 #{_bindir}/lldb-mi-experimental
183 %{pkg_prefix}/HEAD
184 %{pkg_prefix}/bin/lldb
185 %{pkg_prefix}/bin/lldb-server
186 #{pkg_prefix}/bin/lldb-mi
187 %{pkg_prefix}/bin/lldb-argdumper
188 # RHEL-7: File not found by glob: .../lib{lldb,clang,LLVM}*.so.*
189 %{pkg_prefix}/%{_lib}/libl*.so.*
190 %{pkg_prefix}/lib/python*
191
192 %files devel
193 %{pkg_prefix}/include
194 %{pkg_prefix}/%{_lib}/lib[^l]*.so.*
195 %{pkg_prefix}/%{_lib}/*.so
196 %{pkg_prefix}/%{_lib}/*.a
197
198 %changelog
199 * Thu Apr  5 2018 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.0-0.1
200 - Initial import for COPR, based on Fedora package 'lldb'.