(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 7e62777..1db815a 100644 (file)
@@ -18,7 +18,7 @@
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210604snap6%{?dist}
+Release: 0.20210605snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -37,7 +37,7 @@ BuildRequires: clang git libedit-devel libatomic libxml2-devel zlib-devel valgri
 #                      ^
 #SyntaxError: invalid syntax
 %global __python /usr/bin/python3
-BuildRequires: devtoolset-8-gcc-c++
+BuildRequires: llvm-toolset-7.0-clang llvm-toolset-7.0-lld
 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
 BuildRequires: swig3
 BuildRequires: rh-git218-git-core
@@ -191,7 +191,7 @@ FLAGS="%{optflags}"
 FLAGS="$FLAGS -Wno-error=format-security"
 
 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
-. /opt/rh/devtoolset-8/enable
+. /opt/rh/llvm-toolset-7.0/enable
 . /opt/rh/rh-python38/enable
 %endif
 %if %{fast}
@@ -215,8 +215,11 @@ FLAGS="$FLAGS -fPIC"
 FLAGS="$(echo $FLAGS|sed 's/ -fstack-protector-strong / /')"
 %endif
 
-CFLAGS="$FLAGS"
-CXXFLAGS="$FLAGS"
+export CFLAGS="$FLAGS"
+export CXXFLAGS="$FLAGS"
+
+export LDFLAGS="%{build_ldflags}"
+LDFLAGS="$LDFLAGS -flto -Wl,--build-id=sha1"
 
 # This is default - changing it breaks the testsuite: -DLLVM_LINK_LLVM_DYLIB=OFF
 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental