(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 1082a53..48819a1 100644 (file)
@@ -1,4 +1,6 @@
-%global fast 0
+# https://download.copr.fedorainfracloud.org/results/jankratochvil/lldb/fedora-rawhide-x86_64/01574351-lldb-experimental/builder-live.log.gz
+# No space left on device.
+%global fast 1
 %global use_jankratochvil_dwz 1
 %global use_jankratochvil_rust 0
 %global pkg_prefix /opt/%{name}
 %global debug_package %{nil}
 %endif
 Name: lldb-experimental
-Version: 11.0.0
-Release: 0.20200424snap0%{?dist}
+Version: 12.0.0
+Release: 0.20200808snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
 ExclusiveArch: x86_64
-BuildRequires: gcc-c++ git libedit-devel swig libatomic ninja-build libxml2-devel zlib-devel valgrind-devel libpfm-devel
+BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
-BuildRequires: llvm-toolset-7-cmake devtoolset-8-gcc-c++ python-devel python2-pyyaml
+BuildRequires: devtoolset-8-gcc-c++
+# swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
+BuildRequires: swig3
+BuildRequires: rh-git218-git-core
+BuildRequires: rh-python38-python-devel rh-python38-python-pyyaml
 # https://bugzilla.redhat.com/show_bug.cgi?id=1511892
-%global __cmake /opt/rh/llvm-toolset-7/root/usr/bin/cmake3
-%global ninjabuild ninja-build
+BuildRequires: cmake3
+%global cmake %{cmake3}
+%global cmake_build %{cmake3_build}
+%global cmake_install %{cmake3_install}
 %else
-BuildRequires: cmake z3-devel
+# FIXME: CentOS-8:
+# CMake Error at CMakeLists.txt:3 (cmake_minimum_required):
+#   CMake 3.13.4 or higher is required.  You are running version 3.11.4
+BuildRequires: cmake swig
 BuildRequires: python3-devel python3-pygments python3-pyyaml
 # removed in F31+
 #BuildRequires: xar-devel
-%global ninjabuild ninja
+%if !0%{?rhel:1} || 0%{?rhel} > 8
+BuildRequires: z3-devel
+%endif
 %endif
 
 %description
@@ -60,20 +73,45 @@ The package contains header files for %{name}.
 %ldconfig_scriptlets
 
 %prep
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+# git clone --depth 10000 --single-branch --reference ../reference https://github.com/llvm/llvm-project.git .
+# fatal: git fetch-pack: expected shallow list
+. /opt/rh/rh-git218/enable
+# CMake Warning at ../lldb/cmake/modules/FindPythonInterpAndLibs.cmake:10 (find_package):
+#   By not providing "FindPython3.cmake" in CMAKE_MODULE_PATH this project has
+#   asked CMake to find a package configuration file provided by "Python3", but
+#   CMake did not find one.
+#   Could not find a package configuration file provided by "Python3" with any
+#   of the following names:
+#     Python3Config.cmake
+#     python3-config.cmake
+#   Add the installation prefix of "Python3" to CMAKE_PREFIX_PATH or set
+#   "Python3_DIR" to a directory containing one of the above files.  If
+#   "Python3" provides a separate development package or SDK, be sure it has
+#   been installed.
+# Call Stack (most recent call first):
+#   ../lldb/cmake/modules/FindPythonInterpAndLibs.cmake:71 (FindPython3)
+#   ../lldb/cmake/modules/LLDBConfig.cmake:48 (find_package)
+#   ../lldb/cmake/modules/LLDBConfig.cmake:59 (add_optional_dependency)
+#   ../lldb/CMakeLists.txt:28 (include)
+. /opt/rh/rh-python38/enable
+%endif
 %setup -q -c -T
-OPTS=""
+OPTS="--depth 10000"
 %if !0%{?rhel:1} || 0%{?rhel} > 7
   OPTS="$OPTS --no-tags"
 %endif
 REF="reference"
 # RHEL-7 does not support: --reference-if-able
-test -d ../$REF/ && OPTS="$OPTS --reference ../$REF"
+CLONEOPTS="--single-branch"
+test -d ../$REF/ && CLONEOPTS="$CLONEOPTS --reference ../$REF"
 # 2500 = 1 month in 2019
-git clone --depth 10000 --single-branch $OPTS https://github.com/llvm/llvm-project.git .
+git clone $OPTS $CLONEOPTS https://github.com/llvm/llvm-project.git .
 %if %{use_jankratochvil_dwz} || %{use_jankratochvil_rust}
 git remote remove jankratochvil || :
-git remote add jankratochvil git://git.jankratochvil.net/lldb
-git fetch jankratochvil
+#git remote add jankratochvil git://git.jankratochvil.net/lldb
+git remote add jankratochvil https://github.com/jankratochvil/llvm-project.git
+git fetch $OPTS jankratochvil
 git config user.email jankratochvil@copr.fedorainfracloud.org
 git config user.name jankratochvil
 %endif
@@ -87,9 +125,6 @@ git -c merge.renameLimit=1 merge jankratochvil/rust
 %endif
 
 %build
-mkdir build-release
-cd    build-release
-
 FLAGS="%{optflags}"
 
 # lldb/scripts/LLDBWrapPython.cpp:23699:70: error: format not a string literal and no format arguments [-Werror=format-security]
@@ -97,6 +132,7 @@ FLAGS="$FLAGS -Wno-error=format-security"
 
 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
 . /opt/rh/devtoolset-8/enable
+. /opt/rh/rh-python38/enable
 # -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
 # https://bugzilla.redhat.com/show_bug.cgi?id=1590678
 # Set %%{fast} only after %%debug_package above.
@@ -108,7 +144,7 @@ FLAGS="$FLAGS -g0"
 # -fno-reorder-blocks-and-partition:
 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
-FLAGS="$FLAGS -gsplit-dwarf -fno-reorder-blocks-and-partition"
+FLAGS="$FLAGS -fdebug-types-section"
 %endif
 
 CFLAGS="$FLAGS"
@@ -118,9 +154,8 @@ CXXFLAGS="$FLAGS"
 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental
 # -fdebug-types-section && -DLLVM_USE_LINKER=gold:
 # ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
-%cmake ../llvm \
-  -GNinja \
-  -DCMAKE_INSTALL_PREFIX=%{buildroot}%{pkg_prefix} \
+%cmake llvm \
+  -DCMAKE_INSTALL_PREFIX=%{pkg_prefix} \
   -DBUILD_SHARED_LIBS=OFF \
 %if %{fast}
   -DCMAKE_BUILD_TYPE=Release \
@@ -141,7 +176,7 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
   #
-%{ninjabuild} -v
+%cmake_build
 
 %install
 mkdir -p %{buildroot}%{pkg_prefix}
@@ -156,8 +191,7 @@ mkdir -p %{buildroot}%{pkg_prefix}
  revline . jankratochvil/rust
 %endif
 ) >%{buildroot}%{pkg_prefix}/HEAD
-cd build-release
-%{ninjabuild} -v install
+%cmake_install
 mkdir -p %{buildroot}%{_bindir}
 # lldb-mi
 for i in lldb;do
@@ -169,7 +203,7 @@ done
 rm -fv %{buildroot}%{_libdir}/*.a
 
 ### python: fix liblldb.so -> liblldb.so.7 symlink target
-(cd %{buildroot}%{pkg_prefix}/lib/python*/site-packages/lldb/
+(cd %{buildroot}%{pkg_prefix}/%{_lib}/python*/site-packages/lldb/
  ln -vsf "$(dirname $(readlink _lldb.so))/$(readlink $(readlink _lldb.so))" _lldb.so
 )
 
@@ -183,7 +217,7 @@ rm -fv %{buildroot}%{_libdir}/*.a
 %{pkg_prefix}/bin/lldb-argdumper
 # RHEL-7: File not found by glob: .../lib{lldb,clang,LLVM}*.so.*
 %{pkg_prefix}/%{_lib}/libl*.so.*
-%{pkg_prefix}/lib/python*
+%{pkg_prefix}/%{_lib}/python*
 
 %files devel
 %{pkg_prefix}/include