(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 3efbe9a..4a268c3 100644 (file)
 %global debug_package %{nil}
 %endif
 Name: lldb-experimental
-Version: 10.0.0
-Release: 0.20190817snap4%{?dist}
+Version: 11.0.0
+Release: 0.20200625snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
 ExclusiveArch: x86_64
-BuildRequires: gcc-c++ git libedit-devel swig libatomic ninja-build libxml2-devel zlib-devel valgrind-devel libpfm-devel epydoc
+BuildRequires: gcc-c++ git libedit-devel libatomic ninja-build libxml2-devel zlib-devel valgrind-devel libpfm-devel
+# https://src.fedoraproject.org/rpms/epydoc
+#BuildRequires: epydoc
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
 BuildRequires: llvm-toolset-7-cmake devtoolset-8-gcc-c++ python-devel python2-pyyaml
+# swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
+BuildRequires: swig3
 # https://bugzilla.redhat.com/show_bug.cgi?id=1511892
 %global __cmake /opt/rh/llvm-toolset-7/root/usr/bin/cmake3
 %global ninjabuild ninja-build
 %else
-BuildRequires: cmake z3-devel
+%if !0%{?rhel:1} || 0%{?rhel} > 8
+BuildRequires: z3-devel
+%endif
+BuildRequires: cmake swig
 BuildRequires: python3-devel python3-pygments python3-pyyaml
 # removed in F31+
 #BuildRequires: xar-devel
@@ -59,12 +66,21 @@ The package contains header files for %{name}.
 
 %prep
 %setup -q -c -T
+OPTS="--depth 10000"
+%if !0%{?rhel:1} || 0%{?rhel} > 7
+  OPTS="$OPTS --no-tags"
+%endif
+REF="reference"
+# RHEL-7 does not support: --reference-if-able
+CLONEOPTS="--single-branch"
+test -d ../$REF/ && CLONEOPTS="$CLONEOPTS --reference ../$REF"
 # 2500 = 1 month in 2019
-git clone --depth 10000 --no-tags --single-branch --reference-if-able reference https://github.com/llvm/llvm-project.git .
+git clone $OPTS $CLONEOPTS https://github.com/llvm/llvm-project.git .
 %if %{use_jankratochvil_dwz} || %{use_jankratochvil_rust}
 git remote remove jankratochvil || :
-git remote add jankratochvil git://git.jankratochvil.net/lldb
-git fetch jankratochvil
+#git remote add jankratochvil git://git.jankratochvil.net/lldb
+git remote add jankratochvil https://github.com/jankratochvil/llvm-project.git
+git fetch $OPTS jankratochvil
 git config user.email jankratochvil@copr.fedorainfracloud.org
 git config user.name jankratochvil
 %endif
@@ -164,9 +180,6 @@ rm -fv %{buildroot}%{_libdir}/*.a
  ln -vsf "$(dirname $(readlink _lldb.so))/$(readlink $(readlink _lldb.so))" _lldb.so
 )
 
-# FIXME: Port it to Python 3: remove bundled six.py - Python 2<->3
-rm -f %{buildroot}%{pkg_prefix}/%{_lib}/python*/site-packages/six.py*
-
 %files
 %{_bindir}/lldb-experimental
 #{_bindir}/lldb-mi-experimental