(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 52b3575..7453fb3 100644 (file)
@@ -14,7 +14,7 @@
 %endif
 Name: lldb-experimental
 Version: 12.0.0
-Release: 0.20201026snap2%{?dist}
+Release: 0.20201026snap1%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -37,15 +37,7 @@ BuildRequires: cmake3
 # FIXME: CentOS-8:
 # CMake Error at CMakeLists.txt:3 (cmake_minimum_required):
 #   CMake 3.13.4 or higher is required.  You are running version 3.11.4
-%if 0%{?rhel} != 8
-BuildRequires: cmake
-%else
-# cmake-3.17.0-1.el8:
-###BuildRequires: /usr/bin/sphinx-build curl-devel emacs jsoncpp-devel libarchive-devel openssl-devel pkgconfig(Qt5Widgets) rhash-devel
-# [local]=https://kojipkgs.fedoraproject.org/repos/epel8-build/latest/$basearch/
-###BuildRequires: libuv-devel
-%endif
-BuildRequires: swig
+BuildRequires: cmake swig
 BuildRequires: python3-devel python3-pygments python3-pyyaml
 # removed in F31+
 #BuildRequires: xar-devel
@@ -104,28 +96,6 @@ The package contains header files for %{name}.
 #   ../lldb/CMakeLists.txt:28 (include)
 . /opt/rh/rh-python38/enable
 %endif
-%if 0%{?rhel} == 8
-cmakesrc=cmake-3.17.0-1.fc32.src.rpm
-rm -rf $cmakesrc $cmakesrc.tgz $cmakesrc.d
-wget http://ftp.fi.muni.cz/pub/linux/fedora/linux/releases/32/Everything/source/tree/Packages/c/$cmakesrc
-rpm2archive $cmakesrc
-(mkdir $cmakesrc.d
- cd $cmakesrc.d
- tar xzf ../$cmakesrc.tgz
- # FIXME: Why?
- for i in .[a-z]*;do mv $i `echo $i|sed 's/^\.//'`;done
- # -- Could NOT find LibArchive: Found unsuitable version "3.3.2", but required is at least "3.3.3" (found /usr/lib64/libarchive.so)
- # CMAKE_USE_SYSTEM_LIBARCHIVE is ON but LibArchive is not found!
- patch -p1 <../cmake.spec.patch
- rpmbuild --define "_topdir $PWD" --define "_builddir $PWD" --define "_rpmdir $PWD" --define "_sourcedir $PWD" --define "_specdir $PWD" --define "_srcrpmdir $PWD" -bc cmake.spec
-)
-%global __cmake %(echo %{_builddir}/cmake-*.d/cmake-*/*/bin/cmake)
-%global __cmake_builddir .
-%global cmake_build \
-  %__cmake --build "%{__cmake_builddir}" %{?_smp_mflags} --verbose
-%global cmake_install \
-  DESTDIR="%{buildroot}" %__cmake --install "%{__cmake_builddir}"
-%endif
 %setup -q -c -T
 OPTS="--depth 10000"
 %if !0%{?rhel:1} || 0%{?rhel} > 7