(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 57c84cc..8385836 100644 (file)
@@ -1,4 +1,6 @@
-%global fast 0
+# https://download.copr.fedorainfracloud.org/results/jankratochvil/lldb/fedora-rawhide-x86_64/01574351-lldb-experimental/builder-live.log.gz
+# No space left on device.
+%global fast 1
 %global use_jankratochvil_dwz 1
 %global use_jankratochvil_rust 0
 %global pkg_prefix /opt/%{name}
 %endif
 Name: lldb-experimental
 Version: 11.0.0
-Release: 0.20200722snap0%{?dist}
+Release: 0.20200726snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
-Patch1: cmake-old.patch
+Patch1: cmake-old1.patch
+Patch2: cmake-old2.patch
 ExclusiveArch: x86_64
 BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
@@ -25,6 +28,7 @@ BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valg
 BuildRequires: llvm-toolset-7-cmake devtoolset-8-gcc-c++ python-devel python2-pyyaml
 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
 BuildRequires: swig3
+BuildRequires: rh-git218-git-core
 # https://bugzilla.redhat.com/show_bug.cgi?id=1511892
 %global __cmake /opt/rh/llvm-toolset-7/root/usr/bin/cmake3
 %else
@@ -64,6 +68,11 @@ The package contains header files for %{name}.
 %ldconfig_scriptlets
 
 %prep
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+# git clone --depth 10000 --single-branch --reference ../reference https://github.com/llvm/llvm-project.git .
+# fatal: git fetch-pack: expected shallow list
+. /opt/rh/rh-git218/enable
+%endif
 %setup -q -c -T
 OPTS="--depth 10000"
 %if !0%{?rhel:1} || 0%{?rhel} > 7
@@ -91,7 +100,8 @@ git merge jankratochvil/dwz
 # '-c merge.renameLimit=0' has no effect.
 git -c merge.renameLimit=1 merge jankratochvil/rust
 %endif
-%patch1 -p1
+%patch2 -p1 -R
+%patch1 -p1 -R
 
 %build
 FLAGS="%{optflags}"
@@ -112,7 +122,7 @@ FLAGS="$FLAGS -g0"
 # -fno-reorder-blocks-and-partition:
 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
-FLAGS="$FLAGS -gsplit-dwarf -fno-reorder-blocks-and-partition"
+FLAGS="$FLAGS -fdebug-types-section"
 %endif
 
 CFLAGS="$FLAGS"
@@ -144,7 +154,11 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
   #
+%if 0%{?rhel:1} && 0%{?rhel} <= 8
+%__cmake --build . -- %{?_smp_mflags}
+%else
 %cmake_build
+%endif
 
 %install
 mkdir -p %{buildroot}%{pkg_prefix}
@@ -159,7 +173,12 @@ mkdir -p %{buildroot}%{pkg_prefix}
  revline . jankratochvil/rust
 %endif
 ) >%{buildroot}%{pkg_prefix}/HEAD
+%if 0%{?rhel:1} && 0%{?rhel} <= 8
+# It runs a new configure without installing anything: DESTDIR="%{buildroot}" #__cmake --install .
+%make_install
+%else
 %cmake_install
+%endif
 mkdir -p %{buildroot}%{_bindir}
 # lldb-mi
 for i in lldb;do