(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 21c4286..c51b1f1 100644 (file)
@@ -14,7 +14,7 @@
 %endif
 Name: lldb-experimental
 Version: 12.0.0
-Release: 0.20201026snap8%{?dist}
+Release: 0.20201026snap11%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -41,10 +41,19 @@ BuildRequires: cmake3
 BuildRequires: cmake
 %else
 # cmake-3.17.0-1.el8:
-BuildRequires: wget
-BuildRequires: /usr/bin/sphinx-build curl-devel emacs jsoncpp-devel libarchive-devel openssl-devel pkgconfig(Qt5Widgets) rhash-devel
+BuildRequires: wget expat-devel
+BuildRequires: /usr/bin/sphinx-build curl-devel emacs jsoncpp-devel openssl-devel pkgconfig(Qt5Widgets) rhash-devel
+# -- Could NOT find LibArchive: Found unsuitable version "3.3.2", but required is at least "3.3.3" (found /usr/lib64/libarchive.so)
+# CMAKE_USE_SYSTEM_LIBARCHIVE is ON but LibArchive is not found!
+#BuildRequires: libarchive-devel
+# -- Could NOT find LibUV: Found unsuitable version "", but required is at least "1.10.0" (found LibUV_LIBRARY-NOTFOUND)
+# CMAKE_USE_SYSTEM_LIBUV is ON but a libuv is not found!
 # [local]=https://kojipkgs.fedoraproject.org/repos/epel8-build/latest/$basearch/
-BuildRequires: libuv-devel
+#BuildRequires: libuv-devel
+# CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
+# Please set them or make sure they are set and tested correctly in the CMake files:
+# BZIP2_LIBRARY
+BuildRequires: bzip2-devel
 %endif
 BuildRequires: swig
 BuildRequires: python3-devel python3-pygments python3-pyyaml
@@ -115,10 +124,8 @@ rpm2archive $cmakesrc
  tar xzf ../$cmakesrc.tgz
  # FIXME: Why?
  for i in .[a-z]*;do mv $i `echo $i|sed 's/^\.//'`;done
- # -- Could NOT find LibArchive: Found unsuitable version "3.3.2", but required is at least "3.3.3" (found /usr/lib64/libarchive.so)
- # CMAKE_USE_SYSTEM_LIBARCHIVE is ON but LibArchive is not found!
- sed -i -e 's/qt-gui /&--no-system-libarchive /' cmake.spec
- rpmbuild --define "_topdir $PWD" --define "_builddir $PWD" --define "_rpmdir $PWD" --define "_sourcedir $PWD" --define "_specdir $PWD" --define "_srcrpmdir $PWD" -bc cmake.spec
+ sed -i -e 's/qt-gui /&--no-system-libarchive --no-system-libuv /' cmake.spec
+ rpmbuild --define "_topdir $PWD" --define "_builddir $PWD" --define "_rpmdir $PWD" --define "_sourcedir $PWD" --define "_specdir $PWD" --define "_srcrpmdir $PWD" -bc --nodeps cmake.spec
 )
 %global __cmake %(echo %{_builddir}/cmake-*.d/cmake-*/*/bin/cmake)
 %global __cmake_builddir .