(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 7453fb3..c51b1f1 100644 (file)
@@ -14,7 +14,7 @@
 %endif
 Name: lldb-experimental
 Version: 12.0.0
-Release: 0.20201026snap1%{?dist}
+Release: 0.20201026snap11%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -37,7 +37,25 @@ BuildRequires: cmake3
 # FIXME: CentOS-8:
 # CMake Error at CMakeLists.txt:3 (cmake_minimum_required):
 #   CMake 3.13.4 or higher is required.  You are running version 3.11.4
-BuildRequires: cmake swig
+%if 0%{?rhel} != 8
+BuildRequires: cmake
+%else
+# cmake-3.17.0-1.el8:
+BuildRequires: wget expat-devel
+BuildRequires: /usr/bin/sphinx-build curl-devel emacs jsoncpp-devel openssl-devel pkgconfig(Qt5Widgets) rhash-devel
+# -- Could NOT find LibArchive: Found unsuitable version "3.3.2", but required is at least "3.3.3" (found /usr/lib64/libarchive.so)
+# CMAKE_USE_SYSTEM_LIBARCHIVE is ON but LibArchive is not found!
+#BuildRequires: libarchive-devel
+# -- Could NOT find LibUV: Found unsuitable version "", but required is at least "1.10.0" (found LibUV_LIBRARY-NOTFOUND)
+# CMAKE_USE_SYSTEM_LIBUV is ON but a libuv is not found!
+# [local]=https://kojipkgs.fedoraproject.org/repos/epel8-build/latest/$basearch/
+#BuildRequires: libuv-devel
+# CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
+# Please set them or make sure they are set and tested correctly in the CMake files:
+# BZIP2_LIBRARY
+BuildRequires: bzip2-devel
+%endif
+BuildRequires: swig
 BuildRequires: python3-devel python3-pygments python3-pyyaml
 # removed in F31+
 #BuildRequires: xar-devel
@@ -96,6 +114,26 @@ The package contains header files for %{name}.
 #   ../lldb/CMakeLists.txt:28 (include)
 . /opt/rh/rh-python38/enable
 %endif
+%if 0%{?rhel} == 8
+cmakesrc=cmake-3.17.0-1.fc32.src.rpm
+rm -rf $cmakesrc $cmakesrc.tgz $cmakesrc.d
+wget http://ftp.fi.muni.cz/pub/linux/fedora/linux/releases/32/Everything/source/tree/Packages/c/$cmakesrc
+rpm2archive $cmakesrc
+(mkdir $cmakesrc.d
+ cd $cmakesrc.d
+ tar xzf ../$cmakesrc.tgz
+ # FIXME: Why?
+ for i in .[a-z]*;do mv $i `echo $i|sed 's/^\.//'`;done
+ sed -i -e 's/qt-gui /&--no-system-libarchive --no-system-libuv /' cmake.spec
+ rpmbuild --define "_topdir $PWD" --define "_builddir $PWD" --define "_rpmdir $PWD" --define "_sourcedir $PWD" --define "_specdir $PWD" --define "_srcrpmdir $PWD" -bc --nodeps cmake.spec
+)
+%global __cmake %(echo %{_builddir}/cmake-*.d/cmake-*/*/bin/cmake)
+%global __cmake_builddir .
+%global cmake_build \
+  %__cmake --build "%{__cmake_builddir}" %{?_smp_mflags} --verbose
+%global cmake_install \
+  DESTDIR="%{buildroot}" %__cmake --install "%{__cmake_builddir}"
+%endif
 %setup -q -c -T
 OPTS="--depth 10000"
 %if !0%{?rhel:1} || 0%{?rhel} > 7