'kernel-source-*.rpm' directory overridable by 'KERNEL_SOURCE_DIR'.
[lufs.git] / kernel / Linux / modbin / Makefile.am
index 24a3378..e2857b1 100644 (file)
@@ -1,9 +1,11 @@
+KERNEL_SOURCE_DIR=$(top_srcdir)/..
+
 modbin:
        $(srcdir)/../prepmod --modbindir=. --basedir=$(srcdir)/.. \
                        --kernel-gcc-args="-I$$PWD/$(top_srcdir)/include/lufs" \
                        --prebuild \
                        $(wildcard /usr/src/kernel-headers-*) \
-                       $(wildcard $(top_srcdir)/../kernel-source-*.rpm)
+                       $(wildcard $(KERNEL_SOURCE_DIR)/kernel-source-*.rpm)
 
 # Keep the basename as 'lufs.o'.
 # Do not use '$(INSTALL_PROGRAM)' as it would strip the modules.