+macro editor ALT-w: wrap text (subject line) to " [WAS: &]"
[nethome.git] / src / rpm / SPECS / cvs.spec
1 %define cvsbase  1.11.1
2 %define cvspatch p1
3 Summary: A version control system.
4 Name: cvs
5 Version: %{cvsbase}%{cvspatch}
6 Release: 3
7 License: GPL
8 Group: Development/Tools
9 Source: ftp://ftp.cvshome.org/pub/cvs-%{cvsbase}/cvs-%{version}.tar.gz
10 URL: http://www.cvshome.org/
11 Patch0: cvs-1.11.1p1-mktemp.patch
12 Patch1: cvs-1.11.1p1-krb4.patch
13 Patch2: cvs-1.11.1p1-automake.patch
14 Patch3: cvs-1.11.1p1-sockaddr.patch
15 Patch4: cvs-1.11.1p1-authserver.patch
16 Patch5: cvs-1.11.1p1-cvspass.patch
17 Patch6: cvs-1.11.1p1-bs.patch
18 Prereq: /sbin/install-info
19 Prefix: %{_prefix}
20 Buildroot: %{_tmppath}/%{name}-root
21 BuildPreReq: autoconf, automake, libtool, zlib-devel
22 %{!?nokerberos:Requires: krb5-libs}
23 %{!?nokerberos:BuildPrereq: krb5-devel}
24
25 %description
26 CVS (Concurrent Version System) is a version control system that can
27 record the history of your files (usually, but not always, source
28 code). CVS only stores the differences between versions, instead of
29 every version of every file you have ever created. CVS also keeps a log
30 of who, when, and why changes occurred.
31
32 CVS is very helpful for managing releases and controlling the
33 concurrent editing of source files among multiple authors. Instead of
34 providing version control for a collection of files in a single
35 directory, CVS provides version control for a hierarchical collection
36 of directories consisting of revision controlled files. These
37 directories and files can then be combined together to form a software
38 release.
39
40 %prep
41 %setup -q
42 %patch0 -p1 -b .mktemp
43 %patch1 -p1 -b .krb4
44 %patch2 -p1 -b .automake
45 %patch3 -p1 -b .sockaddr
46 %patch4 -p1 -b .authserver
47 %patch5 -p1 -b .cvspass
48 %patch6 -p1 -b .bs
49 aclocal
50 automake
51 autoconf
52
53 %build
54 %{!?nokerberos: CPPFLAGS="-I/usr/kerberos/include"; export CPPFLAGS}
55 %{!?nokerberos: CFLAGS="-I/usr/kerberos/include $RPM_OPT_FLAGS"; export CFLAGS}
56 %{!?nokerberos: LIBS="-L/usr/kerberos/lib -lkrb4 -ldes425 -lk5crypto -lcom_err"; export LIBS}
57 %configure \
58 %{!?nokerberos: --with-gssapi=/usr/kerberos --with-krb4=/usr/kerberos --enable-encryption}
59
60 make
61 if [ `id -u` -ne 0 ] ; then
62         make check
63 fi
64
65 %install
66 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
67 %{makeinstall}
68 # forcefully compress the info pages so that install-info will work properly
69 # in the %%post
70 gzip $RPM_BUILD_ROOT/%{_infodir}/cvs* || true
71
72 %clean
73 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
74
75 %post
76 /sbin/install-info /%{_infodir}/cvs.info.gz /%{_infodir}/dir
77 /sbin/install-info /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir 
78
79 %preun
80 if [ $1 = 0 ]; then
81     /sbin/install-info --delete /%{_infodir}/cvs.info.gz /%{_infodir}/dir
82     /sbin/install-info --delete /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
83 fi
84
85 %files
86 %defattr(-,root,root)
87 %doc AUTHORS BUGS FAQ MINOR-BUGS NEWS PROJECTS TODO README
88 %doc doc/*.ps
89 %{_bindir}/*
90 %{_mandir}/*/*
91 %{_infodir}/*.info*
92 %{_datadir}/%{name}
93
94 %changelog
95 * Tue Jul 31 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.11.1p1-3
96 - Fix up initial cvs login (#47457)
97 - Bring back the leading newline at the beginning of commit messages
98   "a" is one key less than "O". ;)
99 - Fix build in the current build system
100
101 * Mon Jun 25 2001 Bill Nottingham <notting@redhat.com>
102 - don't own /usr/share/info/dir
103
104 * Fri Jun 22 2001 Nalin Dahyabhai <nalin@redhat.com>
105 - fix the files list
106
107 * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
108 - update to 1.11.1p1
109 - drop no-longer-necessary patches
110 - use bundled zlib, because it's apparently not the same as the system zlib
111 - run the test suite in the build phase
112 - drop explicit Requires: on perl (RPM will catch the interpreter req)
113
114 * Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
115 - fix cvs-1.11-security.patch, which had CR-LF line terminators (#25090)
116 - check for and ignore ENOENT errors when attempting to remove symlinks (#25173)
117
118 * Mon Jan 08 2001 Preston Brown <pbrown@redhat.com>
119 - patch from Olaf Kirch <okir@lst.de> to do tmp files safely.
120
121 * Tue Oct 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
122 - 1.11
123
124 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
125 - automatic rebuild
126
127 * Mon Jul 10 2000 Nalin Dahyabhai <nalin@redhat.com>
128 - always zero errno before calling readdir (#10374)
129
130 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
131 - rebuild in new build environment (release 6)
132
133 * Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
134 - rebuild in new build environment (release 5)
135 - FHS tweaks
136 - actually gzip the info pages
137
138 * Wed May 10 2000 Nalin Dahyabhai <nalin@redhat.com>
139 - reverse sense of conditional kerberos dependency
140 - add kerberos IV patch from Ken Raeburn
141 - switch to using the system's zlib instead of built-in
142 - default to unstripped binaries
143
144 * Tue Apr  4 2000 Bill Nottingham <notting@redhat.com>
145 - eliminate explicit krb5-configs dependency
146
147 * Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
148 - 1.10.8
149
150 * Wed Mar  1 2000 Nalin Dahyabhai <nalin@redhat.com>
151 - make kerberos support conditional at build-time
152
153 * Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
154 - integrate kerberos support into main tree
155
156 * Mon Feb 14 2000 Nalin Dahyabhai <nalin@redhat.com>
157 - build with gssapi auth (--with-gssapi, --with-encryption)
158 - apply patch to update libs to krb5 1.1.1
159
160 * Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
161 - fix the damn info pages too while we're at it.
162 - fix description
163 - man pages are compressed
164 - make sure %post and %preun work okay
165
166 * Sun Jan 9 2000  Jim Kingdon <http://bugzilla.redhat.com/bugzilla>
167 - update to 1.10.7.
168
169 * Wed Jul 14 1999 Jim Kingdon <http://developer.redhat.com>
170 - add the patch to make 1.10.6 usable
171   (http://www.cyclic.com/cvs/dev-known.html).
172
173 * Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
174 - update to 1.10.6.
175
176 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> 
177 - auto rebuild in the new build environment (release 2)
178
179 * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
180 - updated text in spec file.
181
182 * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
183 - update to 1.10.5.
184
185 * Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
186 - update to 1.10.4.
187
188 * Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
189 - update to 1.10.3.
190
191 * Mon Sep 28 1998 Jeff Johnson <jbj@redhat.com>
192 - update to 1.10.2.
193
194 * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
195 - remove trailing characters from rcs2log mktemp args
196
197 * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
198 - update to 1.10.1
199
200 * Mon Aug 31 1998 Jeff Johnson <jbj@redhat.com>
201 - fix race conditions in cvsbug/rcs2log
202
203 * Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
204 - update to 1.10.
205
206 * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
207 - update to 1.9.30.
208
209 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
210 - translations modified for de, fr
211
212 * Mon Jun  8 1998 Jeff Johnson <jbj@redhat.com>
213 - build root
214 - update to 1.9.28
215
216 * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
217 - translations modified for de, fr, tr
218
219 * Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
220 - added install-info stuff
221 - added changelog section