This commit was manufactured by cvs2svn to create tag 'rh71'.
[nethome.git] / src / rpm / SPECS / glibc.spec
1 %define glibcrelease 10
2 %define auxarches i586 i686 athlon sparcv9 alphaev6
3 Summary: The GNU libc libraries.
4 Name: glibc
5 Version: 2.2.2
6 Release: %{glibcrelease}
7 Copyright: LGPL
8 Group: System Environment/Libraries
9 Source: %{name}-%{version}.tar.bz2
10 # In the source tarball the file diff-CYGNUS-to-REDHAT.patch contains all
11 # diffs applied by Red Hat to the current CVS version of glibc
12 Buildroot: %{_tmppath}/glibc-%{PACKAGE_VERSION}-root
13 Obsoletes: zoneinfo, libc-static, libc-devel, libc-profile, libc-headers,
14 Obsoletes:  linuxthreads, gencat, locale, ldconfig, locale-ja
15 Provides: ldconfig
16 Autoreq: false
17 Requires: glibc-common = %{version}-%{release}
18 %ifarch alpha
19 Provides: ld.so.2
20 %else
21 %endif
22 %ifarch sparc
23 Obsoletes: libc
24 %endif
25 Prereq: basesystem
26 Conflicts: rpm <= 4.0-0.65
27 Patch: glibc-kernel-2.4.patch
28 %ifarch ia64 sparc64 s390x
29 Conflicts: kernel < 2.4.0
30 %define enablekernel 2.4.0
31 %else
32 %define enablekernel 2.2.5
33 %endif
34 %define enablekernel2 2.4.1
35 %define __find_provides %{_builddir}/%{name}-%{version}/find_provides.sh
36
37 %description
38 The glibc package contains standard libraries which are used by
39 multiple programs on the system. In order to save disk space and
40 memory, as well as to make upgrading easier, common system code is
41 kept in one place and shared between programs. This particular package
42 contains the most important sets of shared libraries: the standard C
43 library and the standard math library. Without these two libraries, a
44 Linux system will not function.
45
46 %package devel
47 Summary: Header and object files for development using standard C libraries.
48 Group: Development/Libraries
49 Conflicts: texinfo < 3.11
50 Prereq: /sbin/install-info
51 Obsoletes: libc-debug, libc-headers, libc-devel, linuxthreads-devel
52 Obsoletes: glibc-debug
53 Prereq: kernel-headers
54 Requires: kernel-headers >= 2.2.1, %{name} = %{version}
55 Autoreq: true
56
57 %description devel
58 The glibc-devel package contains the header and object files necessary
59 for developing programs which use the standard C libraries (which are
60 used by nearly all programs).  If you are developing programs which
61 will use the standard C libraries, your system needs to have these
62 standard header and object files available in order to create the
63 executables.
64
65 Install glibc-devel if you are going to develop programs which will
66 use the standard C libraries.
67
68 %package profile
69 Summary: The GNU libc libraries, including support for gprof profiling.
70 Group: Development/Libraries
71 Obsoletes: libc-profile
72 Autoreq: true
73
74 %description profile
75 The glibc-profile package includes the GNU libc libraries and support
76 for profiling using the gprof program.  Profiling is analyzing a
77 program's functions to see how much CPU time they use and determining
78 which functions are calling other functions during execution.  To use
79 gprof to profile a program, your program needs to use the GNU libc
80 libraries included in glibc-profile (instead of the standard GNU libc
81 libraries included in the glibc package).
82
83 If you are going to use the gprof program to profile a program, you'll
84 need to install the glibc-profile program.
85
86 %package common
87 Summary: Common binaries and locale data for glibc
88 Conflicts: %{name} < %{version}
89 Conflicts: %{name} > %{version} 
90 Autoreq: false
91 Group: System Environment/Base
92
93 %description common
94 The glibc-common package includes common binaries for the GNU libc
95 libraries, as well as national language (locale) support and timezone
96 databases.
97
98 %package -n nscd
99 Summary: A Name Service Caching Daemon (nscd).
100 Group: System Environment/Daemons
101 Conflicts: kernel < 2.2.0
102 Prereq: /sbin/chkconfig, /usr/sbin/useradd, /usr/sbin/userdel
103 Autoreq: true
104
105 %description -n nscd
106 Nscd caches name service lookups and can dramatically improve
107 performance with NIS+, and may help with DNS as well. Note that you
108 can't use nscd with 2.0 kernels because of bugs in the kernel-side
109 thread support. Unfortunately, nscd happens to hit these bugs
110 particularly hard.
111
112 Install nscd if you need a name service lookup caching daemon, and
113 you're not using a version 2.0 kernel.
114
115 %prep
116 %setup -q
117 %ifarch ia64 sparc64 s390x %{auxarches}
118 # If we are building enablekernel 2.4.1 glibc on older kernel,
119 # we have to make sure no binaries compiled against that glibc
120 # are ever run
121 case `uname -r` in
122 [01].*|2.[0-3]*|2.4.0*)
123 %patch -p1
124 ;; esac
125 %endif
126
127 %ifarch armv4l sparc64 ia64 s390 s390x
128 rm -rf glibc-compat
129 %endif
130
131 find . -type f -size 0 -o -name "*.orig" -exec rm -f {} \;
132
133 cat > find_provides.sh <<EOF
134 #!/bin/sh
135 /usr/lib/rpm/find-provides | grep -v GLIBC_2.2.3
136 EOF
137 chmod +x find_provides.sh
138
139 %build
140 rm -rf build-%{_target_cpu}-linux
141 mkdir build-%{_target_cpu}-linux ; cd build-%{_target_cpu}-linux
142 GCC=gcc
143 %ifarch %{ix86}
144 BuildFlags="-march=%{_target_cpu} -D__USE_STRING_INLINES -fstrict-aliasing"
145 %endif
146 %ifarch alphaev6
147 BuildFlags="-mcpu=ev6"
148 %endif
149 %ifarch sparc
150 BuildFlags="-fcall-used-g7"
151 GCC="gcc -m32"
152 %endif
153 %ifarch sparcv9
154 BuildFlags="-mcpu=ultrasparc -fcall-used-g7"
155 GCC="gcc -m32"
156 %endif
157 %ifarch sparc64
158 BuildFlags="-mcpu=ultrasparc -mvis -fcall-used-g7"
159 GCC="gcc -m64"
160 %endif
161 # Temporarily don't do this on ia64 and s390
162 %ifnarch ia64 s390 s390x
163 BuildFlags="$BuildFlags -freorder-blocks"
164 %endif
165 BuildFlags="$BuildFlags -DNDEBUG=1"
166 EnableKernel="--enable-kernel=%{enablekernel}"
167 %ifarch %{auxarches}
168 EnableKernel="$EnableKernel --disable-profile"
169 %endif
170 echo "$BuildFlags" > ../BuildFlags
171 CC="$GCC" CFLAGS="$BuildFlags -g -O3" ../configure --prefix=%{_prefix} \
172         --enable-add-ons=yes --without-cvs $EnableKernel \
173         %{_target_cpu}-redhat-linux
174 if [ -x /usr/bin/getconf ] ; then
175   numprocs=$(/usr/bin/getconf _NPROCESSORS_ONLN)
176   if [ $numprocs -eq 0 ]; then
177     numprocs=1
178   fi
179 else
180   numprocs=1
181 fi
182 make -j$numprocs -r CFLAGS="$BuildFlags -g -O3" PARALLELMFLAGS=-s
183 gcc -static -Os ../redhat/glibc_post_upgrade.c -o glibc_post_upgrade
184
185 %install
186 rm -rf $RPM_BUILD_ROOT
187 mkdir -p $RPM_BUILD_ROOT
188 make install_root=$RPM_BUILD_ROOT install -C build-%{_target_cpu}-linux
189 cd build-%{_target_cpu}-linux && \
190     make install_root=$RPM_BUILD_ROOT install-locales -C ../localedata objdir=`pwd` && \
191     cd ..
192
193 %ifarch i686
194 rm -rf build-%{_target_cpu}-linux2.4
195 mkdir build-%{_target_cpu}-linux2.4 ; cd build-%{_target_cpu}-linux2.4
196 GCC=gcc
197 BuildFlags=`cat ../BuildFlags`
198 EnableKernel="--enable-kernel=%{enablekernel2} --disable-profile"
199 CC="$GCC" CFLAGS="$BuildFlags -g -O3" ../configure --prefix=%{_prefix} \
200         --enable-add-ons=yes --without-cvs $EnableKernel \
201         %{_target_cpu}-redhat-linux
202 if [ -x /usr/bin/getconf ] ; then
203   numprocs=$(/usr/bin/getconf _NPROCESSORS_ONLN)
204   if [ $numprocs -eq 0 ]; then
205     numprocs=1
206   fi
207 else
208   numprocs=1
209 fi
210 make -j$numprocs -r CFLAGS="$BuildFlags -g -O3" PARALLELMFLAGS=-s
211 mkdir -p $RPM_BUILD_ROOT/lib/%{_target_cpu}/
212 cp -a libc.so $RPM_BUILD_ROOT/lib/%{_target_cpu}/`basename $RPM_BUILD_ROOT/lib/libc-*.so`
213 ln -sf `basename $RPM_BUILD_ROOT/lib/libc-*.so` $RPM_BUILD_ROOT/lib/%{_target_cpu}/`basename $RPM_BUILD_ROOT/lib/libc.so.*`
214 cp -a math/libm.so $RPM_BUILD_ROOT/lib/%{_target_cpu}/`basename $RPM_BUILD_ROOT/lib/libm-*.so`
215 ln -sf `basename $RPM_BUILD_ROOT/lib/libm-*.so` $RPM_BUILD_ROOT/lib/%{_target_cpu}/`basename $RPM_BUILD_ROOT/lib/libm.so.*`
216 cp -a linuxthreads/libpthread.so $RPM_BUILD_ROOT/lib/%{_target_cpu}/`basename $RPM_BUILD_ROOT/lib/libpthread-*.so`
217 ln -sf `basename $RPM_BUILD_ROOT/lib/libpthread-*.so` $RPM_BUILD_ROOT/lib/%{_target_cpu}/`basename $RPM_BUILD_ROOT/lib/libpthread.so.*`
218 strip -R .comment $RPM_BUILD_ROOT/lib/{libc,libm,libpthread}-*.so
219 cd ..
220 %endif
221
222 # compatibility hack: this locale has vanished from glibc, but some other
223 # programs are still using it. Normally we would handle it in the %pre
224 # section but with glibc that is simply not an option
225 mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/locale/ru_RU/LC_MESSAGES
226
227 # Remove the files we don't want to distribute
228 rm -f $RPM_BUILD_ROOT%{_prefix}/%{_lib}/libNoVersion*
229 %ifarch sparc64 ia64 s390 s390x
230 rm -f $RPM_BUILD_ROOT/%{_lib}/libNoVersion*
231 %endif
232
233 # the man pages for the linuxthreads require special attention
234 make -C linuxthreads/man
235 mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
236 install -m 0644 linuxthreads/man/*.3thr $RPM_BUILD_ROOT%{_mandir}/man3
237 gzip -9nvf $RPM_BUILD_ROOT%{_mandir}/man3/*
238
239 if [ -d $RPM_BUILD_ROOT%{_prefix}/info -a "%{_infodir}" != "%{_prefix}/info" ]; then
240     mkdir -p $RPM_BUILD_ROOT%{_infodir}
241     mv -f $RPM_BUILD_ROOT%{_prefix}/info/* $RPM_BUILD_ROOT%{_infodir}
242     rm -rf $RPM_BUILD_ROOT%{_prefix}/info
243 fi
244
245 gzip -9nvf $RPM_BUILD_ROOT%{_infodir}/libc*
246
247 ln -sf libbsd-compat.a $RPM_BUILD_ROOT%{_prefix}/%{_lib}/libbsd.a
248
249 install -m 644 redhat/nsswitch.conf $RPM_BUILD_ROOT/etc/nsswitch.conf
250
251 # Take care of setuids
252 # -- new security review sez that this shouldn't be needed anymore
253 #chmod 755 $RPM_BUILD_ROOT%{_prefix}/libexec/pt_chown
254
255 # This is for ncsd - in glibc 2.2
256 install -m 644 nscd/nscd.conf $RPM_BUILD_ROOT/etc
257 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
258 install -m 755 nscd/nscd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/nscd
259
260 # Don't include ld.so.cache
261 rm -f $RPM_BUILD_ROOT/etc/ld.so.cache
262
263 # Include ld.so.conf
264 > $RPM_BUILD_ROOT/etc/ld.so.conf
265 chmod 644 $RPM_BUILD_ROOT/etc/ld.so.conf
266
267 # Install the upgrade program
268 install -m 700 build-%{_target_cpu}-linux/glibc_post_upgrade $RPM_BUILD_ROOT/usr/sbin/glibc_post_upgrade
269
270 # Strip binaries
271 strip -R .comment $RPM_BUILD_ROOT/sbin/* || :
272 strip -R .comment $RPM_BUILD_ROOT%{_prefix}/bin/* || :
273 strip -R .comment $RPM_BUILD_ROOT%{_prefix}/sbin/* || :
274 strip -R .comment $RPM_BUILD_ROOT%{_prefix}/libexec/pt_chown || :
275 strip -R .comment $RPM_BUILD_ROOT%{_prefix}/%{_lib}/gconv/* || :
276
277 # Hardlink identical locale files together
278 ALL_LC="LC_ADDRESS LC_COLLATE LC_CTYPE LC_IDENTIFICATION LC_MEASUREMENT \
279         LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER LC_TELEPHONE LC_TIME \
280         LC_MESSAGES/SYS_LC_MESSAGES"
281 for i in $RPM_BUILD_ROOT%{_prefix}/lib/locale/*; do
282   if [ ! -d $i ]; then continue; fi
283   for j in $ALL_LC; do
284     for k in $RPM_BUILD_ROOT%{_prefix}/lib/locale/*; do
285       if [ ! -d $k ]; then continue; fi
286       if [ $i = $k ]; then break; fi
287       if cmp -s $i/$j $k/$j; then ln -f $k/$j $i/$j; break; fi
288     done
289   done
290 done
291
292 # BUILD THE FILE LIST
293 find $RPM_BUILD_ROOT -type f -or -type l |
294         sed -e 's|.*/etc|%config &|' \
295             -e 's|.*/gconv/gconv-modules|%verify(not md5 size mtime) %config(noreplace) &|' > rpm.filelist.in
296 for n in %{_prefix}/share %{_prefix}/include %{_prefix}/lib/locale; do 
297     find ${RPM_BUILD_ROOT}${n} -type d | \
298         grep -v '%{_prefix}/share$' | \
299         sed "s/^/%dir /" >> rpm.filelist.in
300 done
301
302 # primary filelist
303 SHARE_LANG='s|.*/share/locale/\([^/_]\+\).*/LC_MESSAGES/.*\.mo|%lang(\1) &|'
304 LIB_LANG='s|.*/lib/locale/\([^/_]\+\)|%lang(\1) &|'
305 # rpm does not handle %lang() tagged files hardlinked together accross
306 # languages very well, temporarily disable
307 LIB_LANG=''
308 sed -e "s|$RPM_BUILD_ROOT||" -e "$LIB_LANG" -e "$SHARE_LANG" < rpm.filelist.in |
309         grep -v '/etc/localtime'  | \
310         grep -v '/etc/nsswitch.conf'  | \
311         grep -v '/etc/ld.so.conf'  | \
312         sort > rpm.filelist
313
314 grep '%{_prefix}/%{_lib}/lib.*_p\.a' < rpm.filelist > profile.filelist || :
315 egrep "(%{_prefix}/include)|(%{_infodir})" < rpm.filelist | 
316         grep -v %{_infodir}/dir > devel.filelist
317
318 mv rpm.filelist rpm.filelist.full
319 grep -v '%{_prefix}/%{_lib}/lib.*_p.a' rpm.filelist.full | 
320         egrep -v "(%{_prefix}/include)|(%{_infodir})" > rpm.filelist
321
322 grep '%{_prefix}/%{_lib}/lib.*\.a' < rpm.filelist >> devel.filelist
323 grep '%{_prefix}/%{_lib}/.*\.o' < rpm.filelist >> devel.filelist
324 grep '%{_prefix}/%{_lib}/lib.*\.so' < rpm.filelist >> devel.filelist
325 grep '%{_mandir}' < rpm.filelist >> devel.filelist
326
327 mv rpm.filelist rpm.filelist.full
328 grep -v '%{_prefix}/%{_lib}/lib.*\.a' < rpm.filelist.full |
329         grep -v '%{_prefix}/%{_lib}/.*\.o' |
330         grep -v '%{_prefix}/%{_lib}/lib.*\.so'|
331         grep -v '%{_mandir}' | 
332         grep -v 'nscd' > rpm.filelist
333         
334 grep '%{_prefix}/bin' < rpm.filelist >> common.filelist
335 grep '%{_prefix}/lib/locale' < rpm.filelist >> common.filelist
336 grep '%{_prefix}/libexec' < rpm.filelist >> common.filelist
337 grep '%{_prefix}/sbin/[^g]' < rpm.filelist >> common.filelist
338 grep '%{_prefix}/share' < rpm.filelist >> common.filelist
339
340 mv rpm.filelist rpm.filelist.full
341 grep -v '%{_prefix}/bin' < rpm.filelist.full |
342         grep -v '%{_prefix}/lib/locale' |
343         grep -v '%{_prefix}/libexec' | 
344         grep -v '%{_prefix}/sbin/[^g]' |
345         grep -v '%{_prefix}/share' > rpm.filelist
346
347 # /etc/localtime - we're proud of our timezone
348 rm -f $RPM_BUILD_ROOT/etc/localtime
349 cp -f $RPM_BUILD_ROOT%{_prefix}/share/zoneinfo/US/Eastern $RPM_BUILD_ROOT/etc/localtime
350 #ln -sf ..%{_prefix}/share/zoneinfo/US/Eastern $RPM_BUILD_ROOT/etc/localtime
351
352 # the last bit: more documentation
353 rm -rf documentation
354 mkdir documentation
355 cp linuxthreads/ChangeLog  documentation/ChangeLog.threads
356 cp linuxthreads/Changes documentation/Changes.threads
357 cp linuxthreads/README documentation/README.threads
358 cp linuxthreads/FAQ.html documentation/FAQ-threads.html
359 cp -r linuxthreads/Examples documentation/examples.threads
360 cp crypt/README.ufc-crypt documentation/README.ufc-crypt
361 cp timezone/README documentation/README.timezone
362 cp ChangeLog* documentation
363 gzip -9 documentation/ChangeLog*
364
365 %post -p /usr/sbin/glibc_post_upgrade
366
367 %postun -p /sbin/ldconfig
368
369 %post devel
370 /sbin/install-info %{_infodir}/libc.info.gz %{_infodir}/dir
371
372 %pre devel
373 # this used to be a link and it is causing nightmares now
374 if [ -L %{_prefix}/include/scsi ] ; then
375     rm -f %{_prefix}/include/scsi
376 fi
377
378 %preun devel
379 if [ "$1" = 0 ]; then
380     /sbin/install-info --delete %{_infodir}/libc.info.gz %{_infodir}/dir
381 fi
382
383 %pre -n nscd
384 /usr/sbin/useradd -M -o -r -d / -s /bin/false \
385         -c "NSCD Daemon" -u 28 nscd > /dev/null 2>&1 || :
386
387 %post -n nscd
388 /sbin/chkconfig --add nscd
389
390 %preun -n nscd
391 if [ $1 = 0 ] ; then
392     service nscd stop > /dev/null 2>&1
393     /sbin/chkconfig --del nscd
394 fi
395
396 %postun -n nscd
397 if [ $1 = 0 ] ; then
398     /usr/sbin/userdel nscd > /dev/null 2>&1 || :
399 fi
400 if [ "$1" -ge "1" ]; then
401     service nscd condrestart > /dev/null 2>&1 || :
402 fi
403
404 %clean
405 rm -rf "$RPM_BUILD_ROOT"
406 rm -f *.filelist*
407
408 %files -f rpm.filelist
409 %defattr(-,root,root)
410 %verify(not md5 size mtime) %config(noreplace) /etc/localtime
411 %verify(not md5 size mtime) %config(noreplace) /etc/nsswitch.conf
412 %verify(not md5 size mtime) %config(noreplace) /etc/ld.so.conf
413 %doc README NEWS INSTALL FAQ BUGS NOTES PROJECTS CONFORMANCE
414 %doc COPYING COPYING.LIB README.template README.libm
415 %doc hesiod/README.hesiod
416
417 %ifnarch %{auxarches}
418 %files -f common.filelist common
419 %defattr(-,root,root)
420 %doc documentation/*
421
422 %files -f devel.filelist devel
423 %defattr(-,root,root)
424
425 %files -f profile.filelist profile
426 %defattr(-,root,root)
427
428 %files -n nscd
429 %defattr(-,root,root)
430 %config(noreplace) /etc/nscd.conf
431 %config /etc/rc.d/init.d/nscd
432 %{_prefix}/sbin/nscd
433 %endif
434
435 %changelog
436 * Fri Apr  6 2001 Jakub Jelinek <jakub@redhat.com>
437 - support even 2.4.0 kernels on ia64, sparc64 and s390x
438 - include UTF-8 locales
439 - make gconv-modules %%config(noreplace)
440
441 * Fri Mar 23 2001 Jakub Jelinek <jakub@redhat.com>
442 - back out sunrpc changes
443
444 * Wed Mar 21 2001 Jakub Jelinek <jakub@redhat.com>
445 - update from CVS
446   - fix ia64 build
447   - fix pthread_getattr_np
448
449 * Fri Mar 16 2001 Jakub Jelinek <jakub@redhat.com>
450 - update from CVS
451   - run atexit() registered functions at dlclose time if they are in shared
452     libraries (#28625)
453   - add pthread_getattr_np API to make JVM folks happy
454
455 * Wed Mar 14 2001 Jakub Jelinek <jakub@redhat.com>
456 - require 2.4.1 instead of 2.4.0 on platforms where it required 2.4 kernel
457 - fix ldd behaviour on unresolved symbols
458 - remove nonsensical ldconfig warning, update osversion for the most
459   recent library with the same soname in the same directory instead (#31703)
460 - apply selected patches from CVS
461 - s390x spec file changes from Florian La Roche
462
463 * Wed Mar  7 2001 Jakub Jelinek <jakub@redhat.com>
464 - fix gencat (#30894)
465 - fix ldconfig changes from yesterday, fix LD_ASSUME_KERNEL handling
466
467 * Tue Mar  6 2001 Jakub Jelinek <jakub@redhat.com>
468 - update from CVS
469 - make pthread_attr_setstacksize consistent before and after pthread manager
470   is started (#28194)
471 - pass back struct sigcontext from pthread signal wrapper (on ia32 only so
472   far, #28493)
473 - on i686 ship both --enable-kernel 2.2.5 and 2.4.0 libc/libm/libpthread,
474   make ld.so pick the right one
475
476 * Sat Feb 17 2001 Preston Brown <pbrown@redhat.com>
477 - glib-common doesn't require glibc, until we can figure out how to get out of dependency hell.
478
479 * Sat Feb 17 2001 Jakub Jelinek <jakub@redhat.com>
480 - make glibc require particular version of glibc-common
481   and glibc-common prerequire glibc.
482
483 * Fri Feb 16 2001 Jakub Jelinek <jakub@redhat.com>
484 - glibc 2.2.2 release
485   - fix regex REG_ICASE bug seen in ksymoops
486
487 * Sat Feb 10 2001 Jakub Jelinek <jakub@redhat.com>
488 - fix regexec leaking memory (#26864)
489
490 * Fri Feb  9 2001 Jakub Jelinek <jakub@redhat.com>
491 - update from CVS
492   - fix ia64 build with gnupro
493   - make regex 64bit clean
494   - fix tgmath make check failures on alpha
495
496 * Tue Feb  6 2001 Jakub Jelinek <jakub@redhat.com>
497 - update again for ia64 DF_1_INITFIRST
498
499 * Fri Feb  2 2001 Jakub Jelinek <jakub@redhat.com>
500 - update from CVS
501   - fix getaddrinfo (#25437)
502   - support DF_1_INITFIRST (#25029)
503
504 * Wed Jan 24 2001 Jakub Jelinek <jakub@redhat.com>
505 - build all auxiliary arches with --enablekernel 2.4.0, those wanting
506   to run 2.2 kernels can downgrade to the base architecture glibc.
507
508 * Sat Jan 20 2001 Jakub Jelinek <jakub@redhat.com>
509 - remove %%lang() flags from %%{_prefix}/lib/locale files temporarily
510
511 * Sun Jan 14 2001 Jakub Jelinek <jakub@redhat.com>
512 - update to 2.2.1 final
513   - fix a pthread_kill_other_threads_np breakage (#23966)
514   - make static binaries using dlopen work on ia64 again
515 - fix a typo in glibc-common group
516
517 * Wed Jan 10 2001 Bernhard Rosenkraenzer <bero@redhat.com>
518 - devel requires glibc = %%{version}
519 - noreplace /etc/nscd.conf
520
521 * Wed Jan 10 2001 Jakub Jelinek <jakub@redhat.com>
522 - some more security fixes:
523   - don't look up LD_PRELOAD libs in cache for SUID apps
524     (because that bypasses SUID bit checking on the library)
525   - place output files for profiling SUID apps into /var/profile,
526     use O_NOFOLLOW for them
527   - add checks for $MEMUSAGE_OUTPUT and $SEGFAULT_OUTPUT_NAME
528 - hardlink identical locale files together
529 - add %%lang() tags to locale stuff
530 - remove ko_KR.utf8 for now, it is provided by locale-utf8 package
531
532 * Mon Jan  8 2001 Jakub Jelinek <jakub@redhat.com>
533 - add glibc-common subpackage
534 - fix alphaev6 memcpy (#22494)
535 - fix sys/cdefs.h (#22908)
536 - don't define stdin/stdout/stderr as macros for -traditional (#22913)
537 - work around a bug in IBM JDK (#22932, #23012)
538 - fix pmap_unset when network is down (#23176)
539 - move nscd in rc.d before netfs on shutdown
540 - fix $RESOLV_HOST_CONF in SUID apps (#23562)
541
542 * Fri Dec 15 2000 Jakub Jelinek <jakub@redhat.com>
543 - fix ftw and nftw
544
545 * Wed Dec 13 2000 Jakub Jelinek <jakub@redhat.com>
546 - fix fcvt (#22184)
547 - ldd /lib/ld-linux.so.2 is not crashing any longer again (#22197)
548 - fix gencat
549
550 * Mon Dec 11 2000 Jakub Jelinek <jakub@redhat.com>
551 - fix alpha htonl and alphaev6 stpcpy
552
553 * Sat Dec  9 2000 Jakub Jelinek <jakub@redhat.com>
554 - update to CVS to:
555   - fix getnameinfo (#21934)
556   - don't stomp on memory in rpath handling (#21544)
557   - fix setlocale (#21507)
558 - fix libNoVersion.so.1 loading code (#21579)
559 - use auxarches define in spec file for auxiliary
560   architectures (#21219)
561 - remove /usr/share directory from filelist (#21218)
562
563 * Sun Nov 19 2000 Jakub Jelinek <jakub@redhat.com>
564 - update to CVS to fix getaddrinfo
565
566 * Fri Nov 17 2000 Jakub Jelinek <jakub@redhat.com>
567 - update to CVS to fix freopen
568 - remove all alpha workarounds, not needed anymore
569
570 * Wed Nov 15 2000 Jakub Jelinek <jakub@redhat.com>
571 - fix dladdr bug on alpha/sparc32/sparc64
572 - fix Makefiles so that they run static tests properly
573
574 * Tue Nov 14 2000 Jakub Jelinek <jakub@redhat.com>
575 - update to CVS to fix ldconfig
576
577 * Thu Nov  9 2000 Jakub Jelinek <jakub@redhat.com>
578 - update to glibc 2.2 release
579
580 * Mon Nov  6 2000 Jakub Jelinek <jakub@redhat.com>
581 - update to CVS to:
582   - export __sysconf@@GLIBC_2.2 (#20417)
583
584 * Fri Nov  3 2000 Jakub Jelinek <jakub@redhat.com>
585 - merge to 2.1.97
586
587 * Mon Oct 30 2000 Jakub Jelinek <jakub@redhat.com>
588 - update to CVS, including:
589   - fix WORD_BIT/LONG_BIT definition in limits.h (#19088)
590   - fix hesiod (#19375)
591   - set LC_MESSAGES in zic/zdump for proper error message output (#19495)
592   - fix LFS fcntl when used with non-LFS aware kernels (#19730)
593
594 * Thu Oct 19 2000 Jakub Jelinek <jakub@redhat.com>
595 - fix alpha semctl (#19199)
596 - update to CVS, including:
597   - fix glibc headers for Compaq non-gcc compilers
598   - fix locale alias handling code (#18832)
599   - fix rexec on little endian machines (#18886)
600 - started writing changelog again
601
602 * Thu Aug 10 2000 Adrian Havill <havill@redhat.com>
603 - added ja ujis alias for backwards compatibility