modperl branch collapsed back to MAIN trunk, man!
[www.jankratochvil.net.git] / project / captive / doc / fig / Makefile.am
old mode 100755 (executable)
new mode 100644 (file)
similarity index 60%
rename from project/cvsutil/index.html.pl
rename to project/captive/doc/fig/Makefile.am
index f77cf06..b881b7f
@@ -1,7 +1,5 @@
-#! /usr/bin/perl
-# 
 # $Id$
-# Main page of 'My::Project::cvsutil'
+# automake source for the Makefile of project/captive/ documentation .fig-s
 # Copyright (C) 2003 Jan Kratochvil <project-www.jankratochvil.net@jankratochvil.net>
 # 
 # This program is free software; you can redistribute it and/or modify
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
 
 
-require 5.6.0; # at least 'use warnings;' but we need some 5.6.0+ modules anyway
-use vars qw($VERSION $CVS_ID);
-$VERSION=do { my @r=(q$Revision$=~/\d+/g); sprintf "%d.".("%03d"x$#r),@r; };
-$CVS_ID=q$Id$;
-use strict;
-use warnings;
-
-use My::Web;
-use project::cvsutil::ListItem;
-
+include $(top_srcdir)/Makefile-head.am
 
-My::Web->init_project(
-               "ListItem"=>\%My::Project::cvsutil::ListItem,
-               );
+EXTRA_DIST+= \
+               functype_native_fromunix.fig \
+               functype_patched_native_fromw32.fig \
+               functype_patched_pass_fromunix.fig \
+               functype_patched_pass_fromw32.fig \
+               functype_patched_wrap_fromunix.fig \
+               functype_patched_wrap_fromw32.fig \
+               functype_unpatched_native_fromw32.fig \
+               calltype_cdecl.fig \
+               calltype_stdcall.fig \
+               calltype_fastcall.fig
 
-My::Web->footer();
+CLEANFILES+= \
+               *.png \
+               *.gif