This commit was generated by cvs2svn to compensate for changes in r164,
[gnokii.git] / gnokii.spec
1 %define name gnokii
2 %define version 0.4.0pre3
3 %define release 1
4
5 Summary: Linux/Unix tool suite for Nokia mobile phones
6 Name: %{name}
7 Version: %{version}
8 Release: %{release}
9 Copyright: GPL
10 Packager: Pavel Janik ml. <Pavel.Janik@linux.cz>, Jan Derfinak <ja@mail.upjs.sk>
11 Group: Applications/Communications
12 Source: ftp://ftp.gnokii.org/pub/gnokii/%{name}-%{version}.tar.gz
13 BuildRoot: /var/tmp/%{name}-%{version}-root
14
15 %description
16 Gnokii is a Linux/Unix tool suite and (eventually) modem/fax driver for
17 Nokia's mobile phones, released under the GPL.
18
19 %package xgnokii
20 Summary: Graphical Linux/Unix tool suite for Nokia mobile phones.
21 Group: X11/Applications
22 %description xgnokii
23 Xgnokii is graphical Linux/Unix tool suite for Nokia's mobile phones. It
24 allows you to edit your contacts book, send/read SMS's from/in
25 computer and more other features.
26
27 %prep
28
29 %setup -q
30
31 %build
32 ./configure --prefix=/usr --with-x --enable-nls #--enable-debug --enable-rlpdebug
33 make
34
35 %install
36 rm -rf ${RPM_BUILD_ROOT}
37
38 make prefix=${RPM_BUILD_ROOT}/usr install
39
40 mkdir -p ${RPM_BUILD_ROOT}/etc/
41
42 sed 's#/usr/local/sbin/#/usr/sbin/#' <Docs/sample/gnokiirc >${RPM_BUILD_ROOT}/etc/gnokiirc
43
44 %pre
45 /usr/sbin/groupadd -r -f gnokii >/dev/null 2>&1
46
47 %postun
48 /usr/sbin/groupdel gnokii >/dev/null 2>&1
49
50 %clean
51 rm -rf ${RPM_BUILD_ROOT}
52
53 %files
54 %defattr(-,root,root)
55 %doc Docs/CREDITS Docs/DataCalls-QuickStart Docs/FAQ Docs/README
56 %doc Docs/README-3810 Docs/README-6110 Docs/README-2110 Docs/README-WIN32
57 %doc Docs/gettext-howto Docs/gnokii.nol Docs/gnokii-ir-howto Docs/packaging-howto
58 %doc Docs/README-dancall Docs/logos.txt Docs/gnokii.xpm Docs/Bugs
59 %doc Docs/sample/gnokiirc Docs/sample/options Docs/sample/pap-secrets
60 %doc Docs/sample/ppp-gnokii Docs/sample/ppp-on
61 %doc Docs/protocol/nk2110.txt Docs/protocol/nk3110.txt Docs/protocol/nk6110.txt Docs/protocol/nk6160.txt
62 %doc Docs/protocol/nk6185.txt Docs/protocol/nk640.txt Docs/protocol/nk7110.txt Docs/protocol/nokia.txt
63 %attr(0750, root, gnokii) /usr/bin/gnokii
64 %attr(0750, root, gnokii) /usr/sbin/gnokiid
65 %attr(4750, root, gnokii) /usr/sbin/mgnokiidev
66 %config /etc/gnokiirc
67
68 %files xgnokii
69 %defattr(-,root,root)
70 /usr/X11R6/bin/xgnokii
71 /usr/bin/todologo
72 /usr/share/xgnokii
73
74 %changelog
75
76 * Fri Sep 28 2001 Pawel Kot <pkot@linuxnews.pl>
77 - last minute fixes.
78
79 * Thu Sep 27 2001 Pawel Kot <pkot@linuxnews.pl>
80 - updates to 0.3.3 version - new docs, new ftp server
81
82 * Sun Sep  2 2001 Pawel Kot <pkot@linuxnews.pl>
83 - removes xlogos
84
85 * Thu Jan 11 2001 Pawel Kot <pkot@linuxnews.pl>
86 - misc updates
87
88 * Fri Oct 27 2000 Pavel Janik ml. <Pavel.Janik@linux.cz>
89 - todologo added to the package
90
91 * Mon May 15 2000 Pavel Janik ml. <Pavel.Janik@linux.cz>
92 - proper access rights for gnokiid, gnokii and mgnokiidev
93
94 * Sat May 13 2000 Pavel Janik ml. <Pavel.Janik@linux.cz>
95 - new doc files added
96
97 * Tue Mar 21 2000 Pavel Janik ml. <Pavel.Janik@linux.cz>
98 - permission on /usr/sbin fixed
99 - correct /etc/gnokiirc file
100
101 * Mon Mar 20 2000 Pavel Janik ml. <Pavel.Janik@linux.cz>
102 - mkdir of directories in install removed
103 - xgnokii package should contain lib/xgnokii directory
104
105 * Mon Mar 20 2000 Jan Derfinak <ja@mail.upjs.sk>
106 - split package into gnokii and xgnokii
107 - added configure
108 - correct xgnokii installation
109 - installation with make install
110 - fixing paths
111
112 * Thu Aug  5 1999 Pavel Janik ml. <Pavel.Janik@linux.cz>
113 - documentation files changed
114
115 * Thu Aug  5 1999 Pavel Janik ml. <Pavel.Janik@linux.cz>
116 - xkeyb and xlogos added to RPM package
117
118 * Sat Jul 24 1999 Pavel Janik ml. <Pavel.Janik@linux.cz>
119 - stripping of binaries
120
121 * Thu Jul 22 1999 Pavel Janik ml. <Pavel.Janik@linux.cz>
122 - gnokii.nol added - nice example for logo uploading
123
124 * Sun Jul 18 1999 Pavel Janik ml. <Pavel.Janik@linux.cz>
125 - mgnokiidev added to RPM package
126 - config file in /etc (it is not used now...)
127
128 * Sat Jul 10 1999 Pavel Janik ml. <Pavel.Janik@linux.cz>
129 - use of ~/.gnokiirc so not magic model stuff
130 - new doc files
131
132 * Mon Jun 28 1999 Pavel Janik ml. <Pavel.Janik@linux.cz>
133 - Nokia auth. protocol is there now
134 - xgnokii and gnokiid added to RPM
135
136 * Sun May  9 1999 Pavel Janik ml. <Pavel.Janik@linux.cz>
137 - included 6110-patch updated to my prepatches
138
139 * Thu May  6 1999 Pavel Janik ml. <Pavel.Janik@linux.cz>
140 - TODO-6110 file added to documentation files
141
142 * Sun Mar 28 1999 Pavel Janik ml. <Pavel.Janik@linux.cz>
143 - upgraded to gnokii-0.2.4
144 - 6110 version of gnokii added
145
146 * Fri Mar  5 1999 Pavel Janik ml. <Pavel.Janik@linux.cz>
147 - the first SPEC file for gnokii