2b090a966c702164bfa07ce38b813fe5deb065c8
[lldb-experimental.git] / lldb-experimental.spec
1 %global fast 0
2 %global use_jankratochvil_dwz 1
3 %global use_jankratochvil_rust 0
4 %global pkg_prefix /opt/%{name}
5 %global _unpackaged_files_terminate_build 0
6 # dwz: Couldn't find DIE referenced by DW_OP_GNU_parameter_ref
7 %global _find_debuginfo_dwz_opts %{nil}
8 # *** ERROR: ambiguous python shebang in /opt/lldb-experimental/...: #!/usr/bin/env python. Change it to python3 (or python2) explicitly.
9 %global __brp_mangle_shebangs %{nil}
10 %if %{fast}
11 %global debug_package %{nil}
12 %endif
13 Name: lldb-experimental
14 Version: 11.0.0
15 Release: 0.20200721snap2%{?dist}
16 Summary: Next generation high-performance debugger - experimental trunk snapshot
17 License: NCSA
18 URL: http://lldb.llvm.org/
19 Patch1: cmake-old.patch
20 ExclusiveArch: x86_64
21 BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
22 # https://src.fedoraproject.org/rpms/epydoc
23 #BuildRequires: epydoc
24 %if 0%{?rhel:1} && 0%{?rhel} <= 7
25 BuildRequires: llvm-toolset-7-cmake devtoolset-8-gcc-c++ python-devel python2-pyyaml
26 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
27 BuildRequires: swig3
28 # https://bugzilla.redhat.com/show_bug.cgi?id=1511892
29 %global __cmake /opt/rh/llvm-toolset-7/root/usr/bin/cmake3
30 %else
31 %if !0%{?rhel:1} || 0%{?rhel} > 8
32 BuildRequires: z3-devel
33 %endif
34 BuildRequires: cmake swig
35 BuildRequires: python3-devel python3-pygments python3-pyyaml
36 # removed in F31+
37 #BuildRequires: xar-devel
38 %endif
39
40 %description
41 LLDB is a next generation, high-performance debugger. It is built as a set
42 of reusable components which highly leverage existing libraries in the
43 larger LLVM Project, such as the Clang expression parser and LLVM
44 disassembler.
45 This package is an experimental trunk snapshot.
46 %if %{use_jankratochvil_dwz}
47 This package contains off-trunk DWZ support for Fedora debuginfos such as:
48   unsupported DW_FORM values: 0x1f20 0x1f21
49 %endif
50 %if %{use_jankratochvil_rust}
51 This package contains off-trunk Rust support:
52   https://github.com/rust-lang-nursery/lldb
53 %endif
54
55 %package devel
56 Summary: Development header files for %{name}
57 Requires: %{name}%{?_isa} = %{version}-%{release}
58
59 %description devel
60 The package contains header files for %{name}.
61
62 {-L,"-Wl,-rpath,"}%{pkg_prefix}/%{_lib} -I%{pkg_prefix}/include -llldb -lLLVMSupport -ltinfo -pthread
63
64 %ldconfig_scriptlets
65
66 %prep
67 %setup -q -c -T
68 OPTS="--depth 10000"
69 %if !0%{?rhel:1} || 0%{?rhel} > 7
70   OPTS="$OPTS --no-tags"
71 %endif
72 REF="reference"
73 # RHEL-7 does not support: --reference-if-able
74 CLONEOPTS="--single-branch"
75 test -d ../$REF/ && CLONEOPTS="$CLONEOPTS --reference ../$REF"
76 # 2500 = 1 month in 2019
77 git clone $OPTS $CLONEOPTS https://github.com/llvm/llvm-project.git .
78 %if %{use_jankratochvil_dwz} || %{use_jankratochvil_rust}
79 git remote remove jankratochvil || :
80 #git remote add jankratochvil git://git.jankratochvil.net/lldb
81 git remote add jankratochvil https://github.com/jankratochvil/llvm-project.git
82 git fetch $OPTS jankratochvil
83 git config user.email jankratochvil@copr.fedorainfracloud.org
84 git config user.name jankratochvil
85 %endif
86 %if %{use_jankratochvil_dwz}
87 git merge jankratochvil/dwz
88 %endif
89 %if %{use_jankratochvil_rust}
90 # '-c merge.renames=false' is F-29+.
91 # '-c merge.renameLimit=0' has no effect.
92 git -c merge.renameLimit=1 merge jankratochvil/rust
93 %endif
94 %patch1 -p1
95
96 %build
97 mkdir build-release
98 cd    build-release
99
100 FLAGS="%{optflags}"
101
102 # lldb/scripts/LLDBWrapPython.cpp:23699:70: error: format not a string literal and no format arguments [-Werror=format-security]
103 FLAGS="$FLAGS -Wno-error=format-security"
104
105 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
106 . /opt/rh/devtoolset-8/enable
107 # -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
108 # https://bugzilla.redhat.com/show_bug.cgi?id=1590678
109 # Set %%{fast} only after %%debug_package above.
110 %global fast 1
111 %endif
112 %if %{fast}
113 FLAGS="$FLAGS -g0"
114 %else
115 # -fno-reorder-blocks-and-partition:
116 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
117 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
118 FLAGS="$FLAGS -gsplit-dwarf -fno-reorder-blocks-and-partition"
119 %endif
120
121 CFLAGS="$FLAGS"
122 CXXFLAGS="$FLAGS"
123
124 # This is default - changing it breaks the testsuite: -DLLVM_LINK_LLVM_DYLIB=OFF
125 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental
126 # -fdebug-types-section && -DLLVM_USE_LINKER=gold:
127 # ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
128 %cmake ../llvm \
129   -DCMAKE_INSTALL_PREFIX=%{buildroot}%{pkg_prefix} \
130   -DBUILD_SHARED_LIBS=OFF \
131 %if %{fast}
132   -DCMAKE_BUILD_TYPE=Release \
133 %else
134   -DCMAKE_BUILD_TYPE=RelWithDebInfo \
135 %endif
136   -DLLVM_ENABLE_PROJECTS="lldb;clang;lld" \
137   -DLLVM_TARGETS_TO_BUILD=X86 \
138   -DLLVM_BUILD_TOOLS=OFF \
139   -DLLVM_USE_LINKER=gold \
140   $(: file INSTALL cannot find build-release/lib/python3.6 ) \
141 %if 0%{?__isa_bits} == 64
142   -DLLVM_LIBDIR_SUFFIX=64 \
143 %else
144   -DLLVM_LIBDIR_SUFFIX= \
145 %endif
146   -DLLDB_DISABLE_CURSES=OFF \
147   -DLLDB_DISABLE_LIBEDIT=OFF \
148   -DLLDB_DISABLE_PYTHON=OFF \
149   #
150 # Only Rawhide cmake creates this subdirectory.
151 cd *-redhat-linux-gnu || :
152 %make_build
153
154 %install
155 mkdir -p %{buildroot}%{pkg_prefix}
156 (function revline {
157    echo "$(cd $1;git rev-parse ${2:-origin/master}) ${2:-$1}"
158  }
159  revline .
160 %if %{use_jankratochvil_dwz}
161  revline . jankratochvil/dwz
162 %endif
163 %if %{use_jankratochvil_rust}
164  revline . jankratochvil/rust
165 %endif
166 ) >%{buildroot}%{pkg_prefix}/HEAD
167 cd build-release
168 # Only Rawhide cmake creates this subdirectory.
169 cd *-redhat-linux-gnu || :
170 %make_install
171 mkdir -p %{buildroot}%{_bindir}
172 # lldb-mi
173 for i in lldb;do
174   echo >%{buildroot}%{_bindir}/${i}-experimental -e '#! /bin/bash\nexec %{pkg_prefix}/bin/'$i' "$@"'
175   chmod +x %{buildroot}%{_bindir}/${i}-experimental
176 done
177
178 # remove static libraries
179 rm -fv %{buildroot}%{_libdir}/*.a
180
181 ### python: fix liblldb.so -> liblldb.so.7 symlink target
182 (cd %{buildroot}%{pkg_prefix}/%{_lib}/python*/site-packages/lldb/
183  ln -vsf "$(dirname $(readlink _lldb.so))/$(readlink $(readlink _lldb.so))" _lldb.so
184 )
185
186 %files
187 %{_bindir}/lldb-experimental
188 #{_bindir}/lldb-mi-experimental
189 %{pkg_prefix}/HEAD
190 %{pkg_prefix}/bin/lldb
191 %{pkg_prefix}/bin/lldb-server
192 #{pkg_prefix}/bin/lldb-mi
193 %{pkg_prefix}/bin/lldb-argdumper
194 # RHEL-7: File not found by glob: .../lib{lldb,clang,LLVM}*.so.*
195 %{pkg_prefix}/%{_lib}/libl*.so.*
196 %{pkg_prefix}/%{_lib}/python*
197
198 %files devel
199 %{pkg_prefix}/include
200 %{pkg_prefix}/%{_lib}/lib[^l]*.so.*
201 %{pkg_prefix}/%{_lib}/*.so
202 %{pkg_prefix}/%{_lib}/*.a
203
204 %changelog
205 * Thu Apr  5 2018 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.0-0.1
206 - Initial import for COPR, based on Fedora package 'lldb'.