(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index d7b384f..4bcea20 100644 (file)
@@ -1,6 +1,7 @@
 %global fast 0
 %global use_jankratochvil_dwz 1
 %global use_jankratochvil_uniqaddr 1
+%global use_jankratochvil_ocaml_doc 1
 %global use_jankratochvil_rust 0
 %global pkg_prefix /opt/%{name}
 %global _unpackaged_files_terminate_build 0
@@ -18,7 +19,7 @@
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210610snap0%{?dist}
+Release: 0.20210610snap1%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -96,6 +97,10 @@ This package contains off-trunk DWZ support for Fedora debuginfos such as:
 This package contains off-trunk:
   Support for libstdc++11 std::unique_ptr: [[no_unique_address]]
 %endif
+%if %{use_jankratochvil_ocaml_doc}
+This package contains off-trunk:
+  ocaml_doc fix
+%endif
 %if %{use_jankratochvil_rust}
 This package contains off-trunk Rust support:
   https://github.com/rust-lang-nursery/lldb
@@ -167,7 +172,7 @@ CLONEOPTS="--single-branch"
 test -d ../$REF/ && CLONEOPTS="$CLONEOPTS --reference ../$REF"
 # 2500 = 1 month in 2019
 git clone $OPTS $CLONEOPTS https://github.com/llvm/llvm-project.git .
-%if %{use_jankratochvil_dwz} || %{use_jankratochvil_rust}
+%if 1
 git remote remove jankratochvil || :
 #git remote add jankratochvil git://git.jankratochvil.net/lldb
 git remote add jankratochvil https://github.com/jankratochvil/llvm-project.git
@@ -181,6 +186,9 @@ git merge jankratochvil/dwz
 %if %{use_jankratochvil_uniqaddr}
 git merge jankratochvil/layout5
 %endif
+%if %{use_jankratochvil_ocaml_doc}
+git merge jankratochvil/ocaml_doc
+%endif
 %if %{use_jankratochvil_rust}
 # '-c merge.renames=false' is F-29+.
 # '-c merge.renameLimit=0' has no effect.
@@ -255,7 +263,6 @@ LDFLAGS="$LDFLAGS -flto -Wl,--build-id=sha1"
   -DLLVM_ENABLE_ASSERTIONS=ON \
   #
 %cmake_build
-%cmake_build ocaml_doc
 
 %install
 mkdir -p %{buildroot}%{pkg_prefix}