(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index f83544a..e6e1090 100644 (file)
@@ -3,6 +3,7 @@
 %global use_jankratochvil_layout5 1
 %global use_jankratochvil_ocaml_doc 1
 %global use_jankratochvil_rust 0
+%global use_nealsid_lldb_editline_remove_wchar 1
 %global pkg_prefix /opt/%{name}
 %global _unpackaged_files_terminate_build 0
 # dwz: Couldn't find DIE referenced by DW_OP_GNU_parameter_ref
@@ -19,7 +20,7 @@
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210707snap0%{?dist}
+Release: 0.20210710snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -105,6 +106,10 @@ This package contains off-trunk:
 This package contains off-trunk Rust support:
   https://github.com/rust-lang-nursery/lldb
 %endif
+%if %{use_nealsid_lldb_editline_remove_wchar}
+This package contains:
+  https://github.com/nealsid/llvm-project/tree/lldb-editline-remove-wchar
+%endif
 
 %package devel
 Summary: Development header files for %{name}
@@ -194,6 +199,10 @@ git merge jankratochvil/ocaml_doc
 # '-c merge.renameLimit=0' has no effect.
 git -c merge.renameLimit=1 merge jankratochvil/rust
 %endif
+%if %{use_nealsid_lldb_editline_remove_wchar}
+git remote add nealsid https://github.com/nealsid/llvm-project.git
+git merge nealsid/lldb-editline-remove-wchar
+%endif
 
 %build
 FLAGS="%{optflags}"