(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 1fa1de1..15c3311 100644 (file)
@@ -18,7 +18,7 @@
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210604snap2%{?dist}
+Release: 0.20210609snap2%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -29,6 +29,9 @@ Source0: empty.tar
 BuildRequires: clang git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
+%if 0%{?rhel} > 8 || 0%{?fedora} >= 34
+BuildRequires:  ocaml-findlib ocaml-ctypes ocaml-ocamldoc
+%endif
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
 #+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
 #Compiling /quad/home/jkratoch/redhat/lldb-experimental/BUILDROOT/lldb-experimental-13.0.0-0.20210206snap1.el7.x86_64/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py ...
@@ -37,7 +40,7 @@ BuildRequires: clang git libedit-devel libatomic libxml2-devel zlib-devel valgri
 #                      ^
 #SyntaxError: invalid syntax
 %global __python /usr/bin/python3
-BuildRequires: devtoolset-8-gcc-c++
+BuildRequires: llvm-toolset-7.0-clang llvm-toolset-7.0-lld
 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
 BuildRequires: swig3
 BuildRequires: rh-git218-git-core
@@ -191,7 +194,7 @@ FLAGS="%{optflags}"
 FLAGS="$FLAGS -Wno-error=format-security"
 
 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
-. /opt/rh/devtoolset-8/enable
+. /opt/rh/llvm-toolset-7.0/enable
 . /opt/rh/rh-python38/enable
 %endif
 %if %{fast}
@@ -205,8 +208,21 @@ FLAGS="$FLAGS -fdebug-types-section"
 %endif
 %endif
 
-CFLAGS="$FLAGS"
-CXXFLAGS="$FLAGS"
+# clang-12: error: unsupported argument 'auto' to option 'flto='
+# clang-12: warning: optimization flag '-ffat-lto-objects' is not supported [-Wignored-optimization-argument]
+FLAGS="$(echo $FLAGS|sed 's/ -flto=auto -ffat-lto-objects / -flto /')"
+# ld.lld: error: relocation R_X86_64_PC32 cannot be used against symbol ...; recompile with -fPIC
+FLAGS="$FLAGS -fPIC"
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+# clang: error: unknown argument: '-fstack-protector-strong'
+FLAGS="$(echo $FLAGS|sed 's/ -fstack-protector-strong / /')"
+%endif
+
+export CFLAGS="$FLAGS"
+export CXXFLAGS="$FLAGS"
+
+export LDFLAGS="%{build_ldflags}"
+LDFLAGS="$LDFLAGS -flto -Wl,--build-id=sha1"
 
 # This is default - changing it breaks the testsuite: -DLLVM_LINK_LLVM_DYLIB=OFF
 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental