(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 65c58c9..15c3311 100644 (file)
@@ -18,7 +18,7 @@
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210604snap7%{?dist}
+Release: 0.20210609snap2%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -29,6 +29,9 @@ Source0: empty.tar
 BuildRequires: clang git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
+%if 0%{?rhel} > 8 || 0%{?fedora} >= 34
+BuildRequires:  ocaml-findlib ocaml-ctypes ocaml-ocamldoc
+%endif
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
 #+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
 #Compiling /quad/home/jkratoch/redhat/lldb-experimental/BUILDROOT/lldb-experimental-13.0.0-0.20210206snap1.el7.x86_64/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py ...
@@ -215,8 +218,11 @@ FLAGS="$FLAGS -fPIC"
 FLAGS="$(echo $FLAGS|sed 's/ -fstack-protector-strong / /')"
 %endif
 
-CFLAGS="$FLAGS"
-CXXFLAGS="$FLAGS"
+export CFLAGS="$FLAGS"
+export CXXFLAGS="$FLAGS"
+
+export LDFLAGS="%{build_ldflags}"
+LDFLAGS="$LDFLAGS -flto -Wl,--build-id=sha1"
 
 # This is default - changing it breaks the testsuite: -DLLVM_LINK_LLVM_DYLIB=OFF
 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental