+NVR-BUMP,+COPR-BUILD
[lldb-experimental.git] / lldb-experimental.spec
index 175fdff..1a0fb82 100644 (file)
@@ -7,35 +7,71 @@
 %global _find_debuginfo_dwz_opts %{nil}
 # *** ERROR: ambiguous python shebang in /opt/lldb-experimental/...: #!/usr/bin/env python. Change it to python3 (or python2) explicitly.
 %global __brp_mangle_shebangs %{nil}
+%if (0%{?rhel:1} && 0%{?rhel} <= 7)
+# -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
+# https://bugzilla.redhat.com/show_bug.cgi?id=1590678
+%global fast 1
+%endif
 %if %{fast}
 %global debug_package %{nil}
 %endif
 Name: lldb-experimental
-Version: 11.0.0
-Release: 0.20200704snap0%{?dist}
+Version: 13.0.0
+Release: 0.20210212snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
 ExclusiveArch: x86_64
-BuildRequires: gcc-c++ git libedit-devel libatomic ninja-build libxml2-devel zlib-devel valgrind-devel libpfm-devel
+BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
-BuildRequires: llvm-toolset-7-cmake devtoolset-8-gcc-c++ python-devel python2-pyyaml
+#+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
+#Compiling /quad/home/jkratoch/redhat/lldb-experimental/BUILDROOT/lldb-experimental-13.0.0-0.20210206snap1.el7.x86_64/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py ...
+#  File "/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py", line 883
+#    def IsValid(self) -> "bool":
+#                      ^
+#SyntaxError: invalid syntax
+%global __python /usr/bin/python3
+BuildRequires: devtoolset-8-gcc-c++
 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
 BuildRequires: swig3
+BuildRequires: rh-git218-git-core
+BuildRequires: rh-python38-python-devel rh-python38-python-pyyaml
 # https://bugzilla.redhat.com/show_bug.cgi?id=1511892
-%global __cmake /opt/rh/llvm-toolset-7/root/usr/bin/cmake3
-%global ninjabuild ninja-build
+BuildRequires: cmake3
+%global cmake %{cmake3}
+%global cmake_build %{cmake3_build}
+%global cmake_install %{cmake3_install}
 %else
-%if !0%{?rhel:1} || 0%{?rhel} > 8
-BuildRequires: z3-devel
+# FIXME: CentOS-8:
+# CMake Error at CMakeLists.txt:3 (cmake_minimum_required):
+#   CMake 3.13.4 or higher is required.  You are running version 3.11.4
+%if 0%{?rhel} != 8
+BuildRequires: cmake
+%else
+# cmake-3.17.0-1.el8:
+BuildRequires: wget expat-devel
+BuildRequires: /usr/bin/sphinx-build curl-devel emacs jsoncpp-devel openssl-devel pkgconfig(Qt5Widgets) rhash-devel
+# -- Could NOT find LibArchive: Found unsuitable version "3.3.2", but required is at least "3.3.3" (found /usr/lib64/libarchive.so)
+# CMAKE_USE_SYSTEM_LIBARCHIVE is ON but LibArchive is not found!
+#BuildRequires: libarchive-devel
+# -- Could NOT find LibUV: Found unsuitable version "", but required is at least "1.10.0" (found LibUV_LIBRARY-NOTFOUND)
+# CMAKE_USE_SYSTEM_LIBUV is ON but a libuv is not found!
+# [local]=https://kojipkgs.fedoraproject.org/repos/epel8-build/latest/$basearch/
+#BuildRequires: libuv-devel
+# CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
+# Please set them or make sure they are set and tested correctly in the CMake files:
+# BZIP2_LIBRARY
+BuildRequires: bzip2-devel
 %endif
-BuildRequires: cmake swig
+BuildRequires: swig
 BuildRequires: python3-devel python3-pygments python3-pyyaml
 # removed in F31+
 #BuildRequires: xar-devel
-%global ninjabuild ninja
+%if !0%{?rhel:1} || 0%{?rhel} > 8
+BuildRequires: z3-devel
+%endif
 %endif
 
 %description
@@ -65,6 +101,49 @@ The package contains header files for %{name}.
 %ldconfig_scriptlets
 
 %prep
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+# git clone --depth 10000 --single-branch --reference ../reference https://github.com/llvm/llvm-project.git .
+# fatal: git fetch-pack: expected shallow list
+. /opt/rh/rh-git218/enable
+# CMake Warning at ../lldb/cmake/modules/FindPythonInterpAndLibs.cmake:10 (find_package):
+#   By not providing "FindPython3.cmake" in CMAKE_MODULE_PATH this project has
+#   asked CMake to find a package configuration file provided by "Python3", but
+#   CMake did not find one.
+#   Could not find a package configuration file provided by "Python3" with any
+#   of the following names:
+#     Python3Config.cmake
+#     python3-config.cmake
+#   Add the installation prefix of "Python3" to CMAKE_PREFIX_PATH or set
+#   "Python3_DIR" to a directory containing one of the above files.  If
+#   "Python3" provides a separate development package or SDK, be sure it has
+#   been installed.
+# Call Stack (most recent call first):
+#   ../lldb/cmake/modules/FindPythonInterpAndLibs.cmake:71 (FindPython3)
+#   ../lldb/cmake/modules/LLDBConfig.cmake:48 (find_package)
+#   ../lldb/cmake/modules/LLDBConfig.cmake:59 (add_optional_dependency)
+#   ../lldb/CMakeLists.txt:28 (include)
+. /opt/rh/rh-python38/enable
+%endif
+%if 0%{?rhel} == 8
+cmakesrc=cmake-3.18.3-1.fc33.src.rpm
+rm -rf $cmakesrc $cmakesrc.tgz $cmakesrc.d
+wget http://ftp.fi.muni.cz/pub/linux/fedora/linux/releases/33/Everything/source/tree/Packages/c/$cmakesrc
+rpm2archive $cmakesrc
+(mkdir $cmakesrc.d
+ cd $cmakesrc.d
+ tar xzf ../$cmakesrc.tgz
+ # FIXME: Why? FIXME: No longer needed?
+ #for i in .[a-z]*;do mv $i `echo $i|sed 's/^\.//'`;done
+ sed -i -e 's/qt-gui /&--no-system-libarchive --no-system-libuv /' cmake.spec
+ rpmbuild --define "_topdir $PWD" --define "_builddir $PWD" --define "_rpmdir $PWD" --define "_sourcedir $PWD" --define "_specdir $PWD" --define "_srcrpmdir $PWD" -bc --nodeps cmake.spec
+)
+%global __cmake %(echo %{_builddir}/cmake-*.d/cmake-*/*/bin/cmake)
+%global __cmake_builddir .
+%global cmake_build \
+  %__cmake --build "%{__cmake_builddir}" %{?_smp_mflags} --verbose
+%global cmake_install \
+  DESTDIR="%{buildroot}" %__cmake --install "%{__cmake_builddir}"
+%endif
 %setup -q -c -T
 OPTS="--depth 10000"
 %if !0%{?rhel:1} || 0%{?rhel} > 7
@@ -94,9 +173,6 @@ git -c merge.renameLimit=1 merge jankratochvil/rust
 %endif
 
 %build
-mkdir build-release
-cd    build-release
-
 FLAGS="%{optflags}"
 
 # lldb/scripts/LLDBWrapPython.cpp:23699:70: error: format not a string literal and no format arguments [-Werror=format-security]
@@ -104,10 +180,7 @@ FLAGS="$FLAGS -Wno-error=format-security"
 
 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
 . /opt/rh/devtoolset-8/enable
-# -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
-# https://bugzilla.redhat.com/show_bug.cgi?id=1590678
-# Set %%{fast} only after %%debug_package above.
-%global fast 1
+. /opt/rh/rh-python38/enable
 %endif
 %if %{fast}
 FLAGS="$FLAGS -g0"
@@ -115,7 +188,7 @@ FLAGS="$FLAGS -g0"
 # -fno-reorder-blocks-and-partition:
 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
-FLAGS="$FLAGS -gsplit-dwarf -fno-reorder-blocks-and-partition"
+FLAGS="$FLAGS -fdebug-types-section"
 %endif
 
 CFLAGS="$FLAGS"
@@ -125,10 +198,8 @@ CXXFLAGS="$FLAGS"
 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental
 # -fdebug-types-section && -DLLVM_USE_LINKER=gold:
 # ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
-%cmake ../llvm \
-  -GNinja \
-  -DCMAKE_INSTALL_PREFIX=%{buildroot}%{pkg_prefix} \
-  -DBUILD_SHARED_LIBS=OFF \
+%cmake llvm \
+  -DCMAKE_INSTALL_PREFIX=%{pkg_prefix} \
 %if %{fast}
   -DCMAKE_BUILD_TYPE=Release \
 %else
@@ -148,7 +219,7 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
   #
-%{ninjabuild} -v
+%cmake_build
 
 %install
 mkdir -p %{buildroot}%{pkg_prefix}
@@ -163,8 +234,7 @@ mkdir -p %{buildroot}%{pkg_prefix}
  revline . jankratochvil/rust
 %endif
 ) >%{buildroot}%{pkg_prefix}/HEAD
-cd build-release
-%{ninjabuild} -v install
+%cmake_install
 mkdir -p %{buildroot}%{_bindir}
 # lldb-mi
 for i in lldb;do
@@ -179,6 +249,7 @@ rm -fv %{buildroot}%{_libdir}/*.a
 (cd %{buildroot}%{pkg_prefix}/%{_lib}/python*/site-packages/lldb/
  ln -vsf "$(dirname $(readlink _lldb.so))/$(readlink $(readlink _lldb.so))" _lldb.so
 )
+du -shc $PWD %{buildroot}
 
 %files
 %{_bindir}/lldb-experimental
@@ -191,12 +262,11 @@ rm -fv %{buildroot}%{_libdir}/*.a
 # RHEL-7: File not found by glob: .../lib{lldb,clang,LLVM}*.so.*
 %{pkg_prefix}/%{_lib}/libl*.so.*
 %{pkg_prefix}/%{_lib}/python*
+%{pkg_prefix}/%{_lib}/lib[^l]*.so.*
 
 %files devel
 %{pkg_prefix}/include
-%{pkg_prefix}/%{_lib}/lib[^l]*.so.*
 %{pkg_prefix}/%{_lib}/*.so
-%{pkg_prefix}/%{_lib}/*.a
 
 %changelog
 * Thu Apr  5 2018 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.0-0.1