+NVR-BUMP,+COPR-BUILD
[lldb-experimental.git] / lldb-experimental.spec
index f8fb417..1a0fb82 100644 (file)
@@ -1,6 +1,4 @@
-# https://download.copr.fedorainfracloud.org/results/jankratochvil/lldb/fedora-rawhide-x86_64/01574351-lldb-experimental/builder-live.log.gz
-# No space left on device.
-%global fast 1
+%global fast 0
 %global use_jankratochvil_dwz 1
 %global use_jankratochvil_rust 0
 %global pkg_prefix /opt/%{name}
@@ -9,12 +7,17 @@
 %global _find_debuginfo_dwz_opts %{nil}
 # *** ERROR: ambiguous python shebang in /opt/lldb-experimental/...: #!/usr/bin/env python. Change it to python3 (or python2) explicitly.
 %global __brp_mangle_shebangs %{nil}
+%if (0%{?rhel:1} && 0%{?rhel} <= 7)
+# -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
+# https://bugzilla.redhat.com/show_bug.cgi?id=1590678
+%global fast 1
+%endif
 %if %{fast}
 %global debug_package %{nil}
 %endif
 Name: lldb-experimental
-Version: 12.0.0
-Release: 0.20201107snap0%{?dist}
+Version: 13.0.0
+Release: 0.20210212snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -23,6 +26,13 @@ BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valg
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
+#+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
+#Compiling /quad/home/jkratoch/redhat/lldb-experimental/BUILDROOT/lldb-experimental-13.0.0-0.20210206snap1.el7.x86_64/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py ...
+#  File "/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py", line 883
+#    def IsValid(self) -> "bool":
+#                      ^
+#SyntaxError: invalid syntax
+%global __python /usr/bin/python3
 BuildRequires: devtoolset-8-gcc-c++
 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
 BuildRequires: swig3
@@ -122,8 +132,8 @@ rpm2archive $cmakesrc
 (mkdir $cmakesrc.d
  cd $cmakesrc.d
  tar xzf ../$cmakesrc.tgz
- # FIXME: Why?
- for i in .[a-z]*;do mv $i `echo $i|sed 's/^\.//'`;done
+ # FIXME: Why? FIXME: No longer needed?
#for i in .[a-z]*;do mv $i `echo $i|sed 's/^\.//'`;done
  sed -i -e 's/qt-gui /&--no-system-libarchive --no-system-libuv /' cmake.spec
  rpmbuild --define "_topdir $PWD" --define "_builddir $PWD" --define "_rpmdir $PWD" --define "_sourcedir $PWD" --define "_specdir $PWD" --define "_srcrpmdir $PWD" -bc --nodeps cmake.spec
 )
@@ -171,10 +181,6 @@ FLAGS="$FLAGS -Wno-error=format-security"
 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
 . /opt/rh/devtoolset-8/enable
 . /opt/rh/rh-python38/enable
-# -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
-# https://bugzilla.redhat.com/show_bug.cgi?id=1590678
-# Set %%{fast} only after %%debug_package above.
-%global fast 1
 %endif
 %if %{fast}
 FLAGS="$FLAGS -g0"
@@ -194,7 +200,6 @@ CXXFLAGS="$FLAGS"
 # ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
 %cmake llvm \
   -DCMAKE_INSTALL_PREFIX=%{pkg_prefix} \
-  -DBUILD_SHARED_LIBS=OFF \
 %if %{fast}
   -DCMAKE_BUILD_TYPE=Release \
 %else
@@ -244,6 +249,7 @@ rm -fv %{buildroot}%{_libdir}/*.a
 (cd %{buildroot}%{pkg_prefix}/%{_lib}/python*/site-packages/lldb/
  ln -vsf "$(dirname $(readlink _lldb.so))/$(readlink $(readlink _lldb.so))" _lldb.so
 )
+du -shc $PWD %{buildroot}
 
 %files
 %{_bindir}/lldb-experimental
@@ -256,12 +262,11 @@ rm -fv %{buildroot}%{_libdir}/*.a
 # RHEL-7: File not found by glob: .../lib{lldb,clang,LLVM}*.so.*
 %{pkg_prefix}/%{_lib}/libl*.so.*
 %{pkg_prefix}/%{_lib}/python*
+%{pkg_prefix}/%{_lib}/lib[^l]*.so.*
 
 %files devel
 %{pkg_prefix}/include
-%{pkg_prefix}/%{_lib}/lib[^l]*.so.*
 %{pkg_prefix}/%{_lib}/*.so
-%{pkg_prefix}/%{_lib}/*.a
 
 %changelog
 * Thu Apr  5 2018 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.0-0.1