(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index f7d7d9b..1fa1de1 100644 (file)
@@ -18,7 +18,7 @@
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210531snap0%{?dist}
+Release: 0.20210604snap2%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -26,7 +26,7 @@ ExclusiveArch: x86_64
 # Source zero not found
 # https://bugzilla.redhat.com/show_bug.cgi?id=1938320
 Source0: empty.tar
-BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
+BuildRequires: clang git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
@@ -48,6 +48,7 @@ BuildRequires: cmake3
 %global cmake_build %{cmake3_build}
 %global cmake_install %{cmake3_install}
 %else
+BuildRequires: lld
 # FIXME: CentOS-8:
 # CMake Error at CMakeLists.txt:3 (cmake_minimum_required):
 #   CMake 3.13.4 or higher is required.  You are running version 3.11.4
@@ -204,21 +205,20 @@ FLAGS="$FLAGS -fdebug-types-section"
 %endif
 %endif
 
-# Rawhide Gold on lldb-experimental build: invalid symbol table name index && section_header_offset: bad shndx
-# https://bugzilla.redhat.com/show_bug.cgi?id=1954141
-%if 0%{?fedora} == 35
-FLAGS="$FLAGS -fno-lto"
-%endif
-
 CFLAGS="$FLAGS"
 CXXFLAGS="$FLAGS"
 
 # This is default - changing it breaks the testsuite: -DLLVM_LINK_LLVM_DYLIB=OFF
 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental
-# -fdebug-types-section && -DLLVM_USE_LINKER=gold:
-# ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
 %cmake llvm \
   -DCMAKE_INSTALL_PREFIX=%{pkg_prefix} \
+  -DCMAKE_C_COMPILER=clang \
+  -DCMAKE_CXX_COMPILER=clang++ \
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+  -DLLVM_USE_LINKER=gold \
+%else
+  -DLLVM_USE_LINKER=lld \
+%endif
 %if %{fast}
   -DCMAKE_BUILD_TYPE=Release \
 %else
@@ -227,7 +227,6 @@ CXXFLAGS="$FLAGS"
   -DLLVM_ENABLE_PROJECTS="lldb;clang;lld" \
   -DLLVM_TARGETS_TO_BUILD=X86 \
   -DLLVM_BUILD_TOOLS=OFF \
-  -DLLVM_USE_LINKER=gold \
   $(: file INSTALL cannot find build-release/lib/python3.6 ) \
 %if 0%{?__isa_bits} == 64
   -DLLVM_LIBDIR_SUFFIX=64 \