(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 72c1c17..2051dcf 100644 (file)
 %endif
 Name: lldb-experimental
 Version: 11.0.0
-Release: 0.20200722snap3%{?dist}
+Release: 0.20200723snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
-Patch1: cmake-old.patch
+Patch1: cmake-old1.patch
+Patch2: cmake-old2.patch
 ExclusiveArch: x86_64
 BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
@@ -97,7 +98,8 @@ git merge jankratochvil/dwz
 # '-c merge.renameLimit=0' has no effect.
 git -c merge.renameLimit=1 merge jankratochvil/rust
 %endif
-%patch1 -p1
+%patch2 -p1 -R
+%patch1 -p1 -R
 
 %build
 FLAGS="%{optflags}"
@@ -118,7 +120,7 @@ FLAGS="$FLAGS -g0"
 # -fno-reorder-blocks-and-partition:
 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
-FLAGS="$FLAGS -gsplit-dwarf -fno-reorder-blocks-and-partition"
+FLAGS="$FLAGS -fdebug-types-section"
 %endif
 
 CFLAGS="$FLAGS"