(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index b51dc94..2051dcf 100644 (file)
 %endif
 Name: lldb-experimental
 Version: 11.0.0
-Release: 0.20200721snap1%{?dist}
+Release: 0.20200723snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
-Patch1: cmake-old.patch
+Patch1: cmake-old1.patch
+Patch2: cmake-old2.patch
 ExclusiveArch: x86_64
 BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
@@ -25,6 +26,7 @@ BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valg
 BuildRequires: llvm-toolset-7-cmake devtoolset-8-gcc-c++ python-devel python2-pyyaml
 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
 BuildRequires: swig3
+BuildRequires: rh-git218-git-core
 # https://bugzilla.redhat.com/show_bug.cgi?id=1511892
 %global __cmake /opt/rh/llvm-toolset-7/root/usr/bin/cmake3
 %else
@@ -64,6 +66,11 @@ The package contains header files for %{name}.
 %ldconfig_scriptlets
 
 %prep
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+# git clone --depth 10000 --single-branch --reference ../reference https://github.com/llvm/llvm-project.git .
+# fatal: git fetch-pack: expected shallow list
+. /opt/rh/rh-git218/enable
+%endif
 %setup -q -c -T
 OPTS="--depth 10000"
 %if !0%{?rhel:1} || 0%{?rhel} > 7
@@ -91,12 +98,10 @@ git merge jankratochvil/dwz
 # '-c merge.renameLimit=0' has no effect.
 git -c merge.renameLimit=1 merge jankratochvil/rust
 %endif
-%patch1 -p1
+%patch2 -p1 -R
+%patch1 -p1 -R
 
 %build
-mkdir build-release
-cd    build-release
-
 FLAGS="%{optflags}"
 
 # lldb/scripts/LLDBWrapPython.cpp:23699:70: error: format not a string literal and no format arguments [-Werror=format-security]
@@ -115,7 +120,7 @@ FLAGS="$FLAGS -g0"
 # -fno-reorder-blocks-and-partition:
 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
-FLAGS="$FLAGS -gsplit-dwarf -fno-reorder-blocks-and-partition"
+FLAGS="$FLAGS -fdebug-types-section"
 %endif
 
 CFLAGS="$FLAGS"
@@ -125,8 +130,8 @@ CXXFLAGS="$FLAGS"
 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental
 # -fdebug-types-section && -DLLVM_USE_LINKER=gold:
 # ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
-%cmake ../llvm \
-  -DCMAKE_INSTALL_PREFIX=%{buildroot}%{pkg_prefix} \
+%cmake llvm \
+  -DCMAKE_INSTALL_PREFIX=%{pkg_prefix} \
   -DBUILD_SHARED_LIBS=OFF \
 %if %{fast}
   -DCMAKE_BUILD_TYPE=Release \
@@ -147,8 +152,11 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
   #
-cd *-redhat-linux-gnu
-%make_build
+%if 0%{?rhel:1} && 0%{?rhel} <= 8
+%__cmake --build . -- %{?_smp_mflags}
+%else
+%cmake_build
+%endif
 
 %install
 mkdir -p %{buildroot}%{pkg_prefix}
@@ -163,8 +171,12 @@ mkdir -p %{buildroot}%{pkg_prefix}
  revline . jankratochvil/rust
 %endif
 ) >%{buildroot}%{pkg_prefix}/HEAD
-cd build-release/*-redhat-linux-gnu
+%if 0%{?rhel:1} && 0%{?rhel} <= 8
+# It runs a new configure without installing anything: DESTDIR="%{buildroot}" #__cmake --install .
 %make_install
+%else
+%cmake_install
+%endif
 mkdir -p %{buildroot}%{_bindir}
 # lldb-mi
 for i in lldb;do