(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 52b3575..21c4286 100644 (file)
@@ -14,7 +14,7 @@
 %endif
 Name: lldb-experimental
 Version: 12.0.0
-Release: 0.20201026snap2%{?dist}
+Release: 0.20201026snap8%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -41,9 +41,10 @@ BuildRequires: cmake3
 BuildRequires: cmake
 %else
 # cmake-3.17.0-1.el8:
-###BuildRequires: /usr/bin/sphinx-build curl-devel emacs jsoncpp-devel libarchive-devel openssl-devel pkgconfig(Qt5Widgets) rhash-devel
+BuildRequires: wget
+BuildRequires: /usr/bin/sphinx-build curl-devel emacs jsoncpp-devel libarchive-devel openssl-devel pkgconfig(Qt5Widgets) rhash-devel
 # [local]=https://kojipkgs.fedoraproject.org/repos/epel8-build/latest/$basearch/
-###BuildRequires: libuv-devel
+BuildRequires: libuv-devel
 %endif
 BuildRequires: swig
 BuildRequires: python3-devel python3-pygments python3-pyyaml
@@ -116,7 +117,7 @@ rpm2archive $cmakesrc
  for i in .[a-z]*;do mv $i `echo $i|sed 's/^\.//'`;done
  # -- Could NOT find LibArchive: Found unsuitable version "3.3.2", but required is at least "3.3.3" (found /usr/lib64/libarchive.so)
  # CMAKE_USE_SYSTEM_LIBARCHIVE is ON but LibArchive is not found!
- patch -p1 <../cmake.spec.patch
+ sed -i -e 's/qt-gui /&--no-system-libarchive /' cmake.spec
  rpmbuild --define "_topdir $PWD" --define "_builddir $PWD" --define "_rpmdir $PWD" --define "_sourcedir $PWD" --define "_specdir $PWD" --define "_srcrpmdir $PWD" -bc cmake.spec
 )
 %global __cmake %(echo %{_builddir}/cmake-*.d/cmake-*/*/bin/cmake)