(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index cd1d5af..721fef2 100644 (file)
@@ -1,7 +1,7 @@
-# https://download.copr.fedorainfracloud.org/results/jankratochvil/lldb/fedora-rawhide-x86_64/01574351-lldb-experimental/builder-live.log.gz
-# No space left on device.
 %global fast 0
 %global use_jankratochvil_dwz 1
+%global use_jankratochvil_rnglist 1
+%global use_jankratochvil_uniqaddr 1
 %global use_jankratochvil_rust 0
 %global pkg_prefix /opt/%{name}
 %global _unpackaged_files_terminate_build 0
@@ -9,20 +9,35 @@
 %global _find_debuginfo_dwz_opts %{nil}
 # *** ERROR: ambiguous python shebang in /opt/lldb-experimental/...: #!/usr/bin/env python. Change it to python3 (or python2) explicitly.
 %global __brp_mangle_shebangs %{nil}
+%if (0%{?rhel:1} && 0%{?rhel} <= 7)
+# -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
+# https://bugzilla.redhat.com/show_bug.cgi?id=1590678
+%global fast 1
+%endif
 %if %{fast}
 %global debug_package %{nil}
 %endif
 Name: lldb-experimental
-Version: 12.0.0
-Release: 0.20210121snap1%{?dist}
+Version: 13.0.0
+Release: 0.20210425snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
 ExclusiveArch: x86_64
+# Source zero not found
+# https://bugzilla.redhat.com/show_bug.cgi?id=1938320
+Source0: empty.tar
 BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
+#+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
+#Compiling /quad/home/jkratoch/redhat/lldb-experimental/BUILDROOT/lldb-experimental-13.0.0-0.20210206snap1.el7.x86_64/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py ...
+#  File "/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py", line 883
+#    def IsValid(self) -> "bool":
+#                      ^
+#SyntaxError: invalid syntax
+%global __python /usr/bin/python3
 BuildRequires: devtoolset-8-gcc-c++
 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
 BuildRequires: swig3
@@ -74,6 +89,14 @@ This package is an experimental trunk snapshot.
 This package contains off-trunk DWZ support for Fedora debuginfos such as:
   unsupported DW_FORM values: 0x1f20 0x1f21
 %endif
+%if %{use_jankratochvil_rnglist}
+This package contains off-trunk:
+  Fix DW_AT_ranges DW_FORM_sec_offset not using DW_AT_rnglists_base (used by GCC)
+%endif
+%if %{use_jankratochvil_uniqaddr}
+This package contains off-trunk:
+  Support for libstdc++11 std::unique_ptr: [[no_unique_address]]
+%endif
 %if %{use_jankratochvil_rust}
 This package contains off-trunk Rust support:
   https://github.com/rust-lang-nursery/lldb
@@ -156,6 +179,12 @@ git config user.name jankratochvil
 %if %{use_jankratochvil_dwz}
 git merge jankratochvil/dwz
 %endif
+%if %{use_jankratochvil_rnglist}
+git merge jankratochvil/rnglist0-1-2
+%endif
+%if %{use_jankratochvil_uniqaddr}
+git merge jankratochvil/layout3
+%endif
 %if %{use_jankratochvil_rust}
 # '-c merge.renames=false' is F-29+.
 # '-c merge.renameLimit=0' has no effect.
@@ -171,10 +200,6 @@ FLAGS="$FLAGS -Wno-error=format-security"
 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
 . /opt/rh/devtoolset-8/enable
 . /opt/rh/rh-python38/enable
-# -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
-# https://bugzilla.redhat.com/show_bug.cgi?id=1590678
-# Set %%{fast} only after %%debug_package above.
-%global fast 1
 %endif
 %if %{fast}
 FLAGS="$FLAGS -g0"
@@ -194,7 +219,6 @@ CXXFLAGS="$FLAGS"
 # ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
 %cmake llvm \
   -DCMAKE_INSTALL_PREFIX=%{pkg_prefix} \
-  -DBUILD_SHARED_LIBS=OFF \
 %if %{fast}
   -DCMAKE_BUILD_TYPE=Release \
 %else
@@ -213,6 +237,7 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_CURSES=OFF \
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
+  -DLLVM_ENABLE_ASSERTIONS=ON \
   #
 %cmake_build
 
@@ -244,6 +269,7 @@ rm -fv %{buildroot}%{_libdir}/*.a
 (cd %{buildroot}%{pkg_prefix}/%{_lib}/python*/site-packages/lldb/
  ln -vsf "$(dirname $(readlink _lldb.so))/$(readlink $(readlink _lldb.so))" _lldb.so
 )
+du -shc $PWD %{buildroot}
 
 %files
 %{_bindir}/lldb-experimental
@@ -256,12 +282,11 @@ rm -fv %{buildroot}%{_libdir}/*.a
 # RHEL-7: File not found by glob: .../lib{lldb,clang,LLVM}*.so.*
 %{pkg_prefix}/%{_lib}/libl*.so.*
 %{pkg_prefix}/%{_lib}/python*
+%{pkg_prefix}/%{_lib}/lib[^l]*.so.*
 
 %files devel
 %{pkg_prefix}/include
-%{pkg_prefix}/%{_lib}/lib[^l]*.so.*
 %{pkg_prefix}/%{_lib}/*.so
-%{pkg_prefix}/%{_lib}/*.a
 
 %changelog
 * Thu Apr  5 2018 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.0-0.1