(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index eecd208..72c1c17 100644 (file)
 %global debug_package %{nil}
 %endif
 Name: lldb-experimental
-Version: 10.0.0
-Release: 0.20191028snap0%{?dist}
+Version: 11.0.0
+Release: 0.20200722snap3%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
+Patch1: cmake-old.patch
 ExclusiveArch: x86_64
-BuildRequires: gcc-c++ git libedit-devel swig libatomic ninja-build libxml2-devel zlib-devel valgrind-devel libpfm-devel
+BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
 BuildRequires: llvm-toolset-7-cmake devtoolset-8-gcc-c++ python-devel python2-pyyaml
+# swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
+BuildRequires: swig3
+BuildRequires: rh-git218-git-core
 # https://bugzilla.redhat.com/show_bug.cgi?id=1511892
 %global __cmake /opt/rh/llvm-toolset-7/root/usr/bin/cmake3
-%global ninjabuild ninja-build
 %else
-BuildRequires: cmake z3-devel
+%if !0%{?rhel:1} || 0%{?rhel} > 8
+BuildRequires: z3-devel
+%endif
+BuildRequires: cmake swig
 BuildRequires: python3-devel python3-pygments python3-pyyaml
 # removed in F31+
 #BuildRequires: xar-devel
-%global ninjabuild ninja
 %endif
 
 %description
@@ -60,20 +65,27 @@ The package contains header files for %{name}.
 %ldconfig_scriptlets
 
 %prep
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+# git clone --depth 10000 --single-branch --reference ../reference https://github.com/llvm/llvm-project.git .
+# fatal: git fetch-pack: expected shallow list
+. /opt/rh/rh-git218/enable
+%endif
 %setup -q -c -T
-OPTS=""
+OPTS="--depth 10000"
 %if !0%{?rhel:1} || 0%{?rhel} > 7
   OPTS="$OPTS --no-tags"
 %endif
 REF="reference"
 # RHEL-7 does not support: --reference-if-able
-test -d ../$REF/ && OPTS="$OPTS --reference ../$REF"
+CLONEOPTS="--single-branch"
+test -d ../$REF/ && CLONEOPTS="$CLONEOPTS --reference ../$REF"
 # 2500 = 1 month in 2019
-git clone --depth 10000 --single-branch $OPTS https://github.com/llvm/llvm-project.git .
+git clone $OPTS $CLONEOPTS https://github.com/llvm/llvm-project.git .
 %if %{use_jankratochvil_dwz} || %{use_jankratochvil_rust}
 git remote remove jankratochvil || :
-git remote add jankratochvil git://git.jankratochvil.net/lldb
-git fetch jankratochvil
+#git remote add jankratochvil git://git.jankratochvil.net/lldb
+git remote add jankratochvil https://github.com/jankratochvil/llvm-project.git
+git fetch $OPTS jankratochvil
 git config user.email jankratochvil@copr.fedorainfracloud.org
 git config user.name jankratochvil
 %endif
@@ -85,11 +97,9 @@ git merge jankratochvil/dwz
 # '-c merge.renameLimit=0' has no effect.
 git -c merge.renameLimit=1 merge jankratochvil/rust
 %endif
+%patch1 -p1
 
 %build
-mkdir build-release
-cd    build-release
-
 FLAGS="%{optflags}"
 
 # lldb/scripts/LLDBWrapPython.cpp:23699:70: error: format not a string literal and no format arguments [-Werror=format-security]
@@ -118,9 +128,8 @@ CXXFLAGS="$FLAGS"
 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental
 # -fdebug-types-section && -DLLVM_USE_LINKER=gold:
 # ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
-%cmake ../llvm \
-  -GNinja \
-  -DCMAKE_INSTALL_PREFIX=%{buildroot}%{pkg_prefix} \
+%cmake llvm \
+  -DCMAKE_INSTALL_PREFIX=%{pkg_prefix} \
   -DBUILD_SHARED_LIBS=OFF \
 %if %{fast}
   -DCMAKE_BUILD_TYPE=Release \
@@ -141,7 +150,11 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
   #
-%{ninjabuild} -v
+%if 0%{?rhel:1} && 0%{?rhel} <= 8
+%__cmake --build . -- %{?_smp_mflags}
+%else
+%cmake_build
+%endif
 
 %install
 mkdir -p %{buildroot}%{pkg_prefix}
@@ -156,8 +169,12 @@ mkdir -p %{buildroot}%{pkg_prefix}
  revline . jankratochvil/rust
 %endif
 ) >%{buildroot}%{pkg_prefix}/HEAD
-cd build-release
-%{ninjabuild} -v install
+%if 0%{?rhel:1} && 0%{?rhel} <= 8
+# It runs a new configure without installing anything: DESTDIR="%{buildroot}" #__cmake --install .
+%make_install
+%else
+%cmake_install
+%endif
 mkdir -p %{buildroot}%{_bindir}
 # lldb-mi
 for i in lldb;do
@@ -169,7 +186,7 @@ done
 rm -fv %{buildroot}%{_libdir}/*.a
 
 ### python: fix liblldb.so -> liblldb.so.7 symlink target
-(cd %{buildroot}%{pkg_prefix}/lib/python*/site-packages/lldb/
+(cd %{buildroot}%{pkg_prefix}/%{_lib}/python*/site-packages/lldb/
  ln -vsf "$(dirname $(readlink _lldb.so))/$(readlink $(readlink _lldb.so))" _lldb.so
 )
 
@@ -183,7 +200,7 @@ rm -fv %{buildroot}%{_libdir}/*.a
 %{pkg_prefix}/bin/lldb-argdumper
 # RHEL-7: File not found by glob: .../lib{lldb,clang,LLVM}*.so.*
 %{pkg_prefix}/%{_lib}/libl*.so.*
-%{pkg_prefix}/lib/python*
+%{pkg_prefix}/%{_lib}/python*
 
 %files devel
 %{pkg_prefix}/include