(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 72c1c17..7674f2b 100644 (file)
@@ -1,4 +1,6 @@
-%global fast 0
+# https://download.copr.fedorainfracloud.org/results/jankratochvil/lldb/fedora-rawhide-x86_64/01574351-lldb-experimental/builder-live.log.gz
+# No space left on device.
+%global fast 1
 %global use_jankratochvil_dwz 1
 %global use_jankratochvil_rust 0
 %global pkg_prefix /opt/%{name}
 %global debug_package %{nil}
 %endif
 Name: lldb-experimental
-Version: 11.0.0
-Release: 0.20200722snap3%{?dist}
+Version: 12.0.0
+Release: 0.20201026snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
-Patch1: cmake-old.patch
 ExclusiveArch: x86_64
 BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
-BuildRequires: llvm-toolset-7-cmake devtoolset-8-gcc-c++ python-devel python2-pyyaml
+BuildRequires: devtoolset-8-gcc-c++
 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
 BuildRequires: swig3
 BuildRequires: rh-git218-git-core
+BuildRequires: rh-python38-python-devel rh-python38-python-pyyaml
 # https://bugzilla.redhat.com/show_bug.cgi?id=1511892
-%global __cmake /opt/rh/llvm-toolset-7/root/usr/bin/cmake3
+BuildRequires: cmake3
+%global cmake %{cmake3}
+%global cmake_build %{cmake3_build}
+%global cmake_install %{cmake3_install}
 %else
-%if !0%{?rhel:1} || 0%{?rhel} > 8
-BuildRequires: z3-devel
-%endif
+# FIXME: CentOS-8:
+# CMake Error at CMakeLists.txt:3 (cmake_minimum_required):
+#   CMake 3.13.4 or higher is required.  You are running version 3.11.4
 BuildRequires: cmake swig
 BuildRequires: python3-devel python3-pygments python3-pyyaml
 # removed in F31+
 #BuildRequires: xar-devel
+%if !0%{?rhel:1} || 0%{?rhel} > 8
+BuildRequires: z3-devel
+%endif
 %endif
 
 %description
@@ -69,6 +77,24 @@ The package contains header files for %{name}.
 # git clone --depth 10000 --single-branch --reference ../reference https://github.com/llvm/llvm-project.git .
 # fatal: git fetch-pack: expected shallow list
 . /opt/rh/rh-git218/enable
+# CMake Warning at ../lldb/cmake/modules/FindPythonInterpAndLibs.cmake:10 (find_package):
+#   By not providing "FindPython3.cmake" in CMAKE_MODULE_PATH this project has
+#   asked CMake to find a package configuration file provided by "Python3", but
+#   CMake did not find one.
+#   Could not find a package configuration file provided by "Python3" with any
+#   of the following names:
+#     Python3Config.cmake
+#     python3-config.cmake
+#   Add the installation prefix of "Python3" to CMAKE_PREFIX_PATH or set
+#   "Python3_DIR" to a directory containing one of the above files.  If
+#   "Python3" provides a separate development package or SDK, be sure it has
+#   been installed.
+# Call Stack (most recent call first):
+#   ../lldb/cmake/modules/FindPythonInterpAndLibs.cmake:71 (FindPython3)
+#   ../lldb/cmake/modules/LLDBConfig.cmake:48 (find_package)
+#   ../lldb/cmake/modules/LLDBConfig.cmake:59 (add_optional_dependency)
+#   ../lldb/CMakeLists.txt:28 (include)
+. /opt/rh/rh-python38/enable
 %endif
 %setup -q -c -T
 OPTS="--depth 10000"
@@ -97,7 +123,6 @@ git merge jankratochvil/dwz
 # '-c merge.renameLimit=0' has no effect.
 git -c merge.renameLimit=1 merge jankratochvil/rust
 %endif
-%patch1 -p1
 
 %build
 FLAGS="%{optflags}"
@@ -107,6 +132,7 @@ FLAGS="$FLAGS -Wno-error=format-security"
 
 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
 . /opt/rh/devtoolset-8/enable
+. /opt/rh/rh-python38/enable
 # -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
 # https://bugzilla.redhat.com/show_bug.cgi?id=1590678
 # Set %%{fast} only after %%debug_package above.
@@ -118,7 +144,7 @@ FLAGS="$FLAGS -g0"
 # -fno-reorder-blocks-and-partition:
 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
-FLAGS="$FLAGS -gsplit-dwarf -fno-reorder-blocks-and-partition"
+FLAGS="$FLAGS -fdebug-types-section"
 %endif
 
 CFLAGS="$FLAGS"
@@ -150,11 +176,7 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
   #
-%if 0%{?rhel:1} && 0%{?rhel} <= 8
-%__cmake --build . -- %{?_smp_mflags}
-%else
 %cmake_build
-%endif
 
 %install
 mkdir -p %{buildroot}%{pkg_prefix}
@@ -169,12 +191,7 @@ mkdir -p %{buildroot}%{pkg_prefix}
  revline . jankratochvil/rust
 %endif
 ) >%{buildroot}%{pkg_prefix}/HEAD
-%if 0%{?rhel:1} && 0%{?rhel} <= 8
-# It runs a new configure without installing anything: DESTDIR="%{buildroot}" #__cmake --install .
-%make_install
-%else
 %cmake_install
-%endif
 mkdir -p %{buildroot}%{_bindir}
 # lldb-mi
 for i in lldb;do