(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 8e119f9..7e62777 100644 (file)
@@ -18,7 +18,7 @@
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210604snap0%{?dist}
+Release: 0.20210604snap6%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -26,7 +26,7 @@ ExclusiveArch: x86_64
 # Source zero not found
 # https://bugzilla.redhat.com/show_bug.cgi?id=1938320
 Source0: empty.tar
-BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
+BuildRequires: clang git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
@@ -48,6 +48,7 @@ BuildRequires: cmake3
 %global cmake_build %{cmake3_build}
 %global cmake_install %{cmake3_install}
 %else
+BuildRequires: lld
 # FIXME: CentOS-8:
 # CMake Error at CMakeLists.txt:3 (cmake_minimum_required):
 #   CMake 3.13.4 or higher is required.  You are running version 3.11.4
@@ -55,7 +56,6 @@ BuildRequires: cmake3
 BuildRequires: cmake
 %else
 # cmake-3.17.0-1.el8:
-BuildRequires: clang lld
 BuildRequires: wget expat-devel
 BuildRequires: /usr/bin/sphinx-build curl-devel emacs jsoncpp-devel openssl-devel pkgconfig(Qt5Widgets) rhash-devel
 # -- Could NOT find LibArchive: Found unsuitable version "3.3.2", but required is at least "3.3.3" (found /usr/lib64/libarchive.so)
@@ -205,6 +205,16 @@ FLAGS="$FLAGS -fdebug-types-section"
 %endif
 %endif
 
+# clang-12: error: unsupported argument 'auto' to option 'flto='
+# clang-12: warning: optimization flag '-ffat-lto-objects' is not supported [-Wignored-optimization-argument]
+FLAGS="$(echo $FLAGS|sed 's/ -flto=auto -ffat-lto-objects / -flto /')"
+# ld.lld: error: relocation R_X86_64_PC32 cannot be used against symbol ...; recompile with -fPIC
+FLAGS="$FLAGS -fPIC"
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+# clang: error: unknown argument: '-fstack-protector-strong'
+FLAGS="$(echo $FLAGS|sed 's/ -fstack-protector-strong / /')"
+%endif
+
 CFLAGS="$FLAGS"
 CXXFLAGS="$FLAGS"
 
@@ -214,7 +224,11 @@ CXXFLAGS="$FLAGS"
   -DCMAKE_INSTALL_PREFIX=%{pkg_prefix} \
   -DCMAKE_C_COMPILER=clang \
   -DCMAKE_CXX_COMPILER=clang++ \
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+  -DLLVM_USE_LINKER=gold \
+%else
   -DLLVM_USE_LINKER=lld \
+%endif
 %if %{fast}
   -DCMAKE_BUILD_TYPE=Release \
 %else