(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index f7d7d9b..8e119f9 100644 (file)
@@ -18,7 +18,7 @@
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210531snap0%{?dist}
+Release: 0.20210604snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -55,6 +55,7 @@ BuildRequires: cmake3
 BuildRequires: cmake
 %else
 # cmake-3.17.0-1.el8:
+BuildRequires: clang lld
 BuildRequires: wget expat-devel
 BuildRequires: /usr/bin/sphinx-build curl-devel emacs jsoncpp-devel openssl-devel pkgconfig(Qt5Widgets) rhash-devel
 # -- Could NOT find LibArchive: Found unsuitable version "3.3.2", but required is at least "3.3.3" (found /usr/lib64/libarchive.so)
@@ -204,21 +205,16 @@ FLAGS="$FLAGS -fdebug-types-section"
 %endif
 %endif
 
-# Rawhide Gold on lldb-experimental build: invalid symbol table name index && section_header_offset: bad shndx
-# https://bugzilla.redhat.com/show_bug.cgi?id=1954141
-%if 0%{?fedora} == 35
-FLAGS="$FLAGS -fno-lto"
-%endif
-
 CFLAGS="$FLAGS"
 CXXFLAGS="$FLAGS"
 
 # This is default - changing it breaks the testsuite: -DLLVM_LINK_LLVM_DYLIB=OFF
 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental
-# -fdebug-types-section && -DLLVM_USE_LINKER=gold:
-# ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
 %cmake llvm \
   -DCMAKE_INSTALL_PREFIX=%{pkg_prefix} \
+  -DCMAKE_C_COMPILER=clang \
+  -DCMAKE_CXX_COMPILER=clang++ \
+  -DLLVM_USE_LINKER=lld \
 %if %{fast}
   -DCMAKE_BUILD_TYPE=Release \
 %else
@@ -227,7 +223,6 @@ CXXFLAGS="$FLAGS"
   -DLLVM_ENABLE_PROJECTS="lldb;clang;lld" \
   -DLLVM_TARGETS_TO_BUILD=X86 \
   -DLLVM_BUILD_TOOLS=OFF \
-  -DLLVM_USE_LINKER=gold \
   $(: file INSTALL cannot find build-release/lib/python3.6 ) \
 %if 0%{?__isa_bits} == 64
   -DLLVM_LIBDIR_SUFFIX=64 \