(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 3efbe9a..922118c 100644 (file)
@@ -12,7 +12,7 @@
 %endif
 Name: lldb-experimental
 Version: 10.0.0
-Release: 0.20190817snap4%{?dist}
+Release: 0.20190817snap5%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -59,8 +59,15 @@ The package contains header files for %{name}.
 
 %prep
 %setup -q -c -T
+OPTS=""
+%if !0%{?rhel:1} || 0%{?rhel} > 7
+  OPTS="$OPTS --no-tags"
+%endif
+REF="reference"
+# RHEL-7 does not support: --reference-if-able
+test -d ../$REF/ && OPTS="$OPTS --reference ../$REF"
 # 2500 = 1 month in 2019
-git clone --depth 10000 --no-tags --single-branch --reference-if-able reference https://github.com/llvm/llvm-project.git .
+git clone --depth 10000 --single-branch $OPTS https://github.com/llvm/llvm-project.git .
 %if %{use_jankratochvil_dwz} || %{use_jankratochvil_rust}
 git remote remove jankratochvil || :
 git remote add jankratochvil git://git.jankratochvil.net/lldb