(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index f83544a..b5af3c1 100644 (file)
@@ -2,7 +2,9 @@
 %global use_jankratochvil_dwz 1
 %global use_jankratochvil_layout5 1
 %global use_jankratochvil_ocaml_doc 1
+%global use_jankratochvil_rnglist 1
 %global use_jankratochvil_rust 0
+%global use_nealsid_lldb_editline_remove_wchar 0
 %global pkg_prefix /opt/%{name}
 %global _unpackaged_files_terminate_build 0
 # dwz: Couldn't find DIE referenced by DW_OP_GNU_parameter_ref
@@ -18,8 +20,8 @@
 %global debug_package %{nil}
 %endif
 Name: lldb-experimental
-Version: 13.0.0
-Release: 0.20210707snap0%{?dist}
+Version: 14.0.0
+Release: 0.20210810snap1%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -101,10 +103,17 @@ This package contains off-trunk:
 This package contains off-trunk:
   ocaml_doc fix
 %endif
+%if %{use_jankratochvil_rnglist}
+This package contains off-trunk DWARF-5 .debug_rnglists fix.
+%endif
 %if %{use_jankratochvil_rust}
 This package contains off-trunk Rust support:
   https://github.com/rust-lang-nursery/lldb
 %endif
+%if %{use_nealsid_lldb_editline_remove_wchar}
+This package contains:
+  https://github.com/nealsid/llvm-project/tree/lldb-editline-remove-wchar
+%endif
 
 %package devel
 Summary: Development header files for %{name}
@@ -189,11 +198,19 @@ git merge jankratochvil/layout5
 %if %{use_jankratochvil_ocaml_doc}
 git merge jankratochvil/ocaml_doc
 %endif
+%if %{use_jankratochvil_rnglist}
+git merge jankratochvil/rnglist
+%endif
 %if %{use_jankratochvil_rust}
 # '-c merge.renames=false' is F-29+.
 # '-c merge.renameLimit=0' has no effect.
 git -c merge.renameLimit=1 merge jankratochvil/rust
 %endif
+%if %{use_nealsid_lldb_editline_remove_wchar}
+git remote add nealsid https://github.com/nealsid/llvm-project.git
+git fetch nealsid
+git merge nealsid/lldb-editline-remove-wchar
+%endif
 
 %build
 FLAGS="%{optflags}"