(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 65c58c9..bfcec86 100644 (file)
@@ -18,7 +18,7 @@
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210604snap7%{?dist}
+Release: 0.20210609snap3%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -29,6 +29,9 @@ Source0: empty.tar
 BuildRequires: clang git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
+%if 0%{?rhel} > 8 || 0%{?fedora} >= 34
+BuildRequires:  ocaml-findlib ocaml-ctypes ocaml-ocamldoc
+%endif
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
 #+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
 #Compiling /quad/home/jkratoch/redhat/lldb-experimental/BUILDROOT/lldb-experimental-13.0.0-0.20210206snap1.el7.x86_64/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py ...
@@ -176,7 +179,7 @@ git config user.name jankratochvil
 git merge jankratochvil/dwz
 %endif
 %if %{use_jankratochvil_uniqaddr}
-git merge jankratochvil/layout3
+git merge jankratochvil/layout5
 %endif
 %if %{use_jankratochvil_rust}
 # '-c merge.renames=false' is F-29+.
@@ -215,8 +218,11 @@ FLAGS="$FLAGS -fPIC"
 FLAGS="$(echo $FLAGS|sed 's/ -fstack-protector-strong / /')"
 %endif
 
-CFLAGS="$FLAGS"
-CXXFLAGS="$FLAGS"
+export CFLAGS="$FLAGS"
+export CXXFLAGS="$FLAGS"
+
+export LDFLAGS="%{build_ldflags}"
+LDFLAGS="$LDFLAGS -flto -Wl,--build-id=sha1"
 
 # This is default - changing it breaks the testsuite: -DLLVM_LINK_LLVM_DYLIB=OFF
 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental
@@ -247,6 +253,9 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
   -DLLVM_ENABLE_ASSERTIONS=ON \
+  $(: https://download.copr.fedorainfracloud.org/results/jankratochvil/lldb/fedora-34-x86_64/02246836-lldb-experimental/builder-live.log.gz ) \
+  $(: https://www.reddit.com/r/linuxquestions/comments/fg5dk4/install_clang_from_source/ ) \
+  -DLLVM_BUILD_DOCS=OFF \
   #
 %cmake_build