(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 8e119f9..bfcec86 100644 (file)
@@ -18,7 +18,7 @@
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210604snap0%{?dist}
+Release: 0.20210609snap3%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -26,9 +26,12 @@ ExclusiveArch: x86_64
 # Source zero not found
 # https://bugzilla.redhat.com/show_bug.cgi?id=1938320
 Source0: empty.tar
-BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
+BuildRequires: clang git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
+%if 0%{?rhel} > 8 || 0%{?fedora} >= 34
+BuildRequires:  ocaml-findlib ocaml-ctypes ocaml-ocamldoc
+%endif
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
 #+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
 #Compiling /quad/home/jkratoch/redhat/lldb-experimental/BUILDROOT/lldb-experimental-13.0.0-0.20210206snap1.el7.x86_64/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py ...
@@ -37,7 +40,7 @@ BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valg
 #                      ^
 #SyntaxError: invalid syntax
 %global __python /usr/bin/python3
-BuildRequires: devtoolset-8-gcc-c++
+BuildRequires: llvm-toolset-7.0-clang llvm-toolset-7.0-lld
 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
 BuildRequires: swig3
 BuildRequires: rh-git218-git-core
@@ -48,6 +51,7 @@ BuildRequires: cmake3
 %global cmake_build %{cmake3_build}
 %global cmake_install %{cmake3_install}
 %else
+BuildRequires: lld
 # FIXME: CentOS-8:
 # CMake Error at CMakeLists.txt:3 (cmake_minimum_required):
 #   CMake 3.13.4 or higher is required.  You are running version 3.11.4
@@ -55,7 +59,6 @@ BuildRequires: cmake3
 BuildRequires: cmake
 %else
 # cmake-3.17.0-1.el8:
-BuildRequires: clang lld
 BuildRequires: wget expat-devel
 BuildRequires: /usr/bin/sphinx-build curl-devel emacs jsoncpp-devel openssl-devel pkgconfig(Qt5Widgets) rhash-devel
 # -- Could NOT find LibArchive: Found unsuitable version "3.3.2", but required is at least "3.3.3" (found /usr/lib64/libarchive.so)
@@ -176,7 +179,7 @@ git config user.name jankratochvil
 git merge jankratochvil/dwz
 %endif
 %if %{use_jankratochvil_uniqaddr}
-git merge jankratochvil/layout3
+git merge jankratochvil/layout5
 %endif
 %if %{use_jankratochvil_rust}
 # '-c merge.renames=false' is F-29+.
@@ -191,7 +194,7 @@ FLAGS="%{optflags}"
 FLAGS="$FLAGS -Wno-error=format-security"
 
 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
-. /opt/rh/devtoolset-8/enable
+. /opt/rh/llvm-toolset-7.0/enable
 . /opt/rh/rh-python38/enable
 %endif
 %if %{fast}
@@ -205,8 +208,21 @@ FLAGS="$FLAGS -fdebug-types-section"
 %endif
 %endif
 
-CFLAGS="$FLAGS"
-CXXFLAGS="$FLAGS"
+# clang-12: error: unsupported argument 'auto' to option 'flto='
+# clang-12: warning: optimization flag '-ffat-lto-objects' is not supported [-Wignored-optimization-argument]
+FLAGS="$(echo $FLAGS|sed 's/ -flto=auto -ffat-lto-objects / -flto /')"
+# ld.lld: error: relocation R_X86_64_PC32 cannot be used against symbol ...; recompile with -fPIC
+FLAGS="$FLAGS -fPIC"
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+# clang: error: unknown argument: '-fstack-protector-strong'
+FLAGS="$(echo $FLAGS|sed 's/ -fstack-protector-strong / /')"
+%endif
+
+export CFLAGS="$FLAGS"
+export CXXFLAGS="$FLAGS"
+
+export LDFLAGS="%{build_ldflags}"
+LDFLAGS="$LDFLAGS -flto -Wl,--build-id=sha1"
 
 # This is default - changing it breaks the testsuite: -DLLVM_LINK_LLVM_DYLIB=OFF
 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental
@@ -214,7 +230,11 @@ CXXFLAGS="$FLAGS"
   -DCMAKE_INSTALL_PREFIX=%{pkg_prefix} \
   -DCMAKE_C_COMPILER=clang \
   -DCMAKE_CXX_COMPILER=clang++ \
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+  -DLLVM_USE_LINKER=gold \
+%else
   -DLLVM_USE_LINKER=lld \
+%endif
 %if %{fast}
   -DCMAKE_BUILD_TYPE=Release \
 %else
@@ -233,6 +253,9 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
   -DLLVM_ENABLE_ASSERTIONS=ON \
+  $(: https://download.copr.fedorainfracloud.org/results/jankratochvil/lldb/fedora-34-x86_64/02246836-lldb-experimental/builder-live.log.gz ) \
+  $(: https://www.reddit.com/r/linuxquestions/comments/fg5dk4/install_clang_from_source/ ) \
+  -DLLVM_BUILD_DOCS=OFF \
   #
 %cmake_build