(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 711a54a..d935835 100644 (file)
@@ -1,5 +1,6 @@
 %global fast 0
 %global use_jankratochvil_dwz 1
+%global use_jankratochvil_uniqaddr 1
 %global use_jankratochvil_rust 0
 %global pkg_prefix /opt/%{name}
 %global _unpackaged_files_terminate_build 0
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210312snap1%{?dist}
+Release: 0.20210531snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
 ExclusiveArch: x86_64
-# Source zero not found
-# https://bugzilla.redhat.com/show_bug.cgi?id=1938320
-Source0: empty.tar
 BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
@@ -87,6 +85,10 @@ This package is an experimental trunk snapshot.
 This package contains off-trunk DWZ support for Fedora debuginfos such as:
   unsupported DW_FORM values: 0x1f20 0x1f21
 %endif
+%if %{use_jankratochvil_uniqaddr}
+This package contains off-trunk:
+  Support for libstdc++11 std::unique_ptr: [[no_unique_address]]
+%endif
 %if %{use_jankratochvil_rust}
 This package contains off-trunk Rust support:
   https://github.com/rust-lang-nursery/lldb
@@ -169,6 +171,9 @@ git config user.name jankratochvil
 %if %{use_jankratochvil_dwz}
 git merge jankratochvil/dwz
 %endif
+%if %{use_jankratochvil_uniqaddr}
+git merge jankratochvil/layout3
+%endif
 %if %{use_jankratochvil_rust}
 # '-c merge.renames=false' is F-29+.
 # '-c merge.renameLimit=0' has no effect.
@@ -191,8 +196,16 @@ FLAGS="$FLAGS -g0"
 # -fno-reorder-blocks-and-partition:
 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
+%if 0%{?fedora} != 35
 FLAGS="$FLAGS -fdebug-types-section"
 %endif
+%endif
+
+# Rawhide Gold on lldb-experimental build: invalid symbol table name index && section_header_offset: bad shndx
+# https://bugzilla.redhat.com/show_bug.cgi?id=1954141
+%if 0%{?fedora} == 35
+FLAGS="$FLAGS -fno-lto"
+%endif
 
 CFLAGS="$FLAGS"
 CXXFLAGS="$FLAGS"
@@ -221,6 +234,7 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_CURSES=OFF \
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
+  -DLLVM_ENABLE_ASSERTIONS=ON \
   #
 %cmake_build