(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index a733a15..d935835 100644 (file)
@@ -1,5 +1,6 @@
 %global fast 0
 %global use_jankratochvil_dwz 1
+%global use_jankratochvil_uniqaddr 1
 %global use_jankratochvil_rust 0
 %global pkg_prefix /opt/%{name}
 %global _unpackaged_files_terminate_build 0
@@ -7,12 +8,17 @@
 %global _find_debuginfo_dwz_opts %{nil}
 # *** ERROR: ambiguous python shebang in /opt/lldb-experimental/...: #!/usr/bin/env python. Change it to python3 (or python2) explicitly.
 %global __brp_mangle_shebangs %{nil}
+%if (0%{?rhel:1} && 0%{?rhel} <= 7)
+# -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
+# https://bugzilla.redhat.com/show_bug.cgi?id=1590678
+%global fast 1
+%endif
 %if %{fast}
 %global debug_package %{nil}
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210203snap0%{?dist}
+Release: 0.20210531snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -21,6 +27,13 @@ BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valg
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
+#+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
+#Compiling /quad/home/jkratoch/redhat/lldb-experimental/BUILDROOT/lldb-experimental-13.0.0-0.20210206snap1.el7.x86_64/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py ...
+#  File "/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py", line 883
+#    def IsValid(self) -> "bool":
+#                      ^
+#SyntaxError: invalid syntax
+%global __python /usr/bin/python3
 BuildRequires: devtoolset-8-gcc-c++
 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
 BuildRequires: swig3
@@ -72,6 +85,10 @@ This package is an experimental trunk snapshot.
 This package contains off-trunk DWZ support for Fedora debuginfos such as:
   unsupported DW_FORM values: 0x1f20 0x1f21
 %endif
+%if %{use_jankratochvil_uniqaddr}
+This package contains off-trunk:
+  Support for libstdc++11 std::unique_ptr: [[no_unique_address]]
+%endif
 %if %{use_jankratochvil_rust}
 This package contains off-trunk Rust support:
   https://github.com/rust-lang-nursery/lldb
@@ -154,6 +171,9 @@ git config user.name jankratochvil
 %if %{use_jankratochvil_dwz}
 git merge jankratochvil/dwz
 %endif
+%if %{use_jankratochvil_uniqaddr}
+git merge jankratochvil/layout3
+%endif
 %if %{use_jankratochvil_rust}
 # '-c merge.renames=false' is F-29+.
 # '-c merge.renameLimit=0' has no effect.
@@ -169,10 +189,6 @@ FLAGS="$FLAGS -Wno-error=format-security"
 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
 . /opt/rh/devtoolset-8/enable
 . /opt/rh/rh-python38/enable
-# -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
-# https://bugzilla.redhat.com/show_bug.cgi?id=1590678
-# Set %%{fast} only after %%debug_package above.
-%global fast 1
 %endif
 %if %{fast}
 FLAGS="$FLAGS -g0"
@@ -180,8 +196,16 @@ FLAGS="$FLAGS -g0"
 # -fno-reorder-blocks-and-partition:
 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
+%if 0%{?fedora} != 35
 FLAGS="$FLAGS -fdebug-types-section"
 %endif
+%endif
+
+# Rawhide Gold on lldb-experimental build: invalid symbol table name index && section_header_offset: bad shndx
+# https://bugzilla.redhat.com/show_bug.cgi?id=1954141
+%if 0%{?fedora} == 35
+FLAGS="$FLAGS -fno-lto"
+%endif
 
 CFLAGS="$FLAGS"
 CXXFLAGS="$FLAGS"
@@ -210,6 +234,7 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_CURSES=OFF \
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
+  -DLLVM_ENABLE_ASSERTIONS=ON \
   #
 %cmake_build