(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index d0cea5a..d935835 100644 (file)
@@ -1,6 +1,5 @@
 %global fast 0
 %global use_jankratochvil_dwz 1
-%global use_jankratochvil_rnglist 1
 %global use_jankratochvil_uniqaddr 1
 %global use_jankratochvil_rust 0
 %global pkg_prefix /opt/%{name}
 %endif
 Name: lldb-experimental
 Version: 13.0.0
-Release: 0.20210429snap0%{?dist}
+Release: 0.20210531snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
 ExclusiveArch: x86_64
-# Source zero not found
-# https://bugzilla.redhat.com/show_bug.cgi?id=1938320
-Source0: empty.tar
 BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
@@ -89,10 +85,6 @@ This package is an experimental trunk snapshot.
 This package contains off-trunk DWZ support for Fedora debuginfos such as:
   unsupported DW_FORM values: 0x1f20 0x1f21
 %endif
-%if %{use_jankratochvil_rnglist}
-This package contains off-trunk:
-  Fix DW_AT_ranges DW_FORM_sec_offset not using DW_AT_rnglists_base (used by GCC)
-%endif
 %if %{use_jankratochvil_uniqaddr}
 This package contains off-trunk:
   Support for libstdc++11 std::unique_ptr: [[no_unique_address]]
@@ -179,9 +171,6 @@ git config user.name jankratochvil
 %if %{use_jankratochvil_dwz}
 git merge jankratochvil/dwz
 %endif
-%if %{use_jankratochvil_rnglist}
-git merge jankratochvil/rnglist0-1-2
-%endif
 %if %{use_jankratochvil_uniqaddr}
 git merge jankratochvil/layout3
 %endif
@@ -207,13 +196,15 @@ FLAGS="$FLAGS -g0"
 # -fno-reorder-blocks-and-partition:
 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
+%if 0%{?fedora} != 35
 FLAGS="$FLAGS -fdebug-types-section"
 %endif
+%endif
 
 # Rawhide Gold on lldb-experimental build: invalid symbol table name index && section_header_offset: bad shndx
 # https://bugzilla.redhat.com/show_bug.cgi?id=1954141
 %if 0%{?fedora} == 35
-FLAGS="$FLAGS -flto=off"
+FLAGS="$FLAGS -fno-lto"
 %endif
 
 CFLAGS="$FLAGS"