(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index fb032a4..d935835 100644 (file)
@@ -1,7 +1,6 @@
-# https://download.copr.fedorainfracloud.org/results/jankratochvil/lldb/fedora-rawhide-x86_64/01574351-lldb-experimental/builder-live.log.gz
-# No space left on device.
-%global fast 1
+%global fast 0
 %global use_jankratochvil_dwz 1
+%global use_jankratochvil_uniqaddr 1
 %global use_jankratochvil_rust 0
 %global pkg_prefix /opt/%{name}
 %global _unpackaged_files_terminate_build 0
@@ -9,12 +8,17 @@
 %global _find_debuginfo_dwz_opts %{nil}
 # *** ERROR: ambiguous python shebang in /opt/lldb-experimental/...: #!/usr/bin/env python. Change it to python3 (or python2) explicitly.
 %global __brp_mangle_shebangs %{nil}
+%if (0%{?rhel:1} && 0%{?rhel} <= 7)
+# -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
+# https://bugzilla.redhat.com/show_bug.cgi?id=1590678
+%global fast 1
+%endif
 %if %{fast}
 %global debug_package %{nil}
 %endif
 Name: lldb-experimental
-Version: 12.0.0
-Release: 0.20201013snap0%{?dist}
+Version: 13.0.0
+Release: 0.20210531snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -23,6 +27,13 @@ BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valg
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
+#+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
+#Compiling /quad/home/jkratoch/redhat/lldb-experimental/BUILDROOT/lldb-experimental-13.0.0-0.20210206snap1.el7.x86_64/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py ...
+#  File "/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py", line 883
+#    def IsValid(self) -> "bool":
+#                      ^
+#SyntaxError: invalid syntax
+%global __python /usr/bin/python3
 BuildRequires: devtoolset-8-gcc-c++
 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
 BuildRequires: swig3
@@ -37,7 +48,25 @@ BuildRequires: cmake3
 # FIXME: CentOS-8:
 # CMake Error at CMakeLists.txt:3 (cmake_minimum_required):
 #   CMake 3.13.4 or higher is required.  You are running version 3.11.4
-BuildRequires: cmake swig
+%if 0%{?rhel} != 8
+BuildRequires: cmake
+%else
+# cmake-3.17.0-1.el8:
+BuildRequires: wget expat-devel
+BuildRequires: /usr/bin/sphinx-build curl-devel emacs jsoncpp-devel openssl-devel pkgconfig(Qt5Widgets) rhash-devel
+# -- Could NOT find LibArchive: Found unsuitable version "3.3.2", but required is at least "3.3.3" (found /usr/lib64/libarchive.so)
+# CMAKE_USE_SYSTEM_LIBARCHIVE is ON but LibArchive is not found!
+#BuildRequires: libarchive-devel
+# -- Could NOT find LibUV: Found unsuitable version "", but required is at least "1.10.0" (found LibUV_LIBRARY-NOTFOUND)
+# CMAKE_USE_SYSTEM_LIBUV is ON but a libuv is not found!
+# [local]=https://kojipkgs.fedoraproject.org/repos/epel8-build/latest/$basearch/
+#BuildRequires: libuv-devel
+# CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
+# Please set them or make sure they are set and tested correctly in the CMake files:
+# BZIP2_LIBRARY
+BuildRequires: bzip2-devel
+%endif
+BuildRequires: swig
 BuildRequires: python3-devel python3-pygments python3-pyyaml
 # removed in F31+
 #BuildRequires: xar-devel
@@ -56,6 +85,10 @@ This package is an experimental trunk snapshot.
 This package contains off-trunk DWZ support for Fedora debuginfos such as:
   unsupported DW_FORM values: 0x1f20 0x1f21
 %endif
+%if %{use_jankratochvil_uniqaddr}
+This package contains off-trunk:
+  Support for libstdc++11 std::unique_ptr: [[no_unique_address]]
+%endif
 %if %{use_jankratochvil_rust}
 This package contains off-trunk Rust support:
   https://github.com/rust-lang-nursery/lldb
@@ -96,6 +129,26 @@ The package contains header files for %{name}.
 #   ../lldb/CMakeLists.txt:28 (include)
 . /opt/rh/rh-python38/enable
 %endif
+%if 0%{?rhel} == 8
+cmakesrc=cmake-3.18.3-1.fc33.src.rpm
+rm -rf $cmakesrc $cmakesrc.tgz $cmakesrc.d
+wget http://ftp.fi.muni.cz/pub/linux/fedora/linux/releases/33/Everything/source/tree/Packages/c/$cmakesrc
+rpm2archive $cmakesrc
+(mkdir $cmakesrc.d
+ cd $cmakesrc.d
+ tar xzf ../$cmakesrc.tgz
+ # FIXME: Why? FIXME: No longer needed?
+ #for i in .[a-z]*;do mv $i `echo $i|sed 's/^\.//'`;done
+ sed -i -e 's/qt-gui /&--no-system-libarchive --no-system-libuv /' cmake.spec
+ rpmbuild --define "_topdir $PWD" --define "_builddir $PWD" --define "_rpmdir $PWD" --define "_sourcedir $PWD" --define "_specdir $PWD" --define "_srcrpmdir $PWD" -bc --nodeps cmake.spec
+)
+%global __cmake %(echo %{_builddir}/cmake-*.d/cmake-*/*/bin/cmake)
+%global __cmake_builddir .
+%global cmake_build \
+  %__cmake --build "%{__cmake_builddir}" %{?_smp_mflags} --verbose
+%global cmake_install \
+  DESTDIR="%{buildroot}" %__cmake --install "%{__cmake_builddir}"
+%endif
 %setup -q -c -T
 OPTS="--depth 10000"
 %if !0%{?rhel:1} || 0%{?rhel} > 7
@@ -118,6 +171,9 @@ git config user.name jankratochvil
 %if %{use_jankratochvil_dwz}
 git merge jankratochvil/dwz
 %endif
+%if %{use_jankratochvil_uniqaddr}
+git merge jankratochvil/layout3
+%endif
 %if %{use_jankratochvil_rust}
 # '-c merge.renames=false' is F-29+.
 # '-c merge.renameLimit=0' has no effect.
@@ -133,10 +189,6 @@ FLAGS="$FLAGS -Wno-error=format-security"
 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
 . /opt/rh/devtoolset-8/enable
 . /opt/rh/rh-python38/enable
-# -gsplit-dwarf: LLVM: internal compiler error: in output_index_string, at dwarf2out.c:21891
-# https://bugzilla.redhat.com/show_bug.cgi?id=1590678
-# Set %%{fast} only after %%debug_package above.
-%global fast 1
 %endif
 %if %{fast}
 FLAGS="$FLAGS -g0"
@@ -144,8 +196,16 @@ FLAGS="$FLAGS -g0"
 # -fno-reorder-blocks-and-partition:
 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
+%if 0%{?fedora} != 35
 FLAGS="$FLAGS -fdebug-types-section"
 %endif
+%endif
+
+# Rawhide Gold on lldb-experimental build: invalid symbol table name index && section_header_offset: bad shndx
+# https://bugzilla.redhat.com/show_bug.cgi?id=1954141
+%if 0%{?fedora} == 35
+FLAGS="$FLAGS -fno-lto"
+%endif
 
 CFLAGS="$FLAGS"
 CXXFLAGS="$FLAGS"
@@ -156,7 +216,6 @@ CXXFLAGS="$FLAGS"
 # ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
 %cmake llvm \
   -DCMAKE_INSTALL_PREFIX=%{pkg_prefix} \
-  -DBUILD_SHARED_LIBS=OFF \
 %if %{fast}
   -DCMAKE_BUILD_TYPE=Release \
 %else
@@ -175,6 +234,7 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_CURSES=OFF \
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
+  -DLLVM_ENABLE_ASSERTIONS=ON \
   #
 %cmake_build
 
@@ -206,6 +266,7 @@ rm -fv %{buildroot}%{_libdir}/*.a
 (cd %{buildroot}%{pkg_prefix}/%{_lib}/python*/site-packages/lldb/
  ln -vsf "$(dirname $(readlink _lldb.so))/$(readlink $(readlink _lldb.so))" _lldb.so
 )
+du -shc $PWD %{buildroot}
 
 %files
 %{_bindir}/lldb-experimental
@@ -218,12 +279,11 @@ rm -fv %{buildroot}%{_libdir}/*.a
 # RHEL-7: File not found by glob: .../lib{lldb,clang,LLVM}*.so.*
 %{pkg_prefix}/%{_lib}/libl*.so.*
 %{pkg_prefix}/%{_lib}/python*
+%{pkg_prefix}/%{_lib}/lib[^l]*.so.*
 
 %files devel
 %{pkg_prefix}/include
-%{pkg_prefix}/%{_lib}/lib[^l]*.so.*
 %{pkg_prefix}/%{_lib}/*.so
-%{pkg_prefix}/%{_lib}/*.a
 
 %changelog
 * Thu Apr  5 2018 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.0-0.1