(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 1a0fb82..dbabe50 100644 (file)
@@ -1,6 +1,10 @@
 %global fast 0
 %global use_jankratochvil_dwz 1
+# FIXME:
+%global use_jankratochvil_layout5 0
+%global use_jankratochvil_ocaml_doc 1
 %global use_jankratochvil_rust 0
+%global use_nealsid_lldb_editline_remove_wchar 0
 %global pkg_prefix /opt/%{name}
 %global _unpackaged_files_terminate_build 0
 # dwz: Couldn't find DIE referenced by DW_OP_GNU_parameter_ref
 %global debug_package %{nil}
 %endif
 Name: lldb-experimental
-Version: 13.0.0
-Release: 0.20210212snap0%{?dist}
+Version: 14.0.0
+Release: 0.20210922snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
 ExclusiveArch: x86_64
-BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
+# Source zero not found
+# https://bugzilla.redhat.com/show_bug.cgi?id=1938320
+Source0: empty.tar
+BuildRequires: clang git libedit-devel libatomic libxml2-devel zlib-devel valgrind-devel libpfm-devel
 # https://src.fedoraproject.org/rpms/epydoc
 #BuildRequires: epydoc
+%if 0%{?rhel} > 8 || 0%{?fedora} >= 34
+BuildRequires:  ocaml-findlib ocaml-ctypes ocaml-ocamldoc
+%endif
 %if 0%{?rhel:1} && 0%{?rhel} <= 7
 #+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
 #Compiling /quad/home/jkratoch/redhat/lldb-experimental/BUILDROOT/lldb-experimental-13.0.0-0.20210206snap1.el7.x86_64/opt/lldb-experimental/lib64/python3.8/site-packages/lldb/__init__.py ...
@@ -33,7 +43,7 @@ BuildRequires: gcc-c++ git libedit-devel libatomic libxml2-devel zlib-devel valg
 #                      ^
 #SyntaxError: invalid syntax
 %global __python /usr/bin/python3
-BuildRequires: devtoolset-8-gcc-c++
+BuildRequires: llvm-toolset-7.0-clang llvm-toolset-7.0-lld
 # swig on rhel7: /builddir/build/BUILD/lldb-experimental-11.0.0/lldb/bindings/./python/python-typemaps.swig:496: Error: Syntax error in input(3).
 BuildRequires: swig3
 BuildRequires: rh-git218-git-core
@@ -44,6 +54,7 @@ BuildRequires: cmake3
 %global cmake_build %{cmake3_build}
 %global cmake_install %{cmake3_install}
 %else
+BuildRequires: lld
 # FIXME: CentOS-8:
 # CMake Error at CMakeLists.txt:3 (cmake_minimum_required):
 #   CMake 3.13.4 or higher is required.  You are running version 3.11.4
@@ -84,10 +95,22 @@ This package is an experimental trunk snapshot.
 This package contains off-trunk DWZ support for Fedora debuginfos such as:
   unsupported DW_FORM values: 0x1f20 0x1f21
 %endif
+%if %{use_jankratochvil_layout5}
+This package contains off-trunk:
+  Support for libstdc++11 std::unique_ptr: [[no_unique_address]]
+%endif
+%if %{use_jankratochvil_ocaml_doc}
+This package contains off-trunk:
+  ocaml_doc fix
+%endif
 %if %{use_jankratochvil_rust}
 This package contains off-trunk Rust support:
   https://github.com/rust-lang-nursery/lldb
 %endif
+%if %{use_nealsid_lldb_editline_remove_wchar}
+This package contains:
+  https://github.com/nealsid/llvm-project/tree/lldb-editline-remove-wchar
+%endif
 
 %package devel
 Summary: Development header files for %{name}
@@ -155,7 +178,7 @@ CLONEOPTS="--single-branch"
 test -d ../$REF/ && CLONEOPTS="$CLONEOPTS --reference ../$REF"
 # 2500 = 1 month in 2019
 git clone $OPTS $CLONEOPTS https://github.com/llvm/llvm-project.git .
-%if %{use_jankratochvil_dwz} || %{use_jankratochvil_rust}
+%if 1
 git remote remove jankratochvil || :
 #git remote add jankratochvil git://git.jankratochvil.net/lldb
 git remote add jankratochvil https://github.com/jankratochvil/llvm-project.git
@@ -166,11 +189,22 @@ git config user.name jankratochvil
 %if %{use_jankratochvil_dwz}
 git merge jankratochvil/dwz
 %endif
+%if %{use_jankratochvil_layout5}
+git merge jankratochvil/layout5
+%endif
+%if %{use_jankratochvil_ocaml_doc}
+git merge jankratochvil/ocaml_doc
+%endif
 %if %{use_jankratochvil_rust}
 # '-c merge.renames=false' is F-29+.
 # '-c merge.renameLimit=0' has no effect.
 git -c merge.renameLimit=1 merge jankratochvil/rust
 %endif
+%if %{use_nealsid_lldb_editline_remove_wchar}
+git remote add nealsid https://github.com/nealsid/llvm-project.git
+git fetch nealsid
+git merge nealsid/lldb-editline-remove-wchar
+%endif
 
 %build
 FLAGS="%{optflags}"
@@ -179,7 +213,7 @@ FLAGS="%{optflags}"
 FLAGS="$FLAGS -Wno-error=format-security"
 
 %if (0%{?rhel:1} && 0%{?rhel} <= 7)
-. /opt/rh/devtoolset-8/enable
+. /opt/rh/llvm-toolset-7.0/enable
 . /opt/rh/rh-python38/enable
 %endif
 %if %{fast}
@@ -188,18 +222,38 @@ FLAGS="$FLAGS -g0"
 # -fno-reorder-blocks-and-partition:
 # -gsplit-dwarf: Error: can't resolve `.text.unlikely' - `.LVL414'
 # https://bugzilla.redhat.com/show_bug.cgi?id=1573647
+%if 0%{?fedora} != 35
 FLAGS="$FLAGS -fdebug-types-section"
 %endif
+%endif
 
-CFLAGS="$FLAGS"
-CXXFLAGS="$FLAGS"
+# clang-12: error: unsupported argument 'auto' to option 'flto='
+# clang-12: warning: optimization flag '-ffat-lto-objects' is not supported [-Wignored-optimization-argument]
+FLAGS="$(echo $FLAGS|sed 's/ -flto=auto -ffat-lto-objects / -flto /')"
+# ld.lld: error: relocation R_X86_64_PC32 cannot be used against symbol ...; recompile with -fPIC
+FLAGS="$FLAGS -fPIC"
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+# clang: error: unknown argument: '-fstack-protector-strong'
+FLAGS="$(echo $FLAGS|sed 's/ -fstack-protector-strong / /')"
+%endif
+
+export CFLAGS="$FLAGS"
+export CXXFLAGS="$FLAGS"
+
+export LDFLAGS="%{build_ldflags}"
+LDFLAGS="$LDFLAGS -flto -Wl,--build-id=sha1"
 
 # This is default - changing it breaks the testsuite: -DLLVM_LINK_LLVM_DYLIB=OFF
 # It does not work: -DDCMAKE_EXECUTABLE_SUFFIX=-experimental
-# -fdebug-types-section && -DLLVM_USE_LINKER=gold:
-# ../../../../lib64/libclangLex.a(PreprocessingRecord.cpp.o)(.debug_types+0xfe): error: undefined reference to 'clang::SourceRange::getBegin() const'
 %cmake llvm \
   -DCMAKE_INSTALL_PREFIX=%{pkg_prefix} \
+  -DCMAKE_C_COMPILER=clang \
+  -DCMAKE_CXX_COMPILER=clang++ \
+%if 0%{?rhel:1} && 0%{?rhel} <= 7
+  -DLLVM_USE_LINKER=gold \
+%else
+  -DLLVM_USE_LINKER=lld \
+%endif
 %if %{fast}
   -DCMAKE_BUILD_TYPE=Release \
 %else
@@ -208,7 +262,6 @@ CXXFLAGS="$FLAGS"
   -DLLVM_ENABLE_PROJECTS="lldb;clang;lld" \
   -DLLVM_TARGETS_TO_BUILD=X86 \
   -DLLVM_BUILD_TOOLS=OFF \
-  -DLLVM_USE_LINKER=gold \
   $(: file INSTALL cannot find build-release/lib/python3.6 ) \
 %if 0%{?__isa_bits} == 64
   -DLLVM_LIBDIR_SUFFIX=64 \
@@ -218,13 +271,14 @@ CXXFLAGS="$FLAGS"
   -DLLDB_DISABLE_CURSES=OFF \
   -DLLDB_DISABLE_LIBEDIT=OFF \
   -DLLDB_DISABLE_PYTHON=OFF \
+  -DLLVM_ENABLE_ASSERTIONS=ON \
   #
 %cmake_build
 
 %install
 mkdir -p %{buildroot}%{pkg_prefix}
 (function revline {
-   echo "$(cd $1;git rev-parse ${2:-origin/master}) ${2:-$1}"
+   echo "$(cd $1;git rev-parse ${2:-origin/main}) ${2:-$1}"
  }
  revline .
 %if %{use_jankratochvil_dwz}
@@ -233,7 +287,7 @@ mkdir -p %{buildroot}%{pkg_prefix}
 %if %{use_jankratochvil_rust}
  revline . jankratochvil/rust
 %endif
-) >%{buildroot}%{pkg_prefix}/HEAD
+) >%{buildroot}%{pkg_prefix}/commit
 %cmake_install
 mkdir -p %{buildroot}%{_bindir}
 # lldb-mi
@@ -254,7 +308,7 @@ du -shc $PWD %{buildroot}
 %files
 %{_bindir}/lldb-experimental
 #{_bindir}/lldb-mi-experimental
-%{pkg_prefix}/HEAD
+%{pkg_prefix}/commit
 %{pkg_prefix}/bin/lldb
 %{pkg_prefix}/bin/lldb-server
 #{pkg_prefix}/bin/lldb-mi