(no commit message)
[lldb-experimental.git] / lldb-experimental.spec
index 4bcea20..dbabe50 100644 (file)
@@ -1,8 +1,10 @@
 %global fast 0
 %global use_jankratochvil_dwz 1
-%global use_jankratochvil_uniqaddr 1
+# FIXME:
+%global use_jankratochvil_layout5 0
 %global use_jankratochvil_ocaml_doc 1
 %global use_jankratochvil_rust 0
+%global use_nealsid_lldb_editline_remove_wchar 0
 %global pkg_prefix /opt/%{name}
 %global _unpackaged_files_terminate_build 0
 # dwz: Couldn't find DIE referenced by DW_OP_GNU_parameter_ref
@@ -18,8 +20,8 @@
 %global debug_package %{nil}
 %endif
 Name: lldb-experimental
-Version: 13.0.0
-Release: 0.20210610snap1%{?dist}
+Version: 14.0.0
+Release: 0.20210922snap0%{?dist}
 Summary: Next generation high-performance debugger - experimental trunk snapshot
 License: NCSA
 URL: http://lldb.llvm.org/
@@ -93,7 +95,7 @@ This package is an experimental trunk snapshot.
 This package contains off-trunk DWZ support for Fedora debuginfos such as:
   unsupported DW_FORM values: 0x1f20 0x1f21
 %endif
-%if %{use_jankratochvil_uniqaddr}
+%if %{use_jankratochvil_layout5}
 This package contains off-trunk:
   Support for libstdc++11 std::unique_ptr: [[no_unique_address]]
 %endif
@@ -105,6 +107,10 @@ This package contains off-trunk:
 This package contains off-trunk Rust support:
   https://github.com/rust-lang-nursery/lldb
 %endif
+%if %{use_nealsid_lldb_editline_remove_wchar}
+This package contains:
+  https://github.com/nealsid/llvm-project/tree/lldb-editline-remove-wchar
+%endif
 
 %package devel
 Summary: Development header files for %{name}
@@ -183,7 +189,7 @@ git config user.name jankratochvil
 %if %{use_jankratochvil_dwz}
 git merge jankratochvil/dwz
 %endif
-%if %{use_jankratochvil_uniqaddr}
+%if %{use_jankratochvil_layout5}
 git merge jankratochvil/layout5
 %endif
 %if %{use_jankratochvil_ocaml_doc}
@@ -194,6 +200,11 @@ git merge jankratochvil/ocaml_doc
 # '-c merge.renameLimit=0' has no effect.
 git -c merge.renameLimit=1 merge jankratochvil/rust
 %endif
+%if %{use_nealsid_lldb_editline_remove_wchar}
+git remote add nealsid https://github.com/nealsid/llvm-project.git
+git fetch nealsid
+git merge nealsid/lldb-editline-remove-wchar
+%endif
 
 %build
 FLAGS="%{optflags}"
@@ -276,7 +287,7 @@ mkdir -p %{buildroot}%{pkg_prefix}
 %if %{use_jankratochvil_rust}
  revline . jankratochvil/rust
 %endif
-) >%{buildroot}%{pkg_prefix}/HEAD
+) >%{buildroot}%{pkg_prefix}/commit
 %cmake_install
 mkdir -p %{buildroot}%{_bindir}
 # lldb-mi
@@ -297,7 +308,7 @@ du -shc $PWD %{buildroot}
 %files
 %{_bindir}/lldb-experimental
 #{_bindir}/lldb-mi-experimental
-%{pkg_prefix}/HEAD
+%{pkg_prefix}/commit
 %{pkg_prefix}/bin/lldb
 %{pkg_prefix}/bin/lldb-server
 #{pkg_prefix}/bin/lldb-mi