[llgo] update libgo-llgo.so version to match libtool_VERSION
authorAndrew Wilkins <axwalk@gmail.com>
Wed, 15 Jul 2015 13:17:04 +0000 (13:17 +0000)
committerAndrew Wilkins <axwalk@gmail.com>
Wed, 15 Jul 2015 13:17:04 +0000 (13:17 +0000)
Summary:
libtool_VERSION was changed in gofrontend a while ago,
but CMakeLists.txt in llgo wasn't updated, and so the
install target fails. Not sure how this went unnoticed
for so long.

Reviewers: pcc

Subscribers: llvm-commits

Differential Revision: http://reviews.llvm.org/D11118

llvm-svn: 242291

llgo/CMakeLists.txt

index 8c68eac..356f00d 100644 (file)
@@ -234,8 +234,8 @@ set(LLGO_LIBRARY_DIR ${CMAKE_BINARY_DIR}/lib${LLVM_LIBDIR_SUFFIX})
 
 install(FILES ${LLGO_LIBRARY_DIR}/libgo-llgo.a
               ${LLGO_LIBRARY_DIR}/libgo-llgo.so
-              ${LLGO_LIBRARY_DIR}/libgo-llgo.so.6
-              ${LLGO_LIBRARY_DIR}/libgo-llgo.so.6.0.0
+              ${LLGO_LIBRARY_DIR}/libgo-llgo.so.7
+              ${LLGO_LIBRARY_DIR}/libgo-llgo.so.7.0.0
               ${LLGO_LIBRARY_DIR}/libgobegin-llgo.a
         DESTINATION lib${LLVM_LIBDIR_SUFFIX})