glibc-2.2.2-10_staticnss -> glibc-2.2.2-10_staticnss
[nethome.git] / src / rpm / SPECS / glibc.spec
index 5bdcb32..c105476 100644 (file)
@@ -1,9 +1,9 @@
 %define glibcrelease 10
-%define auxarches i586 i686 athlon sparcv9 alphaev6
+%define auxarches sparcv9 alphaev6
 Summary: The GNU libc libraries.
 Name: glibc
 Version: 2.2.2
-Release: %{glibcrelease}
+Release: %{glibcrelease}_staticnss
 Copyright: LGPL
 Group: System Environment/Libraries
 Source: %{name}-%{version}.tar.bz2
@@ -168,8 +168,9 @@ EnableKernel="--enable-kernel=%{enablekernel}"
 EnableKernel="$EnableKernel --disable-profile"
 %endif
 echo "$BuildFlags" > ../BuildFlags
-CC="$GCC" CFLAGS="$BuildFlags -g -O3" ../configure --prefix=%{_prefix} \
+CC="$GCC -Lnss -Lbuild-%{_target_cpu}-linux/nss" CFLAGS="$BuildFlags -g -O3" ../configure --prefix=%{_prefix} \
        --enable-add-ons=yes --without-cvs $EnableKernel \
+       --enable-static-nss \
        %{_target_cpu}-redhat-linux
 if [ -x /usr/bin/getconf ] ; then
   numprocs=$(/usr/bin/getconf _NPROCESSORS_ONLN)
@@ -198,6 +199,7 @@ BuildFlags=`cat ../BuildFlags`
 EnableKernel="--enable-kernel=%{enablekernel2} --disable-profile"
 CC="$GCC" CFLAGS="$BuildFlags -g -O3" ../configure --prefix=%{_prefix} \
        --enable-add-ons=yes --without-cvs $EnableKernel \
+       --enable-static-nss \
        %{_target_cpu}-redhat-linux
 if [ -x /usr/bin/getconf ] ; then
   numprocs=$(/usr/bin/getconf _NPROCESSORS_ONLN)